p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de nodejs · Página 2

Vulnerabilidades publicadas para nodejs en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 62

  1. ALPINE-CVE-2021-22931

    Crítica · CVSS 9.8Corrección disponible

    ALPINE-CVE-2021-22931

    Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to Remote Code Execution, XSS, Application crashes due to missing input validation of host names returned by Domain Name Servers in Node.js dns library which can lead to output of wrong hostnames (leading to Domain Hijacking) and injection vulnerabilities in applications using the library.

    • Actualiza a 14.17.5-r0
    Publicación Actualización
  2. ALPINE-CVE-2021-22918

    Media · CVSS 5.3Corrección disponible

    ALPINE-CVE-2021-22918

    Node.js before 16.4.1, 14.17.2, 12.22.2 is vulnerable to an out-of-bounds read when uv__idna_toascii() is used to convert strings to ASCII. The pointer p is read and increased without checking whether it is beyond pe, with the latter holding a pointer to the end of the buffer. This can lead to information disclosures or crashes. This function can be triggered via uv_getaddrinfo().

    • Actualiza a 14.17.3-r0
    Publicación Actualización
  3. ALPINE-CVE-2021-22884

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2021-22884

    Node.js before 10.24.0, 12.21.0, 14.16.0, and 15.10.0 is vulnerable to DNS rebinding attacks as the whitelist includes “localhost6”. When “localhost6” is not present in /etc/hosts, it is just an ordinary domain that is resolved via DNS, i.e., over network. If the attacker controls the victim's DNS server or can spoof its responses, the DNS rebinding protection can be bypassed by using the “localhost6” domain. As long as the attacker uses the “localhost6” domain, they can still apply the attack described in CVE-2018-7160.

    • Actualiza a 14.16.0-r0
    Publicación Actualización
  4. ALPINE-CVE-2021-22883

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2021-22883

    Node.js before 10.24.0, 12.21.0, 14.16.0, and 15.10.0 is vulnerable to a denial of service attack when too many connection attempts with an 'unknownProtocol' are established. This leads to a leak of file descriptors. If a file descriptor limit is configured on the system, then the server is unable to accept new connections and prevent the process also from opening, e.g. a file. If no file descriptor limit is configured, then this lead to an excessive memory usage and cause the system to run out of memory.

    • Actualiza a 14.16.0-r0
    Publicación Actualización
  5. ALPINE-CVE-2020-8287

    Media · CVSS 6.5Corrección disponible

    ALPINE-CVE-2020-8287

    Node.js versions before 10.23.1, 12.20.1, 14.15.4, 15.5.1 allow two copies of a header field in an HTTP request (for example, two Transfer-Encoding header fields). In this case, Node.js identifies the first header field and ignores the second. This can lead to HTTP Request Smuggling.

    • Actualiza a 14.15.4-r0
    Publicación Actualización
  6. ALPINE-CVE-2020-8265

    Alta · CVSS 8.1Corrección disponible

    ALPINE-CVE-2020-8265

    Node.js versions before 10.23.1, 12.20.1, 14.15.4, 15.5.1 are vulnerable to a use-after-free bug in its TLS implementation. When writing to a TLS enabled socket, node::StreamBase::Write calls node::TLSWrap::DoWrite with a freshly allocated WriteWrap object as first argument. If the DoWrite method does not return an error, this object is passed back to the caller as part of a StreamWriteResult structure. This may be exploited to corrupt memory leading to a Denial of Service or potentially other exploits.

    • Actualiza a 14.15.4-r0
    Publicación Actualización
  7. ALPINE-CVE-2020-8277

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2020-8277

    A Node.js application that allows an attacker to trigger a DNS request for a host of their choice could trigger a Denial of Service in versions < 15.2.1, < 14.15.1, and < 12.19.1 by getting the application to resolve a DNS record with a larger number of responses. This is fixed in 15.2.1, 14.15.1, and 12.19.1.

    • Actualiza a 14.15.1-r0
    Publicación Actualización
  8. ALPINE-CVE-2020-8252

    Alta · CVSS 7.8Corrección disponible

    ALPINE-CVE-2020-8252

    The implementation of realpath in libuv < 10.22.1, < 12.18.4, and < 14.9.0 used within Node.js incorrectly determined the buffer size which can result in a buffer overflow if the resolved path is longer than 256 bytes.

    • Actualiza a 12.18.4-r0
    Publicación Actualización
  9. ALPINE-CVE-2020-8201

    Alta · CVSS 7.4Corrección disponible

    ALPINE-CVE-2020-8201

    Node.js < 12.18.4 and < 14.11 can be exploited to perform HTTP desync attacks and deliver malicious payloads to unsuspecting users. The payloads can be crafted by an attacker to hijack user sessions, poison cookies, perform clickjacking, and a multitude of other attacks depending on the architecture of the underlying system. The attack was possible due to a bug in processing of carrier-return symbols in the HTTP header names.

    • Actualiza a 12.18.4-r0
    Publicación Actualización
  10. ALPINE-CVE-2020-11080

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2020-11080

    In nghttp2 before version 1.41.0, the overly large HTTP/2 SETTINGS frame payload causes denial of service. The proof of concept attack involves a malicious client constructing a SETTINGS frame with a length of 14,400 bytes (2400 individual settings entries) over and over again. The attack causes the CPU to spike at 100%. nghttp2 v1.41.0 fixes this vulnerability. There is a workaround to this vulnerability. Implement nghttp2_on_frame_recv_callback callback, and if received frame is SETTINGS frame and the number of settings entries are large (e.g., > 32), then drop the connection.

    • Actualiza a 12.18.0-r0
    Publicación Actualización
  11. ALPINE-CVE-2019-9518

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2019-9518

    Some HTTP/2 implementations are vulnerable to a flood of empty frames, potentially leading to a denial of service. The attacker sends a stream of frames with an empty payload and without the end-of-stream flag. These frames can be DATA, HEADERS, CONTINUATION and/or PUSH_PROMISE. The peer spends time processing each frame disproportionate to attack bandwidth. This can consume excess CPU.

    • Actualiza a 10.16.3-r0
    Publicación Actualización
  12. ALPINE-CVE-2019-9517

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2019-9517

    Some HTTP/2 implementations are vulnerable to unconstrained interal data buffering, potentially leading to a denial of service. The attacker opens the HTTP/2 window so the peer can send without constraint; however, they leave the TCP window closed so the peer cannot actually write (many of) the bytes on the wire. The attacker then sends a stream of requests for a large response object. Depending on how the servers queue the responses, this can consume excess memory, CPU, or both.

    • Actualiza a 10.16.3-r0
    Publicación Actualización
  13. ALPINE-CVE-2019-9516

    Media · CVSS 6.5Corrección disponible

    ALPINE-CVE-2019-9516

    Some HTTP/2 implementations are vulnerable to a header leak, potentially leading to a denial of service. The attacker sends a stream of headers with a 0-length header name and 0-length header value, optionally Huffman encoded into 1-byte or greater headers. Some implementations allocate memory for these headers and keep the allocation alive until the session dies. This can consume excess memory.

    • Actualiza a 10.16.3-r0
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →