p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de ansible · Página 3

Vulnerabilidades publicadas para ansible en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 77

  1. CVE-2020-1739

    Baja · CVSS 3.9EPSS 0,36%Corrección disponible

    CVE-2020-1739

    A flaw was found in Ansible 2.7.16 and prior, 2.8.8 and prior, and 2.9.5 and prior when a password is set with the argument "password" of svn module, it is used on svn command line, disclosing to other users within the same node. An attacker could take advantage by reading the cmdline file from that particular PID on the procfs.

    • Actualiza a 2.9.7+dfsg-1
    Publicación Actualización
  2. CVE-2020-1733

    Media · CVSS 5EPSS 0,4%Corrección disponible

    CVE-2020-1733

    A race condition flaw was found in Ansible Engine 2.7.17 and prior, 2.8.9 and prior, 2.9.6 and prior when running a playbook with an unprivileged become user. When Ansible needs to run a module with become user, the temporary directory is created in /var/tmp. This directory is created with "umask 77 && mkdir -p <dir>"; this operation does not fail if the directory already exists and is owned by another user. An attacker could take advantage to gain control of the become user as the target directory can be retrieved by iterating '/proc/<pid>/cmdline'.

    • Actualiza a 2.9.7+dfsg-1
    Publicación Actualización
  3. CVE-2020-1737

    Alta · CVSS 7.5EPSS 0,36%Corrección disponible

    CVE-2020-1737

    A flaw was found in Ansible 2.7.17 and prior, 2.8.9 and prior, and 2.9.6 and prior when using the Extract-Zip function from the win_unzip module as the extracted file(s) are not checked if they belong to the destination folder. An attacker could take advantage of this flaw by crafting an archive anywhere in the file system, using a path traversal. This issue is fixed in 2.10.

    • Actualiza a 2.9.7+dfsg-1
    Publicación Actualización
  4. CVE-2020-1734

    Alta · CVSS 7.4EPSS 0,46%Sin corrección publicada

    CVE-2020-1734

    A flaw was found in the pipe lookup plugin of ansible. Arbitrary commands can be run, when the pipe lookup plugin uses subprocess.Popen() with shell=True, by overwriting ansible facts and the variable is not escaped by quote plugin. An attacker could take advantage and run arbitrary commands by overwriting the ansible facts.

    Publicación Actualización
  5. CVE-2014-4678

    Crítica · CVSS 9.8EPSS 5,24%Corrección disponible

    CVE-2014-4678

    The safe_eval function in Ansible before 1.6.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-4657.

    • Actualiza a 1.6.6+dfsg-1
    Publicación Actualización
  6. CVE-2014-4660

    Media · CVSS 6.8EPSS 0,38%Corrección disponible

    CVE-2014-4660

    Ansible before 1.5.5 constructs filenames containing user and password fields on the basis of deb lines in sources.list, which might allow local users to obtain sensitive credential information in opportunistic circumstances by leveraging existence of a file that uses the "deb http://user:pass@server:port/" format.

    • Actualiza a 1.5.5+dfsg-1
    Publicación Actualización
  7. CVE-2014-4967

    Crítica · CVSS 9.8EPSS 3,55%Corrección disponible

    CVE-2014-4967

    Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow remote attackers to execute arbitrary code by leveraging access to an Ansible managed host and providing a crafted fact, as demonstrated by a fact with (1) a trailing " src=" clause, (2) a trailing " temp=" clause, or (3) a trailing " validate=" clause accompanied by a shell command.

    • Actualiza a 1.6.8+dfsg-1
    Publicación Actualización
  8. CVE-2014-4966

    Crítica · CVSS 9.8EPSS 3,55%Corrección disponible

    CVE-2014-4966

    Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings, and does not prevent remote data with "{{" substrings, which allows remote attackers to execute arbitrary code via (1) crafted lookup('pipe') calls or (2) crafted Jinja2 data.

    • Actualiza a 1.6.8+dfsg-1
    Publicación Actualización
  9. CVE-2019-14864

    Media · CVSS 5.7EPSS 1,87%Corrección disponible

    CVE-2019-14864

    Ansible, versions 2.9.x before 2.9.1, 2.8.x before 2.8.7 and Ansible versions 2.7.x before 2.7.15, is not respecting the flag no_log set it to True when Sumologic and Splunk callback plugins are used send tasks results events to collectors. This would discloses and collects any sensitive data.

    • Actualiza a 2.9.2+dfsg-1
    Publicación Actualización
  10. CVE-2019-10217

    Media · CVSS 5.7EPSS 1,87%Corrección disponible

    CVE-2019-10217

    A flaw was found in ansible 2.8.0 before 2.8.4. Fields managing sensitive data should be set as such by no_log feature. Some of these fields in GCP modules are not set properly. service_account_contents() which is common class for all gcp modules is not setting no_log to True. Any sensitive data managed by that function would be leak as an output when running ansible playbooks.

    • Actualiza a 2.8.6+dfsg-1
    Publicación Actualización
  11. CVE-2019-10206

    Media · CVSS 6.4EPSS 1,52%Corrección disponible

    CVE-2019-10206

    ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt passwords by expanding them from templates as they could contain special characters. Passwords should be wrapped to prevent templates trigger and exposing them.

    • Actualiza a 2.8.6+dfsg-1
    Publicación Actualización
  12. CVE-2019-14858

    Alta · CVSS 7.3EPSS 0,42%Corrección disponible

    CVE-2019-14858

    A vulnerability was found in Ansible engine 2.x up to 2.8 and Ansible tower 3.x up to 3.5. When a module has an argument_spec with sub parameters marked as no_log, passing an invalid parameter name to the module will cause the task to fail before the no_log options in the sub parameters are processed. As a result, data in the sub parameter fields will not be masked and will be displayed if Ansible is run with increased verbosity and present in the module invocation arguments for the task.

    • Actualiza a 2.8.6+dfsg-1
    Publicación Actualización
  13. CVE-2019-14846

    Alta · CVSS 7.3EPSS 0,51%Corrección disponible

    CVE-2019-14846

    In Ansible, all Ansible Engine versions up to ansible-engine 2.8.5, ansible-engine 2.7.13, ansible-engine 2.6.19, were logging at the DEBUG level which lead to a disclosure of credentials if a plugin used a library that logged credentials at the DEBUG level. This flaw does not affect Ansible modules, as those are executed in a separate process.

    • Actualiza a 2.8.6+dfsg-1
    Publicación Actualización
  14. CVE-2019-10156

    Media · CVSS 4.6EPSS 1,77%Corrección disponible

    CVE-2019-10156

    A flaw was discovered in the way Ansible templating was implemented in versions before 2.6.18, 2.7.12 and 2.8.2, causing the possibility of information disclosure through unexpected variable substitution. By taking advantage of unintended variable substitution the content of any variable may be disclosed.

    • Actualiza a 2.8.3+dfsg-1
    Publicación Actualización
  15. CVE-2019-3828

    Media · CVSS 4.2EPSS 0,53%Corrección disponible

    CVE-2019-3828

    Ansible fetch module before versions 2.5.15, 2.6.14, 2.7.8 has a path traversal vulnerability which allows copying and overwriting files outside of the specified destination in the local ansible controller host, by not restricting an absolute path.

    • Actualiza a 2.7.7+dfsg-1
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →