p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de webkit2gtk · Página 38

Vulnerabilidades publicadas para webkit2gtk en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 960

  1. CVE-2019-6215

    Alta · CVSS 8.8EPSS 9,75%Código de explotación públicoCorrección disponible

    CVE-2019-6215

    A type confusion issue was addressed with improved memory handling. This issue is fixed in iOS 12.1.3, tvOS 12.1.2, Safari 12.0.3, iTunes 12.9.3 for Windows, iCloud for Windows 7.10. Processing maliciously crafted web content may lead to arbitrary code execution.

    • Actualiza a 2.22.6-1
    Publicación Actualización
  2. CVE-2019-6212

    Alta · CVSS 8.8EPSS 1,86%Corrección disponible

    CVE-2019-6212

    Multiple memory corruption issues were addressed with improved memory handling. This issue is fixed in iOS 12.1.3, tvOS 12.1.2, Safari 12.0.3, iTunes 12.9.3 for Windows, iCloud for Windows 7.10. Processing maliciously crafted web content may lead to arbitrary code execution.

    • Actualiza a 2.22.6-1
    Publicación Actualización
  3. CVE-2019-8375

    Crítica · CVSS 9.8EPSS 15,7%Código de explotación públicoCorrección disponible

    CVE-2019-8375

    The UIProcess subsystem in WebKit, as used in WebKitGTK through 2.23.90 and WebKitGTK+ through 2.22.6 and other products, does not prevent the script dialog size from exceeding the web view size, which allows remote attackers to cause a denial of service (Buffer Overflow) or possibly have unspecified other impact, related to UIProcess/API/gtk/WebKitScriptDialogGtk.cpp, UIProcess/API/gtk/WebKitScriptDialogImpl.cpp, and UIProcess/API/gtk/WebKitWebViewGtk.cpp, as demonstrated by GNOME Web (aka Epiphany).

    • Actualiza a 2.24.1-1
    Publicación Actualización
  4. CVE-2019-6251

    Alta · CVSS 8.1EPSS 4,26%Corrección disponible

    CVE-2019-6251

    WebKitGTK and WPE WebKit prior to version 2.24.1 are vulnerable to address bar spoofing upon certain JavaScript redirections. An attacker could cause malicious web content to be displayed as if for a trusted URI. This is similar to the CVE-2018-8383 issue in Microsoft Edge.

    • Actualiza a 2.24.1-1
    Publicación Actualización
  5. CVE-2018-4278

    Media · CVSS 4.3EPSS 2,28%Corrección disponible

    CVE-2018-4278

    In Safari before 11.1.2, iTunes before 12.8 for Windows, iOS before 11.4.1, tvOS before 11.4.1, iCloud for Windows before 7.6, sound fetched through audio elements may be exfiltrated cross-origin. This issue was addressed with improved audio taint tracking.

    • Actualiza a 2.20.4-1
    Publicación Actualización
  6. CVE-2018-12293

    Alta · CVSS 8.8EPSS 10,03%Código de explotación públicoCorrección disponible

    CVE-2018-12293

    The getImageData function in the ImageBufferCairo class in WebCore/platform/graphics/cairo/ImageBufferCairo.cpp in WebKit, as used in WebKitGTK+ prior to version 2.20.3 and WPE WebKit prior to version 2.20.1, is vulnerable to a heap-based buffer overflow triggered by an integer overflow, which could be abused by crafted HTML content.

    • Actualiza a 2.20.3-1
    Publicación Actualización
  7. CVE-2018-4246

    Alta · CVSS 8.8EPSS 2,97%Corrección disponible

    CVE-2018-4246

    An issue was discovered in certain Apple products. iOS before 11.4 is affected. Safari before 11.1.1 is affected. iCloud before 7.5 on Windows is affected. iTunes before 12.7.5 on Windows is affected. tvOS before 11.4 is affected. watchOS before 4.3.1 is affected. The issue involves the "WebKit" component. It allows remote attackers to execute arbitrary code via a crafted web site that leverages type confusion.

    • Actualiza a 2.20.4-1
    Publicación Actualización
  8. CVE-2018-4233

    Alta · CVSS 8.8EPSS 53,82%Código de explotación públicoCorrección disponible

    CVE-2018-4233

    An issue was discovered in certain Apple products. iOS before 11.4 is affected. Safari before 11.1.1 is affected. iCloud before 7.5 on Windows is affected. iTunes before 12.7.5 on Windows is affected. tvOS before 11.4 is affected. watchOS before 4.3.1 is affected. The issue involves the "WebKit" component. It allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site.

    • Actualiza a 2.20.3-1
    Publicación Actualización
  9. CVE-2018-4232

    Media · CVSS 4.3EPSS 2,08%Corrección disponible

    CVE-2018-4232

    An issue was discovered in certain Apple products. iOS before 11.4 is affected. Safari before 11.1.1 is affected. iCloud before 7.5 on Windows is affected. iTunes before 12.7.5 on Windows is affected. tvOS before 11.4 is affected. The issue involves the "WebKit" component. It allows remote attackers to overwrite cookies via a crafted web site.

    • Actualiza a 2.20.3-1
    Publicación Actualización
  10. CVE-2018-4222

    Alta · CVSS 8.8EPSS 10,17%Código de explotación públicoCorrección disponible

    CVE-2018-4222

    An issue was discovered in certain Apple products. iOS before 11.4 is affected. Safari before 11.1.1 is affected. iCloud before 7.5 on Windows is affected. iTunes before 12.7.5 on Windows is affected. tvOS before 11.4 is affected. watchOS before 4.3.1 is affected. The issue involves the "WebKit" component. It allows remote attackers to execute arbitrary code via a crafted web site that leverages a getWasmBufferFromValue out-of-bounds read during WebAssembly compilation.

    • Actualiza a 2.20.3-1
    Publicación Actualización
  11. CVE-2018-4218

    Alta · CVSS 8.8EPSS 9,05%Código de explotación públicoCorrección disponible

    CVE-2018-4218

    An issue was discovered in certain Apple products. iOS before 11.4 is affected. Safari before 11.1.1 is affected. iCloud before 7.5 on Windows is affected. iTunes before 12.7.5 on Windows is affected. tvOS before 11.4 is affected. watchOS before 4.3.1 is affected. The issue involves the "WebKit" component. It allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site that triggers an @generatorState use-after-free.

    • Actualiza a 2.20.3-1
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →