p PatchFirst

PatchFirst · Vulnerabilidades recientes

flowise-components 3.0.13: vulnerabilidades conocidas · Página 2

Vulnerabilidades conocidas que afectan a flowise-components 3.0.13: 27. Compara las versiones corregidas de abajo con la que tienes instalada.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 27

  1. CVE-2026-41271

    Alta · CVSS 7.1EPSS 0,23%Corrección disponible

    Flowise: APIChain Prompt Injection SSRF in GET/POST API Chains

    Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, a Server-Side Request Forgery (SSRF) vulnerability exists in FlowiseAI's POST/GET API Chain components that allows unauthenticated attackers to force the server to make arbitrary HTTP requests to internal and external systems. By injecting malicious prompt templates, attackers can bypass the intended API documentation constraints and redirect requests to sensitive internal services, potentially leading to internal network reconnaissance and data exfiltration. This vulnerability is fixed in 3.1.0.

    • Actualiza a 3.1.0
    Publicación Actualización
  2. CVE-2026-41272

    Alta · CVSS 7.1EPSS 0,26%Corrección disponible

    Flowise: SSRF Protection Bypass (TOCTOU & Default Insecure)

    Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, the core security wrappers (secureAxiosRequest and secureFetch) intended to prevent Server-Side Request Forgery (SSRF) contain multiple logic flaws. These flaws allow attackers to bypass the allow/deny lists via DNS Rebinding (Time-of-Check Time-of-Use) or by exploiting the default configuration which fails to enforce any deny list. This vulnerability is fixed in 3.1.0.

    • Actualiza a 3.1.0
    Publicación Actualización
  3. CVE-2026-41270

    Alta · CVSS 7.1EPSS 0,23%Corrección disponible

    Flowise: SSRF Protection Bypass via Unprotected Built-in HTTP Modules in Custom Function Sandbox

    Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, a Server-Side Request Forgery (SSRF) protection bypass vulnerability exists in the Custom Function feature. While the application implements SSRF protection via HTTP_DENY_LIST for axios and node-fetch libraries, the built-in Node.js http, https, and net modules are allowed in the NodeVM sandbox without equivalent protection. This allows authenticated users to bypass SSRF controls and access internal network resources (e.g., cloud provider metadata services) This vulnerability is fixed in 3.1.0.

    • Actualiza a 3.1.0
    Publicación Actualización
  4. CVE-2026-41268

    Alta · CVSS 7.7EPSS 17,44%Corrección disponible

    Flowise: Flowise Parameter Override Bypass Remote Command Execution

    Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, Flowise is vulnerable to a critical unauthenticated remote command execution (RCE) vulnerability. It can be exploited via a parameter override bypass using the FILE-STORAGE:: keyword combined with a NODE_OPTIONS environment variable injection. This allows for the execution of arbitrary system commands with root privileges within the containerized Flowise instance, requiring only a single HTTP request and no authentication or knowledge of the instance. This vulnerability is fixed in 3.1.0.

    • Actualiza a 3.1.0
    Publicación Actualización
  5. CVE-2026-41137

    Crítica · CVSS 9.4EPSS 1,45%Corrección disponible

    Flowise: Code Injection in CSVAgent leads to Authenticated RCE

    Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, The CSVAgent allows providing a custom Pandas CSV read code. Due to lack of sanitization, an attacker can provide a command injection payload that will get interpolated and executed by the server. This vulnerability is fixed in 3.1.0.

    • Actualiza a 3.1.0
    Publicación Actualización
  6. CVE-2026-41138

    Alta · CVSS 8.3EPSS 0,6%Corrección disponible

    Flowise: Remote code execution vulnerability in AirtableAgent.ts caused by lack of input verification when using Pandas.

    Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, there is a remote code execution vulnerability in AirtableAgent.ts caused by lack of input verification when using Pandas. The user’s input is directly applied to the question parameter within the prompt template and it is reflected to the Python code without any sanitization. This vulnerability is fixed in 3.1.0.

    • Actualiza a 3.1.0
    Publicación Actualización
  7. CVE-2026-40933

    Crítica · CVSS 10.0EPSS 11,96%Corrección disponible

    Flowise: Authenticated RCE Via MCP Adapters

    Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, due to unsafe serialization of stdio commands in the MCP adapter, an authenticated attacker can add an MCP stdio server with an arbitrary command, achieving command execution. The vulnerability lies in a bug in the input sanitization from the “Custom MCP” configuration in http://localhost:3000/canvas - where any user can add a new MCP, when doing so - adding a new MCP using stdio, the user can add any command, even though your code have input sanitization checks such as validateCommandInjection and validateArgsForLocalFileAccess, and a lis

    • Actualiza a 3.1.0
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →