p PatchFirst

PatchFirst · Vulnerabilidades recientes

flowise 3.0.8: vulnerabilidades conocidas · Página 5

Vulnerabilidades conocidas que afectan a flowise 3.0.8: 82. Compara las versiones corregidas de abajo con la que tienes instalada.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 82

  1. CVE-2026-30821

    Alta · CVSS 8.2EPSS 15,24%Corrección disponible

    Flowise: Arbitrary File Upload via MIME Spoofing

    Flowise is a drag & drop user interface to build a customized large language model flow. Prior to version 3.0.13, the /api/v1/attachments/:chatflowId/:chatId endpoint is listed in WHITELIST_URLS, allowing unauthenticated access to the file upload API. While the server validates uploads based on the MIME types defined in chatbotConfig.fullFileUpload.allowedUploadFileTypes, it implicitly trusts the client-provided Content-Type header (file.mimetype) without verifying the file's actual content (magic bytes) or extension (file.originalname). Consequently, an attacker can bypass this restriction by spoofing the Content-Type as a permitted type (e.

    • Actualiza a 3.0.13
    Publicación Actualización
  2. CVE-2026-30820

    Alta · CVSS 8.7EPSS 0,5%Corrección disponible

    Flowise Authorization Bypass via Spoofed x-request-from Header

    Flowise is a drag & drop user interface to build a customized large language model flow. Prior to version 3.0.13, Flowise trusts any HTTP client that sets the header x-request-from: internal, allowing an authenticated tenant session to bypass all /api/v1/** authorization checks. With only a browser cookie, a low-privilege tenant can invoke internal administration endpoints (API key management, credential stores, custom function execution, etc.), effectively escalating privilege. This issue has been patched in version 3.0.13.

    • Actualiza a 3.0.13
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →