p PatchFirst

PatchFirst · Vulnerabilidades recientes

undici 7.5.0: vulnerabilidades conocidas · Página 2

Vulnerabilidades conocidas que afectan a undici 7.5.0: 27. Compara las versiones corregidas de abajo con la que tienes instalada.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 27

  1. CVE-2026-12151

    Alta · CVSS 7.5EPSS 0,79%Corrección disponible

    undici WebSocket client vulnerable to denial of service via fragment count bypass

    Impact: The undici WebSocket client enforces maxPayloadSize on the cumulative byte count of fragments in a message but does not enforce a limit on the number of fragments. A malicious WebSocket server can stream many small or empty continuation frames that each pass per-frame and cumulative-size validation, collectively causing unbounded memory growth in the client process. The result is memory exhaustion and a denial of service. Affected applications are those using the undici WebSocket client (new WebSocket(...)) or the WebSocketStream API that can be induced to connect to an attacker-controlled or compromised WebSocket endpoint. All rele

    • Actualiza a 7.28.0
    Publicación Actualización
  2. CVE-2026-2229

    Alta · CVSS 7.5EPSS 0,91%Corrección disponible

    undici is vulnerable to Unhandled Exception in undici WebSocket Client Due to Invalid server_max_window_bits Validation

    ImpactThe undici WebSocket client is vulnerable to a denial-of-service attack due to improper validation of the server_max_window_bits parameter in the permessage-deflate extension. When a WebSocket client connects to a server, it automatically advertises support for permessage-deflate compression. A malicious server can respond with an out-of-range server_max_window_bits value (outside zlib's valid range of 8-15). When the server subsequently sends a compressed frame, the client attempts to create a zlib InflateRaw instance with the invalid windowBits value, causing a synchronous RangeError exception that is not caught, resulting in immediat

    • Actualiza a 7.24.0
    Publicación Actualización
  3. CVE-2026-1528

    Alta · CVSS 7.5EPSS 0,51%Corrección disponible

    undici is vulnerable to Malicious WebSocket 64-bit length overflows undici parser and crashes the client

    ImpactA server can reply with a WebSocket frame using the 64-bit length form and an extremely large length. undici's ByteParser overflows internal math, ends up in an invalid state, and throws a fatal TypeError that terminates the process. Patches Patched in the undici version v7.24.0 and v6.24.0. Users should upgrade to this version or later.

    • Actualiza a 7.24.0
    Publicación Actualización
  4. CVE-2026-1527

    Media · CVSS 4.6EPSS 0,29%Corrección disponible

    undici is vulnerable to CRLF Injection via upgrade option

    ImpactWhen an application passes user-controlled input to the upgrade option of client.request(), an attacker can inject CRLF sequences (\r\n) to: * Inject arbitrary HTTP headers * Terminate the HTTP request prematurely and smuggle raw data to non-HTTP services (Redis, Memcached, Elasticsearch) The vulnerability exists because undici writes the upgrade value directly to the socket without validating for invalid header characters: // lib/dispatcher/client-h1.js:1121 if (upgrade) { header += `connection: upgrade\r\nupgrade: ${upgrade}\r\n` }

    • Actualiza a 7.24.0
    Publicación Actualización
  5. CVE-2026-1526

    Alta · CVSS 7.5EPSS 1,2%Corrección disponible

    undici is vulnerable to Unbounded Memory Consumption in undici WebSocket permessage-deflate Decompression

    The undici WebSocket client is vulnerable to a denial-of-service attack via unbounded memory consumption during permessage-deflate decompression. When a WebSocket connection negotiates the permessage-deflate extension, the client decompresses incoming compressed frames without enforcing any limit on the decompressed data size. A malicious WebSocket server can send a small compressed frame (a "decompression bomb") that expands to an extremely large size in memory, causing the Node.js process to exhaust available memory and crash or become unresponsive. The vulnerability exists in the PerMessageDeflate.decompress() method, which accumulates al

    • Actualiza a 7.24.0
    Publicación Actualización
  6. CVE-2026-1525

    Media · CVSS 6.5EPSS 0,52%Corrección disponible

    undici is vulnerable to Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling')

    Undici allows duplicate HTTP Content-Length headers when they are provided in an array with case-variant names (e.g., Content-Length and content-length). This produces malformed HTTP/1.1 requests with multiple conflicting Content-Length values on the wire. Who is impacted: * Applications using undici.request(), undici.Client, or similar low-level APIs with headers passed as flat arrays * Applications that accept user-controlled header names without case-normalization Potential consequences: * Denial of Service: Strict HTTP parsers (proxies, servers) will reject requests with duplicate Content-Length headers (400 Bad Request) *

    • Actualiza a 7.24.0
    Publicación Actualización
  7. CVE-2026-22036

    Media · CVSS 5.9EPSS 0,46%Corrección disponible

    Undici has an unbounded decompression chain in HTTP responses on Node.js Fetch API via Content-Encoding leads to resource exhaustion

    Undici is an HTTP/1.1 client for Node.js. Prior to 7.18.0 and 6.23.0, the number of links in the decompression chain is unbounded and the default maxHeaderSize allows a malicious server to insert thousands compression steps leading to high CPU usage and excessive memory allocation. This vulnerability is fixed in 7.18.0 and 6.23.0.

    • Actualiza a 7.18.2
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →