p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de vite · Página 2

Vulnerabilidades publicadas para vite en los últimos 30 días: 6. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 28

  1. CVE-2025-24010

    Media · CVSS 6.5EPSS 0,3%Corrección disponible

    Vite allows any websites to send any requests to the development server and read the response

    Vite is a frontend tooling framework for javascript. Vite allowed any websites to send any requests to the development server and read the response due to default CORS settings and lack of validation on the Origin header for WebSocket connections. This vulnerability is fixed in 6.0.9, 5.4.12, and 4.5.6.

    • Actualiza a 4.5.6
    • Actualiza a 5.4.12
    • Actualiza a 6.0.9
    Publicación Actualización
  2. CVE-2024-45812

    Media · CVSS 6.4EPSS 0,64%Corrección disponible

    DOM Clobbering gadget found in vite bundled scripts that leads to XSS in Vite

    Vite a frontend build tooling framework for javascript. Affected versions of vite were discovered to contain a DOM Clobbering vulnerability when building scripts to `cjs`/`iife`/`umd` output format. The DOM Clobbering gadget in the module can lead to cross-site scripting (XSS) in web pages where scriptless attacker-controlled HTML elements (e.g., an img tag with an unsanitized name attribute) are present. DOM Clobbering is a type of code-reuse attack where the attacker first embeds a piece of non-script, seemingly benign HTML markups in the webpage (e.g. through a post or comment) and leverages the gadgets (pieces of js code) living in the ex

    • Actualiza a 3.2.11
    • Actualiza a 4.5.4
    • Actualiza a 5.1.8
    • Actualiza a 5.2.14
    • Actualiza a 5.3.6
    • Actualiza a 5.4.6
    Publicación Actualización
  3. CVE-2024-45811

    Media · CVSS 4.8EPSS 1,1%Corrección disponible

    server.fs.deny bypassed when using ?import&raw in vite

    Vite a frontend build tooling framework for javascript. In affected versions the contents of arbitrary files can be returned to the browser. `@fs` denies access to files outside of Vite serving allow list. Adding `?import&raw` to the URL bypasses this limitation and returns the file content if it exists. This issue has been patched in versions 5.4.6, 5.3.6, 5.2.14, 4.5.5, and 3.2.11. Users are advised to upgrade. There are no known workarounds for this vulnerability.

    • Actualiza a 3.2.11
    • Actualiza a 4.5.4
    • Actualiza a 5.1.8
    • Actualiza a 5.2.14
    • Actualiza a 5.3.6
    • Actualiza a 5.4.6
    Publicación Actualización
  4. CVE-2024-31207

    Media · CVSS 5.9EPSS 0,71%Corrección disponible

    Vite's `server.fs.deny` did not deny requests for patterns with directories

    Vite (French word for "quick", pronounced /vit/, like "veet") is a frontend build tooling to improve the frontend development experience.`server.fs.deny` does not deny requests for patterns with directories. This vulnerability has been patched in version(s) 5.2.6, 5.1.7, 5.0.13, 4.5.3, 3.2.10 and 2.9.18.

    • Actualiza a 2.9.18
    • Actualiza a 3.2.10
    • Actualiza a 4.5.3
    • Actualiza a 5.0.13
    • Actualiza a 5.1.7
    • Actualiza a 5.2.6
    Publicación Actualización
  5. CVE-2024-23331

    Alta · CVSS 7.5EPSS 0,78%Corrección disponible

    Vite dev server option `server.fs.deny` can be bypassed when hosted on case-insensitive filesystem

    Vite is a frontend tooling framework for javascript. The Vite dev server option `server.fs.deny` can be bypassed on case-insensitive file systems using case-augmented versions of filenames. Notably this affects servers hosted on Windows. This bypass is similar to CVE-2023-34092 -- with surface area reduced to hosts having case-insensitive filesystems. Since `picomatch` defaults to case-sensitive glob matching, but the file server doesn't discriminate; a blacklist bypass is possible. By requesting raw filesystem paths using augmented casing, the matcher derived from `config.server.fs.deny` fails to block access to sensitive files. This issue h

    • Actualiza a 2.9.17
    • Actualiza a 3.2.8
    • Actualiza a 4.5.2
    • Actualiza a 5.0.12
    Publicación Actualización
  6. CVE-2023-49293

    Media · CVSS 6.1EPSS 1%Código de explotación públicoCorrección disponible

    Cross-site Scripting in `server.transformIndexHtml` via URL payload in vite

    Vite is a website frontend framework. When Vite's HTML transformation is invoked manually via `server.transformIndexHtml`, the original request URL is passed in unmodified, and the `html` being transformed contains inline module scripts (`<script type="module">...</script>`), it is possible to inject arbitrary HTML into the transformed output by supplying a malicious URL query string to `server.transformIndexHtml`. Only apps using `appType: 'custom'` and using the default Vite HTML middleware are affected. The HTML entry must also contain an inline script. The attack requires a user to click on a malicious URL while running the dev server. Re

    • Actualiza a 4.4.12
    • Actualiza a 4.5.1
    • Actualiza a 5.0.5
    Publicación Actualización
  7. CVE-2023-34092

    Alta · CVSS 7.5EPSS 3,15%Código de explotación públicoCorrección disponible

    Vite Server Options (server.fs.deny) can be bypassed using double forward-slash (//)

    Vite provides frontend tooling. Prior to versions 2.9.16, 3.2.7, 4.0.5, 4.1.5, 4.2.3, and 4.3.9, Vite Server Options (`server.fs.deny`) can be bypassed using double forward-slash (//) allows any unauthenticated user to read file from the Vite root-path of the application including the default `fs.deny` settings (`['.env', '.env.*', '*.{crt,pem}']`). Only users explicitly exposing the Vite dev server to the network (using `--host` or `server.host` config option) are affected, and only files in the immediate Vite project root folder could be exposed. This issue is fixed in [email protected], [email protected], [email protected], [email protected], [email protected], and [email protected]

    • Actualiza a 2.9.16
    • Actualiza a 3.2.7
    • Actualiza a 4.0.5
    • Actualiza a 4.1.5
    • Actualiza a 4.2.3
    • Actualiza a 4.3.9
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →