p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de contao/core-bundle · Página 2

Vulnerabilidades publicadas para contao/core-bundle en los últimos 30 días: 6. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 40

  1. CVE-2024-28235

    Alta · CVSS 8.4EPSS 0,71%Corrección disponible

    Contao possible cookie sharing with external domains while checking protected pages for broken links

    Contao is an open source content management system. Starting in version 4.9.0 and prior to versions 4.13.40 and 5.3.4, when checking for broken links on protected pages, Contao sends the cookie header to external urls as well, the passed options for the http client are used for all requests. Contao versions 4.13.40 and 5.3.4 have a patch for this issue. As a workaround, disable crawling protected pages.

    • Actualiza a 4.13.40
    • Actualiza a 5.3.4
    Publicación Actualización
  2. CVE-2024-28191

    Baja · CVSS 3.1EPSS 0,5%Corrección disponible

    Contao may have unencoded insert tags in the frontend

    Contao is an open source content management system. Starting in version 4.0.0 and prior to version 4.13.40 and 5.3.4, it is possible to inject insert tags in frontend forms if the output is structured in a very specific way. Contao versions 4.13.40 and 5.3.4 have a patch for this issue. As a workaround, do not output user data from frontend forms next to each other, always separate them by at least one character.

    • Actualiza a 4.13.40
    • Actualiza a 5.3.4
    Publicación Actualización
  3. CVE-2024-28190

    Media · CVSS 5.4EPSS 0,5%Corrección disponible

    Contao core bundle vulnerable to cross site scripting in the file manager

    Contao is an open source content management system. Starting in version 4.0.0 and prior to version 4.13.40 and 5.3.4, users can inject malicious code in filenames when uploading files (back end and front end), which is then executed in tooltips and popups in the back end. Contao versions 4.13.40 and 5.3.4 have a patch for this issue. As a workaround, remove upload fields from frontend forms and disable uploads for untrusted back end users.

    • Actualiza a 4.13.40
    • Actualiza a 5.3.4
    Publicación Actualización
  4. CVE-2023-36806

    Media · CVSS 6.5EPSS 0,64%Corrección disponible

    Contao cross site scripting vulnerability via input unit widget

    Contao is an open source content management system. Starting in version 4.0.0 and prior to versions 4.9.42, 4.13.28, and 5.1.10, it is possible for untrusted backend users to inject malicious code into headline fields in the back end, which will be executed both in the element preview (back end) and on the website (front end). Installations are only affected if there are untrusted back end users who have the rights to modify headline fields, or other fields using the input unit widget. Contao 4.9.42, 4.13.28, and 5.1.10 have a patch for this issue. As a workaround, disable the login for all untrusted back end users.

    • Actualiza a 4.13.28
    • Actualiza a 4.9.42
    • Actualiza a 5.1.10
    Publicación Actualización
  5. CVE-2022-24899

    Alta · CVSS 7.2EPSS 4,48%Código de explotación públicoCorrección disponible

    Cross site scripting via canonical tag

    Contao is a powerful open source CMS that allows you to create professional websites and scalable web applications. In versions of Contao prior to 4.13.3 it is possible to inject code into the canonical tag. As a workaround users may disable canonical tags in the root page settings.

    • Actualiza a 4.13.3
    Publicación Actualización
  6. CVE-2021-37627

    Alta · CVSS 8EPSS 1,02%Corrección disponible

    Privilege escalation via form generator

    Contao is an open source CMS that allows creation of websites and scalable web applications. In affected versions it is possible to gain privileged rights in the Contao back end. Installations are only affected if they have untrusted back end users who have access to the form generator. All users are advised to update to Contao 4.4.56, 4.9.18 or 4.11.7. As a workaround users may disable the form generator or disable the login for untrusted back end users.

    • Actualiza a 4.11.7
    • Actualiza a 4.4.56
    • Actualiza a 4.9.18
    Publicación Actualización
  7. CVE-2021-37626

    Alta · CVSS 7.2EPSS 1,25%Corrección disponible

    PHP file inclusion via insert tags

    Contao is an open source CMS that allows you to create websites and scalable web applications. In affected versions it is possible to load PHP files by entering insert tags in the Contao back end. Installations are only affected if they have untrusted back end users who have the rights to modify fields that are shown in the front end. Update to Contao 4.4.56, 4.9.18 or 4.11.7 to resolve. If you cannot update then disable the login for untrusted back end users.

    • Actualiza a 4.11.7
    • Actualiza a 4.4.56
    • Actualiza a 4.9.18
    Publicación Actualización
  8. CVE-2021-35210

    Media · CVSS 6.1EPSS 0,74%Corrección disponible

    CVE-2021-35210

    Contao 4.5.x through 4.9.x before 4.9.16, and 4.10.x through 4.11.x before 4.11.5, allows XSS. It is possible to inject code into the tl_log table that will be executed in the browser when the system log is called in the back end.

    • Actualiza a 4.11.5
    • Actualiza a 4.9.16
    Publicación Actualización
  9. CVE-2020-25768

    Media · CVSS 5.3EPSS 0,82%Corrección disponible

    CVE-2020-25768

    Contao before 4.4.52, 4.9.x before 4.9.6, and 4.10.x before 4.10.1 have Improper Input Validation. It is possible to inject insert tags in front end forms which will be replaced when the page is rendered.

    • Actualiza a 4.10.1
    • Actualiza a 4.4.52
    • Actualiza a 4.9.6
    Publicación Actualización
  10. CVE-2017-10993

    Alta · CVSS 8.8EPSS 2,72%Corrección disponible

    CVE-2017-10993

    Contao before 3.5.28 and 4.x before 4.4.1 allows remote attackers to include and execute arbitrary local PHP files via a crafted parameter in a URL, aka Directory Traversal.

    • Actualiza a 4.4.1
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →