p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de drupal/core · Página 7

Vulnerabilidades publicadas para drupal/core en los últimos 30 días: 3. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 150

  1. CVE-2017-6929

    Media · CVSS 6.1EPSS 1,22%Corrección disponible

    CVE-2017-6929

    A jQuery cross site scripting vulnerability is present when making Ajax requests to untrusted domains. This vulnerability is mitigated by the fact that it requires contributed or custom modules in order to exploit. For Drupal 8, this vulnerability was already fixed in Drupal 8.4.0 in the Drupal core upgrade to jQuery 3. For Drupal 7, it is fixed in the current release (Drupal 7.57) for jQuery 1.4.4 (the version that ships with Drupal 7 core) as well as for other newer versions of jQuery that might be used on the site, for example using the jQuery Update module.

    • Actualiza a 7.57
    • Actualiza a 8.4.0
    Publicación Actualización
  2. CVE-2017-6928

    Media · CVSS 5.3EPSS 1,02%Corrección disponible

    CVE-2017-6928

    Drupal core 7.x versions before 7.57 when using Drupal's private file system, Drupal will check to make sure a user has access to a file before allowing the user to view or download it. This check fails under certain conditions in which one module is trying to grant access to the file and another is trying to deny it, leading to an access bypass vulnerability. This vulnerability is mitigated by the fact that it only occurs for unusual site configurations.

    • Actualiza a 7.57
    Publicación Actualización
  3. CVE-2017-6927

    Media · CVSS 6.1EPSS 1,61%Corrección disponible

    CVE-2017-6927

    Drupal 8.4.x versions before 8.4.5 and Drupal 7.x versions before 7.57 has a Drupal.checkPlain() JavaScript function which is used to escape potentially dangerous text before outputting it to HTML (as JavaScript output does not typically go through Twig autoescaping). This function does not correctly handle all methods of injecting malicious HTML, leading to a cross-site scripting vulnerability under certain circumstances. The PHP functions which Drupal provides for HTML escaping are not affected.

    • Actualiza a 7.57
    • Actualiza a 8.4.5
    Publicación Actualización
  4. CVE-2017-6926

    Alta · CVSS 8.1EPSS 1,21%Corrección disponible

    CVE-2017-6926

    In Drupal versions 8.4.x versions before 8.4.5 users with permission to post comments are able to view content and comments they do not have access to, and are also able to add comments to this content. This vulnerability is mitigated by the fact that the comment system must be enabled and the attacker must have permission to post comments.

    • Actualiza a 7.57
    • Actualiza a 8.4.5
    Publicación Actualización
  5. DRUPAL-CORE-2018-001

    Sin evaluarCorrección disponible

    DRUPAL-CORE-2018-001

    This security advisory fixes multiple vulnerabilities in both Drupal 7 and Drupal 8. See below for a list. #### Comment reply form allows access to restricted content - Critical - Drupal 8 - CVE-2017-6926 Users with permission to post comments are able to view content and comments they do not have access to, and are also able to add comments to this content. This vulnerability is mitigated by the fact that the comment system must be enabled and the attacker must have permission to post comments. #### JavaScript cross-site scripting prevention is incomplete - Critical - Drupal 7 and Drupal 8 - CVE-2017-6927 Drupal has a `Drupal.checkPlain

    • Actualiza a 8.4.5
    Publicación Actualización
  6. CVE-2017-6381

    Alta · CVSS 8.1EPSS 3,9%Corrección disponible

    CVE-2017-6381

    A 3rd party development library including with Drupal 8 development dependencies is vulnerable to remote code execution. This is mitigated by the default .htaccess protection against PHP execution, and the fact that Composer development dependencies aren't normal installed. You might be vulnerable to this if you are running a version of Drupal before 8.2.2. To be sure you aren't vulnerable, you can remove the <siteroot>/vendor/phpunit directory from your production deployments

    • Actualiza a 8.2.7
    Publicación Actualización
  7. CVE-2017-6379

    Alta · CVSS 7.5EPSS 0,78%Corrección disponible

    CVE-2017-6379

    Some administrative paths in Drupal 8.2.x before 8.2.7 did not include protection for CSRF. This would allow an attacker to disable some blocks on a site. This issue is mitigated by the fact that users would have to know the block ID.

    • Actualiza a 8.2.7
    Publicación Actualización
  8. CVE-2016-7572

    Media · CVSS 4.3EPSS 1,72%Corrección disponible

    CVE-2016-7572

    The system.temporary route in Drupal 8.x before 8.1.10 does not properly check for "Export configuration" permission, which allows remote authenticated users to bypass intended access restrictions and read a full config export via unspecified vectors.

    • Actualiza a 8.1.10
    Publicación Actualización
  9. CVE-2016-7570

    Media · CVSS 4.3EPSS 1,68%Corrección disponible

    CVE-2016-7570

    Drupal 8.x before 8.1.10 does not properly check for "Administer comments" permission, which allows remote authenticated users to set the visibility of comments for arbitrary nodes by leveraging rights to edit those nodes.

    • Actualiza a 8.1.10
    Publicación Actualización
  10. CVE-2016-6212

    Media · CVSS 5.3EPSS 2,21%Corrección disponible

    CVE-2016-6212

    The Views module 7.x-3.x before 7.x-3.14 in Drupal 7.x and the Views module in Drupal 8.x before 8.1.3 might allow remote authenticated users to bypass intended access restrictions and obtain sensitive Statistics information via unspecified vectors.

    • Actualiza a 8.1.3
    Publicación Actualización
  11. CVE-2016-5385

    Alta · CVSS 8.1EPSS 50,43%Corrección disponible

    CVE-2016-5385

    PHP through 7.0.8 does not attempt to address RFC 3875 section 4.1.18 namespace conflicts and therefore does not protect applications from the presence of untrusted client data in the HTTP_PROXY environment variable, which might allow remote attackers to redirect an application's outbound HTTP traffic to an arbitrary proxy server via a crafted Proxy header in an HTTP request, as demonstrated by (1) an application that makes a getenv('HTTP_PROXY') call or (2) a CGI configuration of PHP, aka an "httpoxy" issue.

    • Actualiza a 8.1.7
    Publicación Actualización
  12. CVE-2016-3171

    Alta · CVSS 8.1EPSS 3,19%Corrección disponible

    CVE-2016-3171

    Drupal 6.x before 6.38, when used with PHP before 5.4.45, 5.5.x before 5.5.29, or 5.6.x before 5.6.13, might allow remote attackers to execute arbitrary code via vectors related to session data truncation.

    • Actualiza a 6.38
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →