p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de laravel/framework · Página 2

Vulnerabilidades publicadas para laravel/framework en los últimos 30 días: 2. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 28

  1. CVE-2021-43808

    Media · CVSS 5.3EPSS 0,83%Corrección disponible

    Blade `@parent` Exploitation Leading To Possible XSS in Laravel

    Laravel is a web application framework. Laravel prior to versions 8.75.0, 7.30.6, and 6.20.42 contain a possible cross-site scripting (XSS) vulnerability in the Blade templating engine. A broken HTML element may be clicked and the user taken to another location in their browser due to XSS. This is due to the user being able to guess the parent placeholder SHA-1 hash by trying common names of sections. If the parent template contains an exploitable HTML structure an XSS vulnerability can be exposed. This vulnerability has been patched in versions 8.75.0, 7.30.6, and 6.20.42 by determining the parent placeholder at runtime and using a random ha

    • Actualiza a 6.20.42
    • Actualiza a 7.30.6
    • Actualiza a 8.75.0
    Publicación Actualización
  2. GHSA-4mg9-vhxq-vm7j

    Sin evaluarCorrección disponible

    SQL Server LIMIT / OFFSET SQL Injection in laravel/framework and illuminate/database

    ### Impact Those using SQL Server with Laravel and allowing user input to be passed directly to the `limit` and `offset` functions are vulnerable to SQL injection. Other database drivers such as MySQL and Postgres are not affected by this vulnerability. ### Patches This problem has been patched on Laravel versions 6.20.26, 7.30.5, and 8.40.0. ### Workarounds You may workaround this vulnerability by ensuring that only integers are passed to the `limit` and `offset` functions, as well as the `skip` and `take` functions.

    • Actualiza a 6.20.26
    • Actualiza a 8.40.0
    Publicación Actualización
  3. GHSA-x7p5-p2c9-phvg

    Alta · CVSS 7.2Corrección disponible

    Unexpected database bindings

    This is a follow-up to the previous security advisory (GHSA-3p32-j457-pg5x) which addresses a few additional edge cases. If a request is crafted where a field that is normally a non-array value is an array, and that input is not validated or cast to its expected type before being passed to the query builder, an unexpected number of query bindings can be added to the query. In some situations, this will simply lead to no results being returned by the query builder; however, it is possible certain queries could be affected in a way that causes the query to return unexpected results.

    • Actualiza a 6.20.14
    • Actualiza a 7.30.4
    • Actualiza a 8.24.0
    Publicación Actualización
  4. CVE-2021-21263

    Alta · CVSS 7.2EPSS 1,62%Corrección disponible

    Query Binding Exploitation in Laravel

    Laravel is a web application framework. Versions of Laravel before 6.20.11, 7.30.2 and 8.22.1 contain a query binding exploitation. This same exploit applies to the illuminate/database package which is used by Laravel. If a request is crafted where a field that is normally a non-array value is an array, and that input is not validated or cast to its expected type before being passed to the query builder, an unexpected number of query bindings can be added to the query. In some situations, this will simply lead to no results being returned by the query builder; however, it is possible certain queries could be affected in a way that causes the

    • Actualiza a 6.20.11
    • Actualiza a 7.30.2
    • Actualiza a 8.22.1
    Publicación Actualización
  5. CVE-2018-15133

    Alta · CVSS 8.1EPSS 76,57%En el catálogo KEVCódigo de explotación públicoCorrección disponible

    CVE-2018-15133

    In Laravel Framework through 5.5.40 and 5.6.x through 5.6.29, remote code execution might occur as a result of an unserialize call on a potentially untrusted X-XSRF-TOKEN value. This involves the decrypt method in Illuminate/Encryption/Encrypter.php and PendingBroadcast in gadgetchains/Laravel/RCE/3/chain.php in phpggc. The attacker must know the application key, which normally would never occur, but could happen if the attacker previously had privileged access or successfully accomplished a previous attack.

    • Actualiza a 5.6.30
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →