p PatchFirst

PatchFirst · Vulnerabilidades recientes

yeswiki/yeswiki 4.4.5: vulnerabilidades conocidas · Página 2

Vulnerabilidades conocidas que afectan a yeswiki/yeswiki 4.4.5: 27. Compara las versiones corregidas de abajo con la que tienes instalada.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 27

  1. CVE-2025-46349

    Alta · CVSS 7.6EPSS 0,63%Código de explotación públicoSin corrección publicada

    YesWiki Vulnerable to Unauthenticated Reflected Cross-site Scripting

    YesWiki is a wiki system written in PHP. Prior to version 4.5.4, YesWiki is vulnerable to reflected XSS in the file upload form. This vulnerability allows any malicious unauthenticated user to create a link that can be clicked on by the victim to perform arbitrary actions. This issue has been patched in version 4.5.4.

    Publicación Actualización
  2. CVE-2025-46347

    Media · CVSS 5.8EPSS 1,03%Corrección disponible

    YesWiki Remote Code Execution via Arbitrary PHP File Write and Execution

    YesWiki is a wiki system written in PHP. Prior to version 4.5.4, YesWiki vulnerable to remote code execution. An arbitrary file write can be used to write a file with a PHP extension, which then can be browsed to in order to execute arbitrary code on the server, resulting in a full compromise of the server. This could potentially be performed unwittingly by a user. This issue has been patched in version 4.5.4.

    • Actualiza a 4.5.4
    Publicación Actualización
  3. CVE-2025-46346

    Media · CVSS 6.3EPSS 0,35%Corrección disponible

    YesWiki Vulnerable to Stored XSS in Comments

    YesWiki is a wiki system written in PHP. Prior to version 4.5.4, a stored cross-site scripting (XSS) vulnerability was discovered in the application’s comments feature. This issue allows a malicious actor to inject JavaScript payloads that are stored and later executed in the browser of any user viewing the affected comment. The XSS occurs because the application fails to properly sanitize or encode user input submitted to the comments. Notably, the application sanitizes or does not allow execution of `<script>` tags, but does not account for payloads obfuscated using JavaScript block comments like `/* JavaScriptPayload */`. This issue has be

    • Actualiza a 4.5.4
    Publicación Actualización
  4. CVE-2025-31131

    Alta · CVSS 8.6EPSS 5,58%Código de explotación públicoCorrección disponible

    Path Traversal allowing arbitrary read of files in Yeswiki

    YesWiki is a wiki system written in PHP. The squelette parameter is vulnerable to path traversal attacks, enabling read access to arbitrary files on the server. This vulnerability is fixed in 4.5.2.

    • Actualiza a 4.5.2
    Publicación Actualización
  5. CVE-2025-24019

    Alta · CVSS 7.1EPSS 0,61%Corrección disponible

    YesWiki vulnerable to authenticated arbitrary file deletion

    YesWiki is a wiki system written in PHP. In versions up to and including 4.4.5, it is possible for any authenticated user, through the use of the filemanager to delete any file owned by the user running the FastCGI Process Manager (FPM) on the host without any limitation on the filesystem's scope. This vulnerability allows any authenticated user to arbitrarily remove content from the Wiki resulting in partial loss of data and defacement/deterioration of the website. In the context of a container installation of YesWiki without any modification, the `yeswiki` files (for example .php) are not owned by the same user (root) as the one running the

    • Actualiza a 4.5.0
    Publicación Actualización
  6. CVE-2025-24018

    Alta · CVSS 7.6EPSS 0,42%Corrección disponible

    YesWiki Vulnerable to Authenticated Stored XSS

    YesWiki is a wiki system written in PHP. In versions up to and including 4.4.5, it is possible for an authenticated user with rights to edit/create a page or comment to trigger a stored XSS which will be reflected on any page where the resource is loaded. The vulnerability makes use of the content edition feature and more specifically of the `{{attach}}` component allowing users to attach files/medias to a page. When a file is attached using the `{{attach}}` component, if the resource contained in the `file` attribute doesn't exist, then the server will generate a file upload button containing the filename. This vulnerability allows any malic

    • Actualiza a 4.5.0
    Publicación Actualización
  7. CVE-2025-24017

    Alta · CVSS 7.6EPSS 0,36%Corrección disponible

    YesWiki Vulnerable to Unauthenticated DOM Based XSS

    YesWiki is a wiki system written in PHP. Versions up to and including 4.4.5 are vulnerable to any end-user crafting a DOM based XSS on all of YesWiki's pages which is triggered when a user clicks on a malicious link. The vulnerability makes use of the search by tag feature. When a tag doesn't exist, the tag is reflected on the page and isn't properly sanitized on the server side which allows a malicious user to generate a link that will trigger an XSS on the client's side when clicked. This vulnerability allows any user to generate a malicious link that will trigger an account takeover when clicked, therefore allowing a user to steal other ac

    • Actualiza a 4.5.0
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →