p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de apache2 · Página 2

Vulnerabilidades publicadas para apache2 en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 53

  1. CVE-2021-33193

    Alta · CVSS 7.5EPSS 46,18%Corrección disponible

    Request splitting via HTTP/2 method injection and mod_proxy

    A crafted method sent through HTTP/2 will bypass validation and be forwarded by mod_proxy, which can lead to request splitting or cache poisoning. This issue affects Apache HTTP Server 2.4.17 to 2.4.48.

    • Actualiza a 2.4.29-1ubuntu4.17
    Publicación Actualización
  2. CVE-2020-35452

    Alta · CVSS 7.3EPSS 54,81%Corrección disponible

    mod_auth_digest possible stack overflow by one nul byte

    Apache HTTP Server versions 2.4.0 to 2.4.46 A specially crafted Digest nonce can cause a stack overflow in mod_auth_digest. There is no report of this overflow being exploitable, nor the Apache HTTP Server team could create one, though some particular compiler and/or compilation option might make it possible, with limited consequences anyway due to the size (a single byte) and the value (zero byte) of the overflow

    • Actualiza a 2.4.29-1ubuntu4.16
    Publicación Actualización
  3. CVE-2020-11993

    Alta · CVSS 7.5EPSS 56,45%Corrección disponible

    CVE-2020-11993

    Apache HTTP Server versions 2.4.20 to 2.4.43 When trace/debug was enabled for the HTTP/2 module and on certain traffic edge patterns, logging statements were made on the wrong connection, causing concurrent use of memory pools. Configuring the LogLevel of mod_http2 above "info" will mitigate this vulnerability for unpatched servers.

    • Actualiza a 2.4.29-1ubuntu4.14
    Publicación Actualización
  4. CVE-2020-9490

    Alta · CVSS 7.5EPSS 88,84%Corrección disponible

    CVE-2020-9490

    Apache HTTP Server versions 2.4.20 to 2.4.43. A specially crafted value for the 'Cache-Digest' header in a HTTP/2 request would result in a crash when the server actually tries to HTTP/2 PUSH a resource afterwards. Configuring the HTTP/2 feature via "H2Push off" will mitigate this vulnerability for unpatched servers.

    • Actualiza a 2.4.29-1ubuntu4.14
    Publicación Actualización
  5. USN-4307-1

    Sin evaluarCorrección disponible

    apache2 update

    As a security improvement, this update adds TLSv1.3 support to the Apache HTTP Server package in Ubuntu 18.04 LTS. TLSv1.3 is enabled by default, and in certain environments may cause compatibility issues. The SSLProtocol directive may be used to disable TLSv1.3 in these problematic environments.

    • Actualiza a 2.4.29-1ubuntu4.13
    Publicación Actualización
  6. CVE-2019-10092

    Media · CVSS 6.1EPSS 81,47%Código de explotación públicoCorrección disponible

    CVE-2019-10092

    In Apache HTTP Server 2.4.0-2.4.39, a limited cross-site scripting issue was reported affecting the mod_proxy error page. An attacker could cause the link on the error page to be malformed and instead point to a page of their choice. This would only be exploitable where a server was set up with proxying enabled but was misconfigured in such a way that the Proxy Error page was displayed.

    • Actualiza a 2.4.29-1ubuntu4.10
    Publicación Actualización
  7. CVE-2019-10098

    Media · CVSS 6.1EPSS 73,98%Código de explotación públicoCorrección disponible

    CVE-2019-10098

    In Apache HTTP server 2.4.0 to 2.4.39, Redirects configured with mod_rewrite that were intended to be self-referential might be fooled by encoded newlines and redirect instead to an unexpected URL within the request URL.

    • Actualiza a 2.4.29-1ubuntu4.10
    Publicación Actualización
  8. USN-4113-2

    Sin evaluarCorrección disponible

    apache2 regression

    USN-4113-1 fixed vulnerabilities in the Apache HTTP server. Unfortunately, that update introduced a regression when proxying balancer manager connections in some configurations. This update fixes the problem. We apologize for the inconvenience. Original advisory details: Stefan Eissing discovered that the HTTP/2 implementation in Apache did not properly handle upgrade requests from HTTP/1.1 to HTTP/2 in some situations. A remote attacker could use this to cause a denial of service (daemon crash). This issue only affected Ubuntu 18.04 LTS and Ubuntu 19.04. (CVE-2019-0197) Craig Young discovered that a memory overwrite error existed i

    • Actualiza a 2.4.29-1ubuntu4.11
    Publicación Actualización
  9. CVE-2019-10081

    Alta · CVSS 7.5EPSS 14,56%Corrección disponible

    CVE-2019-10081

    HTTP/2 (2.4.20 through 2.4.39) very early pushes, for example configured with "H2PushResource", could lead to an overwrite of memory in the pushing request's pool, leading to crashes. The memory copied is that of the configured push link header values, not data supplied by the client.

    • Actualiza a 2.4.29-1ubuntu4.10
    Publicación Actualización
  10. CVE-2019-9517

    Alta · CVSS 7.5EPSS 27,89%Corrección disponible

    Some HTTP/2 implementations are vulnerable to unconstrained interal data buffering, potentially leading to a denial of service

    Some HTTP/2 implementations are vulnerable to unconstrained interal data buffering, potentially leading to a denial of service. The attacker opens the HTTP/2 window so the peer can send without constraint; however, they leave the TCP window closed so the peer cannot actually write (many of) the bytes on the wire. The attacker then sends a stream of requests for a large response object. Depending on how the servers queue the responses, this can consume excess memory, CPU, or both.

    • Actualiza a 2.4.29-1ubuntu4.10
    Publicación Actualización
  11. CVE-2019-0197

    Media · CVSS 4.2EPSS 8,59%Corrección disponible

    CVE-2019-0197

    A vulnerability was found in Apache HTTP Server 2.4.34 to 2.4.38. When HTTP/2 was enabled for a http: host or H2Upgrade was enabled for h2 on a https: host, an Upgrade request from http/1.1 to http/2 that was not the first request on a connection could lead to a misconfiguration and crash. Server that never enabled the h2 protocol or that only enabled it for https: and did not set "H2Upgrade on" are unaffected by this issue.

    • Actualiza a 2.4.29-1ubuntu4.10
    Publicación Actualización
  12. CVE-2019-0196

    Media · CVSS 5.3EPSS 19,96%Corrección disponible

    CVE-2019-0196

    A vulnerability was found in Apache HTTP Server 2.4.17 to 2.4.38. Using fuzzed network input, the http/2 request handling could be made to access freed memory in string comparison when determining the method of a request and thus process the request incorrectly.

    • Actualiza a 2.4.29-1ubuntu4.6
    Publicación Actualización
  13. CVE-2019-0220

    Media · CVSS 5.3EPSS 18,01%Corrección disponible

    CVE-2019-0220

    A vulnerability was found in Apache HTTP Server 2.4.0 to 2.4.38. When the path component of a request URL contains multiple consecutive slashes ('/'), directives such as LocationMatch and RewriteRule must account for duplicates in regular expressions while other aspects of the servers processing will implicitly collapse them.

    • Actualiza a 2.4.29-1ubuntu4.6
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →