p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de consul · Página 2

Vulnerabilidades publicadas para consul en los últimos 30 días: 4. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 46

  1. CVE-2024-10086

    Media · CVSS 6.1EPSS 0,4%Sin corrección publicada

    Consul Vulnerable To Reflected XSS On Content-Type Error Manipulation

    A vulnerability was identified in Consul and Consul Enterprise such that the server response did not explicitly set a Content-Type HTTP header, allowing user-provided inputs to be misinterpreted and lead to reflected XSS.

    Publicación Actualización
  2. CVE-2023-5332

    Media · CVSS 5.9EPSS 0,87%Sin corrección publicada

    Dependency on Vulnerable Third-Party Component in GitLab

    Patch in third party library Consul requires 'enable-script-checks' to be set to False. This was required to enable a patch by the vendor. Without this setting the patch could be bypassed. This only affects GitLab-EE.

    Publicación Actualización
  3. CVE-2023-1297

    Media · CVSS 4.9EPSS 0,77%Sin corrección publicada

    Consul Cluster Peering can Result in Denial of Service

    Consul and Consul Enterprise's cluster peering implementation contained a flaw whereby a peer cluster with service of the same name as a local service could corrupt Consul state, resulting in denial of service. This vulnerability was resolved in Consul 1.14.5, and 1.15.3

    Publicación Actualización
  4. CVE-2023-2816

    Alta · CVSS 8.7EPSS 0,58%Sin corrección publicada

    Consul Envoy Extension Downsteam Proxy Configuration By Upstream Service Owner

    Consul and Consul Enterprise allowed any user with service:write permissions to use Envoy extensions configured via service-defaults to patch remote proxy instances that target the configured service, regardless of whether the user has permission to modify the service(s) corresponding to those modified proxies.

    Publicación Actualización
  5. CVE-2023-0845

    Media · CVSS 4.9EPSS 1%Sin corrección publicada

    Consul Server Panic when Ingress and API Gateways Configured with Peering

    Consul and Consul Enterprise allowed an authenticated user with service:write permissions to trigger a workflow that causes Consul server and client agents to crash under certain circumstances. This vulnerability was fixed in Consul 1.14.5.

    Publicación Actualización
  6. CVE-2022-3920

    Media · CVSS 5.3EPSS 0,72%Sin corrección publicada

    Consul Peering Imported Nodes/Services Leak

    HashiCorp Consul and Consul Enterprise 1.13.0 up to 1.13.3 do not filter cluster filtering's imported nodes and services for HTTP or RPC endpoints used by the UI. Fixed in 1.14.0.

    Publicación Actualización
  7. CVE-2022-40716

    Media · CVSS 6.5EPSS 1,09%Sin corrección publicada

    CVE-2022-40716

    HashiCorp Consul and Consul Enterprise up to 1.11.8, 1.12.4, and 1.13.1 do not check for multiple SAN URI values in a CSR on the internal RPC endpoint, enabling leverage of privileged access to bypass service mesh intentions. Fixed in 1.11.9, 1.12.5, and 1.13.2."

    Publicación Actualización
  8. CVE-2022-29153

    Alta · CVSS 7.5EPSS 8,75%Código de explotación públicoSin corrección publicada

    CVE-2022-29153

    HashiCorp Consul and Consul Enterprise up to 1.9.16, 1.10.9, and 1.11.4 may allow server side request forgery when the Consul client agent follows redirects returned by HTTP health check endpoints. Fixed in 1.9.17, 1.10.10, and 1.11.5.

    Publicación Actualización
  9. CVE-2022-24687

    Media · CVSS 6.5EPSS 1,49%Sin corrección publicada

    CVE-2022-24687

    HashiCorp Consul and Consul Enterprise 1.9.0 through 1.9.14, 1.10.7, and 1.11.2 clusters with at least one Ingress Gateway allow a user with service:write to register a specifically-defined service that can cause Consul servers to panic. Fixed in 1.9.15, 1.10.8, and 1.11.3.

    Publicación Actualización
  10. CVE-2021-41805

    Alta · CVSS 8.8EPSS 34,79%Sin corrección publicada

    CVE-2021-41805

    HashiCorp Consul Enterprise before 1.8.17, 1.9.x before 1.9.11, and 1.10.x before 1.10.4 has Incorrect Access Control. An ACL token (with the default operator:write permissions) in one namespace can be used for unintended privilege escalation in a different namespace.

    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →