p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de thunderbird · Página 65

Vulnerabilidades publicadas para thunderbird en los últimos 30 días: 263. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 1304

  1. CVE-2022-23639

    Alta · CVSS 8.1EPSS 1,23%Sin corrección publicada

    Improper Restriction of Operations within the Bounds of a Memory Buffer and Race Condition in crossbeam-utils

    crossbeam-utils provides atomics, synchronization primitives, scoped threads, and other utilities for concurrent programming in Rust. crossbeam-utils prior to version 0.8.7 incorrectly assumed that the alignment of `{i,u}64` was always the same as `Atomic{I,U}64`. However, the alignment of `{i,u}64` on a 32-bit target can be smaller than `Atomic{I,U}64`. This can cause unaligned memory accesses and data race. Crates using `fetch_*` methods with `AtomicCell<{i,u}64>` are affected by this issue. 32-bit targets without `Atomic{I,U}64` and 64-bit targets are not affected by this issue. This has been fixed in crossbeam-utils 0.8.7. There are curre

    Publicación Actualización
  2. CVE-2021-44538

    Crítica · CVSS 9.8EPSS 2%Corrección disponible

    CVE-2021-44538

    The olm_session_describe function in Matrix libolm before 3.2.7 is vulnerable to a buffer overflow. The Olm session object represents a cryptographic channel between two parties. Therefore, its state is partially controllable by the remote party of the channel. Attackers can construct a crafted sequence of messages to manipulate the state of the receiver's session in such a way that, for some buffer sizes, a buffer overflow happens on a call to olm_session_describe. Furthermore, safe buffer sizes were undocumented. The overflow content is partially controllable by the attacker and limited to ASCII spaces and digits. The known affected product

    • Actualiza a 1:91.5.0+build1-0ubuntu1
    Publicación Actualización
  3. CVE-2021-38503

    Crítica · CVSS 10EPSS 4,12%Corrección disponible

    CVE-2021-38503

    The iframe sandbox rules were not correctly applied to XSLT stylesheets, allowing an iframe to bypass restrictions such as executing scripts or navigating the top-level frame. This vulnerability affects Firefox < 94, Thunderbird < 91.3, and Firefox ESR < 91.3.

    • Actualiza a 1:91.3.1+build1-0ubuntu1
    Publicación Actualización
  4. CVE-2021-38504

    Alta · CVSS 8.8EPSS 1,77%Corrección disponible

    CVE-2021-38504

    When interacting with an HTML input element's file picker dialog with webkitdirectory set, a use-after-free could have resulted, leading to memory corruption and a potentially exploitable crash. This vulnerability affects Firefox < 94, Thunderbird < 91.3, and Firefox ESR < 91.3.

    • Actualiza a 1:91.3.1+build1-0ubuntu1
    Publicación Actualización
  5. CVE-2021-38506

    Media · CVSS 4.3EPSS 1,51%Corrección disponible

    CVE-2021-38506

    Through a series of navigations, Firefox could have entered fullscreen mode without notification or warning to the user. This could lead to spoofing attacks on the browser UI including phishing. This vulnerability affects Firefox < 94, Thunderbird < 91.3, and Firefox ESR < 91.3.

    • Actualiza a 1:91.3.1+build1-0ubuntu1
    Publicación Actualización
  6. CVE-2021-38507

    Media · CVSS 6.5EPSS 0,83%Corrección disponible

    CVE-2021-38507

    The Opportunistic Encryption feature of HTTP2 (RFC 8164) allows a connection to be transparently upgraded to TLS while retaining the visual properties of an HTTP connection, including being same-origin with unencrypted connections on port 80. However, if a second encrypted port on the same IP address (e.g. port 8443) did not opt-in to opportunistic encryption; a network attacker could forward a connection from the browser to port 443 to port 8443, causing the browser to treat the content of port 8443 as same-origin with HTTP. This was resolved by disabling the Opportunistic Encryption feature, which had low usage. This vulnerability affects F

    • Actualiza a 1:91.3.1+build1-0ubuntu1
    Publicación Actualización
  7. CVE-2021-38508

    Media · CVSS 4.3EPSS 1,64%Corrección disponible

    CVE-2021-38508

    By displaying a form validity message in the correct location at the same time as a permission prompt (such as for geolocation), the validity message could have obscured the prompt, resulting in the user potentially being tricked into granting the permission. This vulnerability affects Firefox < 94, Thunderbird < 91.3, and Firefox ESR < 91.3.

    • Actualiza a 1:91.3.1+build1-0ubuntu1
    Publicación Actualización
  8. CVE-2021-38509

    Media · CVSS 4.3EPSS 1,76%Corrección disponible

    CVE-2021-38509

    Due to an unusual sequence of attacker-controlled events, a Javascript alert() dialog with arbitrary (although unstyled) contents could be displayed over top an uncontrolled webpage of the attacker's choosing. This vulnerability affects Firefox < 94, Thunderbird < 91.3, and Firefox ESR < 91.3.

    • Actualiza a 1:91.3.1+build1-0ubuntu1
    Publicación Actualización
  9. CVE-2021-43527

    Crítica · CVSS 9.8EPSS 17,56%Corrección disponible

    CVE-2021-43527

    NSS (Network Security Services) versions prior to 3.73 or 3.68.1 ESR are vulnerable to a heap overflow when handling DER-encoded DSA or RSA-PSS signatures. Applications using NSS for handling signatures encoded within CMS, S/MIME, PKCS \#7, or PKCS \#12 are likely to be impacted. Applications using NSS for certificate validation or other TLS, X.509, OCSP or CRL functionality may be impacted, depending on how they configure NSS. *Note: This vulnerability does NOT impact Mozilla Firefox.* However, email clients and PDF viewers that use NSS for signature verification, such as Thunderbird, LibreOffice, Evolution and Evince are believed to be impa

    • Actualiza a 1:91.4.0+build1.1-0ubuntu1
    Publicación Actualización
  10. CVE-2021-38496

    Alta · CVSS 8.8EPSS 1,66%Corrección disponible

    CVE-2021-38496

    During operations on MessageTasks, a task may have been removed while it was still scheduled, resulting in memory corruption and a potentially exploitable crash. This vulnerability affects Thunderbird < 78.15, Thunderbird < 91.2, Firefox ESR < 91.2, Firefox ESR < 78.15, and Firefox < 93.

    • Actualiza a 1:91.3.0+build2-0ubuntu1
    Publicación Actualización
  11. CVE-2021-38497

    Media · CVSS 6.5EPSS 0,59%Corrección disponible

    CVE-2021-38497

    Through use of reportValidity() and window.open(), a plain-text validation message could have been overlaid on another origin, leading to possible user confusion and spoofing attacks. This vulnerability affects Firefox < 93, Thunderbird < 91.2, and Firefox ESR < 91.2.

    • Actualiza a 1:91.3.0+build2-0ubuntu1
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →