p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de ruby3.2 · Página 2

Vulnerabilidades publicadas para ruby3.2 en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 28

  1. CVE-2024-49761

    Media · CVSS 6.6EPSS 1,42%Corrección disponible

    REXML ReDoS vulnerability

    REXML is an XML toolkit for Ruby. The REXML gem before 3.3.9 has a ReDoS vulnerability when it parses an XML that has many digits between &# and x...; in a hex numeric character reference (&#x...;). This does not happen with Ruby 3.2 or later. Ruby 3.1 is the only affected maintained Ruby. The REXML gem 3.3.9 or later include the patch to fix the vulnerability.

    • Actualiza a 3.2.3-1ubuntu0.24.04.3
    Publicación Actualización
  2. CVE-2024-43398

    Media · CVSS 5.9EPSS 1,21%Corrección disponible

    REXML denial of service vulnerability

    REXML is an XML toolkit for Ruby. The REXML gem before 3.3.6 has a DoS vulnerability when it parses an XML that has many deep elements that have same local name attributes. If you need to parse untrusted XMLs with tree parser API like REXML::Document.new, you may be impacted to this vulnerability. If you use other parser APIs such as stream parser API and SAX2 parser API, this vulnerability is not affected. The REXML gem 3.3.6 or later include the patch to fix the vulnerability.

    • Actualiza a 3.2.3-1ubuntu0.24.04.5
    Publicación Actualización
  3. CVE-2024-41946

    Media · CVSS 5.3EPSS 1,19%Corrección disponible

    REXML DoS vulnerability

    REXML is an XML toolkit for Ruby. The REXML gem 3.3.2 has a DoS vulnerability when it parses an XML that has many entity expansions with SAX2 or pull parser API. The REXML gem 3.3.3 or later include the patch to fix the vulnerability.

    • Actualiza a 3.2.3-1ubuntu0.24.04.3
    Publicación Actualización
  4. CVE-2024-41123

    Media · CVSS 5.3EPSS 1,28%Corrección disponible

    REXML DoS vulnerability

    REXML is an XML toolkit for Ruby. The REXML gem before 3.3.2 has some DoS vulnerabilities when it parses an XML that has many specific characters such as whitespace character, `>]` and `]>`. The REXML gem 3.3.3 or later include the patches to fix these vulnerabilities.

    • Actualiza a 3.2.3-1ubuntu0.24.04.5
    Publicación Actualización
  5. CVE-2024-39908

    Media · CVSS 4.3EPSS 1,49%Corrección disponible

    Denial of service in REXML

    REXML is an XML toolkit for Ruby. The REXML gem before 3.3.1 has some DoS vulnerabilities when it parses an XML that has many specific characters such as `<`, `0` and `%>`. If you need to parse untrusted XMLs, you many be impacted to these vulnerabilities. The REXML gem 3.3.2 or later include the patches to fix these vulnerabilities. Users are advised to upgrade. Users unable to upgrade should avoid parsing untrusted XML strings.

    • Actualiza a 3.2.3-1ubuntu0.24.04.5
    Publicación Actualización
  6. CVE-2024-35176

    Media · CVSS 5.3EPSS 2,06%Corrección disponible

    REXML contains a denial of service vulnerability

    REXML is an XML toolkit for Ruby. The REXML gem before 3.2.6 has a denial of service vulnerability when it parses an XML that has many `<`s in an attribute value. Those who need to parse untrusted XMLs may be impacted to this vulnerability. The REXML gem 3.2.7 or later include the patch to fix this vulnerability. As a workaround, don't parse untrusted XMLs.

    • Actualiza a 3.2.3-1ubuntu0.24.04.5
    Publicación Actualización
  7. CVE-2024-27281

    Media · CVSS 4.5EPSS 1,57%Corrección disponible

    CVE-2024-27281

    An issue was discovered in RDoc 6.3.3 through 6.6.2, as distributed in Ruby 3.x through 3.3.0. When parsing .rdoc_options (used for configuration in RDoc) as a YAML file, object injection and resultant remote code execution are possible because there are no restrictions on the classes that can be restored. (When loading the documentation cache, object injection and resultant remote code execution are also possible if there were a crafted cache.) The main fixed version is 6.6.3.1. For Ruby 3.0 users, a fixed version is rdoc 6.3.4.1. For Ruby 3.1 users, a fixed version is rdoc 6.4.1.1. For Ruby 3.2 users, a fixed version is rdoc 6.5.1.1.

    • Actualiza a 3.2.3-1ubuntu0.24.04.1
    Publicación Actualización
  8. CVE-2024-27282

    Media · CVSS 6.6EPSS 0,66%Corrección disponible

    CVE-2024-27282

    An issue was discovered in Ruby 3.x through 3.3.0. If attacker-supplied data is provided to the Ruby regex compiler, it is possible to extract arbitrary heap data relative to the start of the text, including pointers and sensitive strings. The fixed versions are 3.0.7, 3.1.5, 3.2.4, and 3.3.1.

    • Actualiza a 3.2.3-1ubuntu0.24.04.1
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →