p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de apache2 · Página 4

Vulnerabilidades publicadas para apache2 en los últimos 30 días: 17. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 83

  1. CVE-2022-28615

    Crítica · CVSS 9.1EPSS 6,28%Corrección disponible

    Read beyond bounds in ap_strcmp_match()

    Apache HTTP Server 2.4.53 and earlier may crash or disclose information due to a read beyond bounds in ap_strcmp_match() when provided with an extremely large input buffer. While no code distributed with the server can be coerced into such a call, third-party modules or lua scripts that use ap_strcmp_match() may hypothetically be affected.

    • Actualiza a 2.4.7-1ubuntu4.22+esm6
    Publicación Actualización
  2. CVE-2022-28614

    Media · CVSS 5.3EPSS 4,98%Corrección disponible

    read beyond bounds via ap_rwrite()

    The ap_rwrite() function in Apache HTTP Server 2.4.53 and earlier may read unintended memory if an attacker can cause the server to reflect very large input using ap_rwrite() or ap_rputs(), such as with mod_luas r:puts() function. Modules compiled and distributed separately from Apache HTTP Server that use the 'ap_rputs' function and may pass it a very large (INT_MAX or larger) string must be compiled against current headers to resolve the issue.

    • Actualiza a 2.4.7-1ubuntu4.22+esm6
    Publicación Actualización
  3. CVE-2022-26377

    Alta · CVSS 7.5EPSS 21,08%Corrección disponible

    mod_proxy_ajp: Possible request smuggling

    Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in mod_proxy_ajp of Apache HTTP Server allows an attacker to smuggle requests to the AJP server it forwards requests to. This issue affects Apache HTTP Server Apache HTTP Server 2.4 version 2.4.53 and prior versions.

    • Actualiza a 2.4.7-1ubuntu4.22+esm5
    Publicación Actualización
  4. CVE-2022-23943

    Crítica · CVSS 9.8EPSS 50,4%Corrección disponible

    mod_sed: Read/write beyond bounds

    Out-of-bounds Write vulnerability in mod_sed of Apache HTTP Server allows an attacker to overwrite heap memory with possibly attacker provided data. This issue affects Apache HTTP Server 2.4 version 2.4.52 and prior versions.

    • Actualiza a 2.4.7-1ubuntu4.22+esm4
    Publicación Actualización
  5. CVE-2022-22721

    Crítica · CVSS 9.1EPSS 41,71%Corrección disponible

    core: Possible buffer overflow with very large or unlimited LimitXMLRequestBody

    If LimitXMLRequestBody is set to allow request bodies larger than 350MB (defaults to 1M) on 32 bit systems an integer overflow happens which later causes out of bounds writes. This issue affects Apache HTTP Server 2.4.52 and earlier.

    • Actualiza a 2.4.7-1ubuntu4.22+esm4
    Publicación Actualización
  6. CVE-2022-22720

    Crítica · CVSS 9.8EPSS 28,19%Corrección disponible

    HTTP request smuggling vulnerability in Apache HTTP Server 2.4.52 and earlier

    Apache HTTP Server 2.4.52 and earlier fails to close inbound connection when errors are encountered discarding the request body, exposing the server to HTTP Request Smuggling

    • Actualiza a 2.4.7-1ubuntu4.22+esm4
    Publicación Actualización
  7. CVE-2021-44224

    Alta · CVSS 8.2EPSS 82,3%Corrección disponible

    Possible NULL dereference or SSRF in forward proxy configurations in Apache HTTP Server 2.4.51 and earlier

    A crafted URI sent to httpd configured as a forward proxy (ProxyRequests on) can cause a crash (NULL pointer dereference) or, for configurations mixing forward and reverse proxy declarations, can allow for requests to be directed to a declared Unix Domain Socket endpoint (Server Side Request Forgery). This issue affects Apache HTTP Server 2.4.7 up to 2.4.51 (included).

    • Actualiza a 2.4.7-1ubuntu4.22+esm3
    Publicación Actualización
  8. CVE-2021-44790

    Crítica · CVSS 9.8EPSS 96,84%Código de explotación públicoCorrección disponible

    Possible buffer overflow when parsing multipart content in mod_lua of Apache HTTP Server 2.4.51 and earlier

    A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.

    • Actualiza a 2.4.7-1ubuntu4.22+esm3
    Publicación Actualización
  9. CVE-2021-39275

    Crítica · CVSS 9.8EPSS 39,4%Corrección disponible

    ap_escape_quotes buffer overflow

    ap_escape_quotes() may write beyond the end of a buffer when given malicious input. No included modules pass untrusted data to these functions, but third-party / external modules may. This issue affects Apache HTTP Server 2.4.48 and earlier.

    • Actualiza a 2.4.7-1ubuntu4.22+esm2
    Publicación Actualización
  10. CVE-2020-35452

    Alta · CVSS 7.3EPSS 54,81%Corrección disponible

    mod_auth_digest possible stack overflow by one nul byte

    Apache HTTP Server versions 2.4.0 to 2.4.46 A specially crafted Digest nonce can cause a stack overflow in mod_auth_digest. There is no report of this overflow being exploitable, nor the Apache HTTP Server team could create one, though some particular compiler and/or compilation option might make it possible, with limited consequences anyway due to the size (a single byte) and the value (zero byte) of the overflow

    • Actualiza a 2.4.7-1ubuntu4.22+esm1
    Publicación Actualización
  11. CVE-2019-17567

    Media · CVSS 5.3EPSS 60,27%Sin corrección publicada

    mod_proxy_wstunnel tunneling of non Upgraded connections

    Apache HTTP Server versions 2.4.6 to 2.4.46 mod_proxy_wstunnel configured on an URL that is not necessarily Upgraded by the origin server was tunneling the whole connection regardless, thus allowing for subsequent requests on the same connection to pass through with no HTTP validation, authentication or authorization possibly configured.

    Publicación Actualización
  12. CVE-2020-11985

    Media · CVSS 5.3EPSS 7,05%Sin corrección publicada

    CVE-2020-11985

    IP address spoofing when proxying using mod_remoteip and mod_rewrite For configurations using proxying with mod_remoteip and certain mod_rewrite rules, an attacker could spoof their IP address for logging and PHP scripts. Note this issue was fixed in Apache HTTP Server 2.4.24 but was retrospectively allocated a low severity CVE in 2020.

    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →