p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de eglibc · Página 3

Vulnerabilidades publicadas para eglibc en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 63

  1. CVE-2020-29573

    Alta · CVSS 7.5EPSS 2,72%Sin corrección publicada

    CVE-2020-29573

    sysdeps/i386/ldbl2mpn.c in the GNU C Library (aka glibc or libc6) before 2.23 on x86 targets has a stack-based buffer overflow if the input to any of the printf family of functions is an 80-bit long double with a non-canonical bit pattern, as seen when passing a \x00\x04\x00\x00\x00\x00\x00\x00\x00\x04 value to sprintf. NOTE: the issue does not affect glibc by default in 2016 or later (i.e., 2.23 or later) because of commits made in 2015 for inlining of C99 math functions through use of GCC built-ins. In other words, the reference to 2.23 is intentional despite the mention of "Fixed for glibc 2.33" in the 26649 reference.

    Publicación Actualización
  2. CVE-2020-1752

    Alta · CVSS 7EPSS 0,55%Sin corrección publicada

    CVE-2020-1752

    A use-after-free vulnerability introduced in glibc upstream version 2.14 was found in the way the tilde expansion was carried out. Directory paths containing an initial tilde followed by a valid username were affected by this issue. A local attacker could exploit this flaw by creating a specially crafted path that, when processed by the glob function, would potentially lead to arbitrary code execution. This was fixed in version 2.32.

    Publicación Actualización
  3. CVE-2020-1751

    Media · CVSS 5.1EPSS 0,54%Sin corrección publicada

    CVE-2020-1751

    An out-of-bounds write vulnerability was found in glibc before 2.31 when handling signal trampolines on PowerPC. Specifically, the backtrace function did not properly check the array bounds when storing the frame address, resulting in a denial of service or potential code execution. The highest threat from this vulnerability is to system availability.

    Publicación Actualización
  4. CVE-2020-6096

    Alta · CVSS 8.1EPSS 5,48%Sin corrección publicada

    CVE-2020-6096

    An exploitable signed comparison vulnerability exists in the ARMv7 memcpy() implementation of GNU glibc 2.30.9000. Calling memcpy() (on ARMv7 targets that utilize the GNU glibc implementation) with a negative value for the 'num' parameter results in a signed comparison vulnerability. If an attacker underflows the 'num' parameter to memcpy(), this vulnerability could lead to undefined behavior such as writing to out-of-bounds memory and potentially remote code execution. Furthermore, this memcpy() implementation allows for program execution to continue in scenarios where a segmentation fault or crash should have occurred. The dangers occur in

    Publicación Actualización
  5. CVE-2020-10029

    Media · CVSS 5.5EPSS 0,76%Sin corrección publicada

    CVE-2020-10029

    The GNU C Library (aka glibc or libc6) before 2.32 could overflow an on-stack buffer during range reduction if an input to an 80-bit long double function contains a non-canonical bit pattern, a seen when passing a 0x5d414141414141410000 value to sinl on x86 targets. This is related to sysdeps/ieee754/ldbl-96/e_rem_pio2l.c.

    Publicación Actualización
  6. CVE-2019-1010023

    Media · CVSS 5.4EPSS 3,07%Sin corrección publicada

    CVE-2019-1010023

    GNU Libc current is affected by: Re-mapping current loaded library with malicious ELF file. The impact is: In worst case attacker may evaluate privileges. The component is: libld. The attack vector is: Attacker sends 2 ELF files to victim and asks to run ldd on it. ldd execute code. NOTE: Upstream comments indicate "this is being treated as a non-security bug and no real threat.

    Publicación Actualización
  7. CVE-2009-5155

    Alta · CVSS 7.5EPSS 3,91%Sin corrección publicada

    CVE-2009-5155

    In the GNU C Library (aka glibc or libc6) before 2.28, parse_reg_exp in posix/regcomp.c misparses alternatives, which allows attackers to cause a denial of service (assertion failure and application exit) or trigger an incorrect result by attempting a regular-expression match.

    Publicación Actualización
  8. CVE-2016-10739

    Media · CVSS 5.3EPSS 0,48%Sin corrección publicada

    CVE-2016-10739

    In the GNU C Library (aka glibc or libc6) through 2.28, the getaddrinfo function would successfully parse a string that contained an IPv4 address followed by whitespace and arbitrary characters, which could lead applications to incorrectly assume that it had parsed a valid string, without the possibility of embedded HTTP headers or other potentially dangerous substrings.

    Publicación Actualización
  9. CVE-2019-6488

    Alta · CVSS 7.8EPSS 0,45%Sin corrección publicada

    CVE-2019-6488

    The string component in the GNU C Library (aka glibc or libc6) through 2.28, when running on the x32 architecture, incorrectly attempts to use a 64-bit register for size_t in assembly codes, which can lead to a segmentation fault or possibly unspecified other impact, as demonstrated by a crash in __memmove_avx_unaligned_erms in sysdeps/x86_64/multiarch/memmove-vec-unaligned-erms.S during a memcpy.

    Publicación Actualización
  10. CVE-2018-11236

    Crítica · CVSS 9.8EPSS 6,92%Corrección disponible

    CVE-2018-11236

    stdlib/canonicalize.c in the GNU C Library (aka glibc or libc6) 2.27 and earlier, when processing very long pathname arguments to the realpath function, could encounter an integer overflow on 32-bit architectures, leading to a stack-based buffer overflow and, potentially, arbitrary code execution.

    • Actualiza a 2.19-0ubuntu6.15+esm3
    Publicación Actualización
  11. CVE-2018-6485

    Crítica · CVSS 9.8EPSS 4,69%Corrección disponible

    CVE-2018-6485

    An integer overflow in the implementation of the posix_memalign in memalign functions in the GNU C Library (aka glibc or libc6) 2.26 and earlier could cause these functions to return a pointer to a heap area that is too small, potentially leading to heap corruption.

    • Actualiza a 2.19-0ubuntu6.15+esm1
    Publicación Actualización
  12. CVE-2014-9984

    Crítica · CVSS 9.8EPSS 4,48%Corrección disponible

    CVE-2014-9984

    nscd in the GNU C Library (aka glibc or libc6) before version 2.20 does not correctly compute the size of an internal buffer when processing netgroup requests, possibly leading to an nscd daemon crash or code execution as the user running nscd.

    • Actualiza a 2.19-0ubuntu6.15+esm3
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →