p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de unbound · Página 3

Vulnerabilidades publicadas para unbound en los últimos 30 días: 5. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 53

  1. CVE-2025-5994

    Alta · CVSS 8.7EPSS 0,22%Sin corrección publicada

    Cache poisoning via the ECS-enabled Rebirthday Attack

    A multi-vendor cache poisoning vulnerability named 'Rebirthday Attack' has been discovered in caching resolvers that support EDNS Client Subnet (ECS). Unbound is also vulnerable when compiled with ECS support, i.e., '--enable-subnet', AND configured to send ECS information along with queries to upstream name servers, i.e., at least one of the 'send-client-subnet', 'client-subnet-zone' or 'client-subnet-always-forward' options is used. Resolvers supporting ECS need to segregate outgoing queries to accommodate for different outgoing ECS information. This re-opens up resolvers to a birthday paradox attack (Rebirthday Attack) that tries to match

    Publicación Actualización
  2. CVE-2024-8508

    Media · CVSS 5.3EPSS 0,8%Corrección disponible

    Unbounded name compression could lead to Denial of Service

    NLnet Labs Unbound up to and including version 1.21.0 contains a vulnerability when handling replies with very large RRsets that it needs to perform name compression for. Malicious upstreams responses with very large RRsets can cause Unbound to spend a considerable time applying name compression to downstream replies. This can lead to degraded performance and eventually denial of service in well orchestrated attacks. The vulnerability can be exploited by a malicious actor querying Unbound for the specially crafted contents of a malicious zone with very large RRsets. Before Unbound replies to the query it will try to apply name compression whi

    • Actualiza a 1.4.22-1ubuntu4.14.04.3+esm2
    Publicación Actualización
  3. CVE-2024-43168

    Media · CVSS 4.8EPSS 0,31%Corrección disponible

    Unbound: heap-buffer-overflow in unbound

    DISPUTE NOTE: this issue does not pose a security risk as it (according to analysis by the original software developer, NLnet Labs) falls within the expected functionality and security controls of the application. Red Hat has made a claim that there is a security risk within Red Hat products. NLnet Labs has no further information about the claim, and suggests that affected Red Hat customers refer to available Red Hat documentation or support channels. ORIGINAL DESCRIPTION: A heap-buffer-overflow flaw was found in the cfg_mark_ports function within Unbound's config_file.c, which can lead to memory corruption. This issue could allow an attacker

    • Actualiza a 1.4.22-1ubuntu4.14.04.3+esm1
    Publicación Actualización
  4. CVE-2024-43167

    Baja · CVSS 2.8EPSS 0,39%Corrección disponible

    Unbound: null pointer dereference in unbound

    DISPUTE NOTE: this issue does not pose a security risk as it (according to analysis by the original software developer, NLnet Labs) falls within the expected functionality and security controls of the application. Red Hat has made a claim that there is a security risk within Red Hat products. NLnet Labs has no further information about the claim, and suggests that affected Red Hat customers refer to available Red Hat documentation or support channels. ORIGINAL DESCRIPTION: A NULL pointer dereference flaw was found in the ub_ctx_set_fwd function in Unbound. This issue could allow an attacker who can invoke specific sequences of API calls to ca

    • Actualiza a 1.4.22-1ubuntu4.14.04.3+esm1
    Publicación Actualización
  5. CVE-2024-33655

    Alta · CVSS 7.5EPSS 1,74%Sin corrección publicada

    CVE-2024-33655

    The DNS protocol in RFC 1035 and updates allows remote attackers to cause a denial of service (resource consumption) by arranging for DNS queries to be accumulated for seconds, such that responses are later sent in a pulsing burst (which can be considered traffic amplification in some cases), aka the "DNSBomb" issue.

    Publicación Actualización
  6. CVE-2023-50868

    Alta · CVSS 7.5EPSS 74,3%Corrección disponible

    CVE-2023-50868

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations.

    • Actualiza a 1.4.22-1ubuntu4.14.04.3+esm5
    Publicación Actualización
  7. CVE-2023-50387

    Alta · CVSS 7.5EPSS 99,99%Corrección disponible

    CVE-2023-50387

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG records, the protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.

    • Actualiza a 1.4.22-1ubuntu4.14.04.3+esm5
    Publicación Actualización
  8. CVE-2022-3204

    Alta · CVSS 7.5EPSS 1,65%Sin corrección publicada

    NRDelegation Attack

    A vulnerability named 'Non-Responsive Delegation Attack' (NRDelegation Attack) has been discovered in various DNS resolving software. The NRDelegation Attack works by having a malicious delegation with a considerable number of non responsive nameservers. The attack starts by querying a resolver for a record that relies on those unresponsive nameservers. The attack can cause a resolver to spend a lot of time/resources resolving records under a malicious delegation point where a considerable number of unresponsive NS records reside. It can trigger high CPU usage in some resolver implementations that continually look in the cache for resolved NS

    Publicación Actualización
  9. CVE-2022-30699

    Media · CVSS 6.5EPSS 1,16%Sin corrección publicada

    Novel "ghost domain names" attack by updating almost expired delegation information

    NLnet Labs Unbound, up to and including version 1.16.1, is vulnerable to a novel type of the "ghost domain names" attack. The vulnerability works by targeting an Unbound instance. Unbound is queried for a rogue domain name when the cached delegation information is about to expire. The rogue nameserver delays the response so that the cached delegation information is expired. Upon receiving the delayed answer containing the delegation information, Unbound overwrites the now expired entries. This action can be repeated when the delegation information is about to expire making the rogue delegation information ever-updating. From version 1.16.2 on

    Publicación Actualización
  10. CVE-2022-30698

    Media · CVSS 6.5EPSS 1,16%Sin corrección publicada

    Novel "ghost domain names" attack by introducing subdomain delegations

    NLnet Labs Unbound, up to and including version 1.16.1 is vulnerable to a novel type of the "ghost domain names" attack. The vulnerability works by targeting an Unbound instance. Unbound is queried for a subdomain of a rogue domain name. The rogue nameserver returns delegation information for the subdomain that updates Unbound's delegation cache. This action can be repeated before expiry of the delegation information by querying Unbound for a second level subdomain which the rogue nameserver provides new delegation information. Since Unbound is a child-centric resolver, the ever-updating child delegation information can keep a rogue domain na

    Publicación Actualización
  11. CVE-2020-28935

    Media · CVSS 5.5EPSS 0,49%Sin corrección publicada

    Local symlink attack in Unbound and NSD

    NLnet Labs Unbound, up to and including version 1.12.0, and NLnet Labs NSD, up to and including version 4.3.3, contain a local vulnerability that would allow for a local symlink attack. When writing the PID file, Unbound and NSD create the file if it is not there, or open an existing file for writing. In case the file was already present, they would follow symlinks if the file happened to be a symlink instead of a regular file. An additional chown of the file would then take place after it was written, making the user Unbound/NSD is supposed to run as the new owner of the file. If an attacker has local access to the user Unbound/NSD runs as,

    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →