p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de ansible · Página 3

Vulnerabilidad publicada para ansible en los últimos 30 días: 1. En el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 53

  1. CVE-2020-10684

    Alta · CVSS 7.9EPSS 0,33%Sin corrección publicada

    CVE-2020-10684

    A flaw was found in Ansible Engine, all versions 2.7.x, 2.8.x and 2.9.x prior to 2.7.17, 2.8.9 and 2.9.6 respectively, when using ansible_facts as a subkey of itself and promoting it to a variable when inject is enabled, overwriting the ansible_facts after the clean. An attacker could take advantage of this by altering the ansible_facts, such as ansible_hosts, users and any other key data which would lead into privilege escalation or code injection.

    Publicación Actualización
  2. CVE-2020-1738

    Baja · CVSS 3.9EPSS 0,4%Sin corrección publicada

    CVE-2020-1738

    A flaw was found in Ansible Engine when the module package or service is used and the parameter 'use' is not specified. If a previous task is executed with a malicious user, the module sent can be selected by the attacker using the ansible facts file. All versions in 2.7.x, 2.8.x and 2.9.x branches are believed to be vulnerable.

    Publicación Actualización
  3. CVE-2020-1740

    Baja · CVSS 3.9EPSS 0,36%Sin corrección publicada

    CVE-2020-1740

    A flaw was found in Ansible Engine when using Ansible Vault for editing encrypted files. When a user executes "ansible-vault edit", another user on the same computer can read the old and new secret, as it is created in a temporary file with mkstemp and the returned file descriptor is closed and the method write_data is called to write the existing secret in the file. This method will delete the file before recreating it insecurely. All versions in 2.7.x, 2.8.x and 2.9.x branches are believed to be vulnerable.

    Publicación Actualización
  4. CVE-2020-1735

    Media · CVSS 4.2EPSS 0,47%Sin corrección publicada

    CVE-2020-1735

    A flaw was found in the Ansible Engine when the fetch module is used. An attacker could intercept the module, inject a new path, and then choose a new destination path on the controller node. All versions in 2.7.x, 2.8.x and 2.9.x branches are believed to be vulnerable.

    Publicación Actualización
  5. CVE-2020-1736

    Baja · CVSS 2.2EPSS 0,4%Sin corrección publicada

    CVE-2020-1736

    A flaw was found in Ansible Engine when a file is moved using atomic_move primitive as the file mode cannot be specified. This sets the destination files world-readable if the destination file does not exist and if the file exists, the file could be changed to have less restrictive permissions before the move. This could lead to the disclosure of sensitive data. All versions in 2.7.x, 2.8.x and 2.9.x branches are believed to be vulnerable.

    Publicación Actualización
  6. CVE-2020-1753

    Media · CVSS 5EPSS 0,51%Sin corrección publicada

    CVE-2020-1753

    A security flaw was found in Ansible Engine, all Ansible 2.7.x versions prior to 2.7.17, all Ansible 2.8.x versions prior to 2.8.11 and all Ansible 2.9.x versions prior to 2.9.7, when managing kubernetes using the k8s module. Sensitive parameters such as passwords and tokens are passed to kubectl from the command line, not using an environment variable or an input configuration file. This will disclose passwords and tokens from process list and no_log directive from debug module would not have any effect making these secrets being disclosed on stdout and log files.

    Publicación Actualización
  7. CVE-2020-1739

    Baja · CVSS 3.9EPSS 0,36%Corrección disponible

    CVE-2020-1739

    A flaw was found in Ansible 2.7.16 and prior, 2.8.8 and prior, and 2.9.5 and prior when a password is set with the argument "password" of svn module, it is used on svn command line, disclosing to other users within the same node. An attacker could take advantage by reading the cmdline file from that particular PID on the procfs.

    • Actualiza a 2.0.0.2-2ubuntu1.3+esm5
    Publicación Actualización
  8. CVE-2020-1733

    Media · CVSS 5EPSS 0,4%Corrección disponible

    CVE-2020-1733

    A race condition flaw was found in Ansible Engine 2.7.17 and prior, 2.8.9 and prior, 2.9.6 and prior when running a playbook with an unprivileged become user. When Ansible needs to run a module with become user, the temporary directory is created in /var/tmp. This directory is created with "umask 77 && mkdir -p <dir>"; this operation does not fail if the directory already exists and is owned by another user. An attacker could take advantage to gain control of the become user as the target directory can be retrieved by iterating '/proc/<pid>/cmdline'.

    • Actualiza a 2.0.0.2-2ubuntu1.3+esm1
    Publicación Actualización
  9. CVE-2020-1737

    Alta · CVSS 7.5EPSS 0,36%Sin corrección publicada

    CVE-2020-1737

    A flaw was found in Ansible 2.7.17 and prior, 2.8.9 and prior, and 2.9.6 and prior when using the Extract-Zip function from the win_unzip module as the extracted file(s) are not checked if they belong to the destination folder. An attacker could take advantage of this flaw by crafting an archive anywhere in the file system, using a path traversal. This issue is fixed in 2.10.

    Publicación Actualización
  10. CVE-2020-1734

    Alta · CVSS 7.4EPSS 0,46%Sin corrección publicada

    CVE-2020-1734

    A flaw was found in the pipe lookup plugin of ansible. Arbitrary commands can be run, when the pipe lookup plugin uses subprocess.Popen() with shell=True, by overwriting ansible facts and the variable is not escaped by quote plugin. An attacker could take advantage and run arbitrary commands by overwriting the ansible facts.

    Publicación Actualización
  11. CVE-2019-10206

    Media · CVSS 6.4EPSS 1,52%Corrección disponible

    CVE-2019-10206

    ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt passwords by expanding them from templates as they could contain special characters. Passwords should be wrapped to prevent templates trigger and exposing them.

    • Actualiza a 2.0.0.2-2ubuntu1.3+esm5
    Publicación Actualización
  12. CVE-2019-14846

    Alta · CVSS 7.3EPSS 0,51%Corrección disponible

    CVE-2019-14846

    In Ansible, all Ansible Engine versions up to ansible-engine 2.8.5, ansible-engine 2.7.13, ansible-engine 2.6.19, were logging at the DEBUG level which lead to a disclosure of credentials if a plugin used a library that logged credentials at the DEBUG level. This flaw does not affect Ansible modules, as those are executed in a separate process.

    • Actualiza a 2.0.0.2-2ubuntu1.3+esm5
    Publicación Actualización
  13. CVE-2016-8614

    Media · CVSS 6.3EPSS 2,46%Corrección disponible

    CVE-2016-8614

    A flaw was found in Ansible before version 2.2.0. The apt_key module does not properly verify key fingerprints, allowing remote adversary to create an OpenPGP key which matches the short key ID and inject this key instead of the correct key.

    • Actualiza a 2.0.0.2-2ubuntu1.3+esm5
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →