p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de ffmpeg · Página 5

Vulnerabilidades publicadas para ffmpeg en los últimos 30 días: 10. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 98

  1. CVE-2024-35366

    Crítica · CVSS 9.1EPSS 0,65%Corrección disponible

    CVE-2024-35366

    FFmpeg n6.1.1 is Integer Overflow. The vulnerability exists in the parse_options function of sbgdec.c within the libavformat module. When parsing certain options, the software does not adequately validate the input. This allows for negative duration values to be accepted without proper bounds checking.

    • Actualiza a 7:4.4.2-0ubuntu0.22.04.1+esm9
    Publicación Actualización
  2. CVE-2024-7055

    Media · CVSS 6.9EPSS 1,44%Corrección disponible

    FFmpeg pnmdec.c pnm_decode_frame heap-based overflow

    A vulnerability was found in FFmpeg up to 7.0.1. It has been classified as critical. This affects the function pnm_decode_frame in the library /libavcodec/pnmdec.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 7.0.2 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-273651.

    • Actualiza a 7:4.4.2-0ubuntu0.22.04.1+esm9
    Publicación Actualización
  3. CVE-2024-32230

    Alta · CVSS 7.8EPSS 0,35%Corrección disponible

    CVE-2024-32230

    FFmpeg 7.0 is vulnerable to Buffer Overflow. There is a negative-size-param bug at libavcodec/mpegvideo_enc.c:1216:21 in load_input_picture in FFmpeg7.0

    • Actualiza a 7:4.4.2-0ubuntu0.22.04.1+esm5
    Publicación Actualización
  4. CVE-2023-51794

    Alta · CVSS 7.8EPSS 0,22%Corrección disponible

    CVE-2023-51794

    Buffer Overflow vulnerability in Ffmpeg v.N113007-g8d24a28d06 allows a local attacker to execute arbitrary code via the libavfilter/af_stereowiden.c:120:69.

    • Actualiza a 7:4.4.2-0ubuntu0.22.04.1+esm4
    Publicación Actualización
  5. USN-6449-2

    Sin evaluarCorrección disponible

    ffmpeg regression

    USN-6449-1 fixed vulnerabilities in FFmpeg. Unfortunately that update could introduce a regression in tools using an FFmpeg library, like VLC. This updated fixes the problem. We apologize for the inconvenience. Original advisory details: It was discovered that FFmpeg incorrectly managed memory resulting in a memory leak. An attacker could possibly use this issue to cause a denial of service via application crash. This issue only affected Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2020-22038) It was discovered that FFmpeg incorrectly handled certain input files, leading to an integer overflow. An attacker could possibly use this iss

    • Actualiza a 7:4.4.2-0ubuntu0.22.04.1+esm3
    Publicación Actualización
  6. CVE-2022-48434

    Alta · CVSS 8.1EPSS 1,52%Corrección disponible

    CVE-2022-48434

    libavcodec/pthread_frame.c in FFmpeg before 5.1.2, as used in VLC and other products, leaves stale hwaccel state in worker threads, which allows attackers to trigger a use-after-free and execute arbitrary code in some circumstances (e.g., hardware re-initialization upon a mid-video SPS change when Direct3D11 is used).

    • Actualiza a 7:4.4.2-0ubuntu0.22.04.1+esm2
    Publicación Actualización
  7. CVE-2022-3341

    Media · CVSS 5.3EPSS 0,86%Corrección disponible

    CVE-2022-3341

    A null pointer dereference issue was discovered in 'FFmpeg' in decode_main_header() function of libavformat/nutdec.c file. The flaw occurs because the function lacks check of the return value of avformat_new_stream() and triggers the null pointer dereference error, causing an application to crash.

    • Actualiza a 7:4.4.2-0ubuntu0.22.04.1+esm1
    Publicación Actualización
  8. CVE-2022-3964

    Media · CVSS 4.3EPSS 3,78%Corrección disponible

    ffmpeg QuickTime RPZA Video Encoder rpzaenc.c out-of-bounds

    A vulnerability classified as problematic has been found in ffmpeg. This affects an unknown part of the file libavcodec/rpzaenc.c of the component QuickTime RPZA Video Encoder. The manipulation of the argument y_size leads to out-of-bounds read. It is possible to initiate the attack remotely. The name of the patch is 92f9b28ed84a77138105475beba16c146bdaf984. It is recommended to apply a patch to fix this issue. The associated identifier of this vulnerability is VDB-213543.

    • Actualiza a 7:4.4.2-0ubuntu0.22.04.1+esm1
    Publicación Actualización
  9. CVE-2014-5271

    Sin evaluarEPSS 4,7%Sin corrección publicada

    CVE-2014-5271

    Heap-based buffer overflow in the encode_slice function in libavcodec/proresenc_kostya.c in FFMpeg before 1.1.14, 1.2.x before 1.2.8, 2.x before 2.2.7, and 2.3.x before 2.3.3 and Libav before 10.5 allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via unspecified vectors.

    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →