p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de php-twig · Página 2

Vulnerabilidades publicadas para php-twig en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 22

  1. CVE-2024-45411

    Alta · CVSS 8.6EPSS 0,85%Corrección disponible

    Twig has a possible sandbox bypass

    Twig is a template language for PHP. Under some circumstances, the sandbox security checks are not run which allows user-contributed templates to bypass the sandbox restrictions. This vulnerability is fixed in 1.44.8, 2.16.1, and 3.14.0.

    • Actualiza a 3.3.8-2ubuntu4+esm2
    Publicación Actualización
  2. CVE-2022-39261

    Alta · CVSS 7.5EPSS 3,17%Corrección disponible

    Twig may load a template outside a configured directory when using the filesystem loader

    Twig is a template language for PHP. Versions 1.x prior to 1.44.7, 2.x prior to 2.15.3, and 3.x prior to 3.4.3 encounter an issue when the filesystem loader loads templates for which the name is a user input. It is possible to use the `source` or `include` statement to read arbitrary files from outside the templates' directory when using a namespace like `@somewhere/../some.file`. In such a case, validation is bypassed. Versions 1.44.7, 2.15.3, and 3.4.3 contain a fix for validation of such template names. There are no known workarounds aside from upgrading.

    • Actualiza a 3.3.8-2ubuntu4+esm1
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →