p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de ffmpeg · Page n° 5

Vulnérabilités publiées pour ffmpeg au cours des 30 derniers jours : 10. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 418

  1. CVE-2024-35366

    Critique · CVSS 9.1EPSS 0,65%Correctif disponible

    CVE-2024-35366

    FFmpeg n6.1.1 is Integer Overflow. The vulnerability exists in the parse_options function of sbgdec.c within the libavformat module. When parsing certain options, the software does not adequately validate the input. This allows for negative duration values to be accepted without proper bounds checking.

    • Mettez à jour vers 7:5.1.5-0+deb12u1
    Publication Mise à jour
  2. CVE-2024-7272

    Moyenne · CVSS 6.9EPSS 1,2%Correctif disponible

    FFmpeg swresample.c fill_audiodata heap-based overflow

    A vulnerability, which was classified as critical, was found in FFmpeg up to 5.1.5. This affects the function fill_audiodata of the file /libswresample/swresample.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. This issue was fixed in version 6.0 by 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 but a backport for 5.1 was forgotten. The exploit has been disclosed to the public and may be used. Upgrading to version 5.1.6 and 6.0 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 is able to address this issue. It is recommended to upgrade the affected component.

    • Mettez à jour vers 7:5.1.6-0+deb12u1
    Publication Mise à jour
  3. CVE-2024-7055

    Moyenne · CVSS 6.9EPSS 1,44%Correctif disponible

    FFmpeg pnmdec.c pnm_decode_frame heap-based overflow

    A vulnerability was found in FFmpeg up to 7.0.1. It has been classified as critical. This affects the function pnm_decode_frame in the library /libavcodec/pnmdec.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 7.0.2 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-273651.

    • Mettez à jour vers 7:5.1.6-0+deb12u1
    Publication Mise à jour
  4. CVE-2024-31582

    Élevée · CVSS 7.8EPSS 0,34%Correctif disponible

    CVE-2024-31582

    FFmpeg version n6.1 was discovered to contain a heap buffer overflow vulnerability in the draw_block_rectangle function of libavfilter/vf_codecview.c. This vulnerability allows attackers to cause undefined behavior or a Denial of Service (DoS) via crafted input.

    • Mettez à jour vers 7:5.1.7-0+deb12u1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →