p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de ffmpeg · Page n° 4

Vulnérabilités publiées pour ffmpeg au cours des 30 derniers jours : 10. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 433

  1. CVE-2025-7700

    Moyenne · CVSS 5.3EPSS 0,39%Correctif disponible

    Ffmpeg: null pointer dereference in ffmpeg als decoder (libavcodec/alsdec.c)

    A flaw was found in FFmpeg’s ALS audio decoder, where it does not properly check for memory allocation failures. This can cause the application to crash when processing certain malformed audio files. While it does not lead to data theft or system control, it can be used to disrupt services and cause a denial of service.

    • Mettez à jour vers 7:7.1.2-0+deb13u1
    Publication Mise à jour
  2. CVE-2025-59733

    Élevée · CVSS 8.7EPSS 0,18%Correctif disponible

    Heap-buffer-overflow write in FFmpeg EXR dwa_uncompress

    When decoding an OpenEXR file that uses DWAA or DWAB compression, there's an implicit assumption that all image channels have the same pixel type (and size), and that if there are four channels, the first four are "B", "G", "R" and "A". The channel parsing code can be found in decode_header. The buffer td->uncompressed_data is allocated in decode_block based on the xsize, ysize and computed current_channel_offset. The function dwa_uncompress then assumes at [5] that if there are 4 channels, these are "B", "G", "R" and "A", and in the calculations at [6] and [7] that all channels are of the same type, which matches the type of the main color

    • Mettez à jour vers 7:7.1.2-0+deb13u1
    Publication Mise à jour
  3. CVE-2025-59732

    Élevée · CVSS 8.7EPSS 0,19%Correctif disponible

    Heap-buffer-overflow write in FFmpeg EXR dwa_uncompress

    When decoding an OpenEXR file that uses DWAA or DWAB compression, there's an implicit assumption that the height and width are divisible by 8. If the height or width of the image is not divisible by 8, the copy loops at [0] and [1] will continue to write until the next multiple of 8. The buffer td->uncompressed_data is allocated in decode_block based on the precise height and width of the image, so the "rounded-up" multiple of 8 in the copy loop can exceed the buffer bounds, and the write block starting at [2] can corrupt following heap memory. We recommend upgrading to version 8.0 or beyond.

    • Mettez à jour vers 7:7.1.2-0+deb13u1
    Publication Mise à jour
  4. CVE-2025-59731

    Moyenne · CVSS 6.9EPSS 0,17%Correctif disponible

    Heap-buffer-overflow write in FFmpeg EXR dwa_uncompress

    When decoding an OpenEXR file that uses DWAA or DWAB compression, the specified raw length of run-length-encoded data is not checked when using it to calculate the output data. We read rle_raw_size from the input file at [0], we decompress and decode into the buffer td->rle_raw_data of size rle_raw_size at [1], and then at [2] we will access entries in this buffer up to (td->xsize - 1) * (td->ysize - 1) + rle_raw_size / 2, which may exceed rle_raw_size. We recommend upgrading to version 8.0 or beyond.

    • Mettez à jour vers 7:7.1.2-0+deb13u1
    Publication Mise à jour
  5. CVE-2025-9951

    Élevée · CVSS 7.2EPSS 0,44%Correctif disponible

    Remote code execution via Heap Buffer Overflow in FFmpeg JPEG2000

    A heap-buffer-overflow write exists in jpeg2000dec FFmpeg which allows an attacker to potentially gain remote code execution or cause denial of service via the channel definition cdef atom of JPEG2000.

    • Mettez à jour vers 7:7.1.2-0+deb13u1
    Publication Mise à jour
  6. CVE-2025-1816

    Moyenne · CVSS 5.3EPSS 0,54%Correctif disponible

    FFmpeg IAMF File iamf_parse.c audio_element_obu memory leak

    A vulnerability classified as problematic has been found in FFmpeg up to 6e26f57f672b05e7b8b052007a83aef99dc81ccb. This affects the function audio_element_obu of the file libavformat/iamf_parse.c of the component IAMF File Handler. The manipulation of the argument num_parameters leads to memory leak. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. The identifier of the patch is 0526535cd58444dd264e810b2f3348b4d96cff3b. It is recommended to apply a patch to fix this issue.

    • Mettez à jour vers 7:7.1.1-1
    Publication Mise à jour
  7. CVE-2025-1594

    Moyenne · CVSS 5.3EPSS 0,6%Correctif disponible

    FFmpeg AAC Encoder aacenc_tns.c ff_aac_search_for_tns stack-based overflow

    A vulnerability, which was classified as critical, was found in FFmpeg up to 7.1. This affects the function ff_aac_search_for_tns of the file libavcodec/aacenc_tns.c of the component AAC Encoder. The manipulation leads to stack-based buffer overflow. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used.

    • Mettez à jour vers 7:7.1.2-0+deb13u1
    Publication Mise à jour
  8. CVE-2025-0518

    Moyenne · CVSS 4.8EPSS 0,38%Correctif disponible

    Unchecked sscanf return value which leads to memory data leak

    Unchecked Return Value, Out-of-bounds Read vulnerability in FFmpeg allows Read Sensitive Constants Within an Executable. This vulnerability is associated with program files https://github.Com/FFmpeg/FFmpeg/blob/master/libavfilter/af_pan.C . This issue affects FFmpeg: 7.1. Issue was fixed:  https://github.com/FFmpeg/FFmpeg/commit/b5b6391d64807578ab872dc58fb8aa621dcfc38a https://github.com/FFmpeg/FFmpeg/commit/b5b6391d64807578ab872dc58fb8aa621dcfc38a This issue was discovered by: Simcha Kosman

    • Mettez à jour vers 7:7.1.1-1
    Publication Mise à jour
  9. CVE-2023-6604

    Moyenne · CVSS 5.3EPSS 0,47%Correctif disponible

    Ffmpeg: hls xbin demuxer dos amplification in ffmpeg

    A flaw was found in FFmpeg. This vulnerability allows unexpected additional CPU load and storage consumption, potentially leading to degraded performance or denial of service via the demuxing of arbitrary data as XBIN-formatted data without proper format validation.

    • Mettez à jour vers 7:7.1.1-1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →