p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de kubernetes · Page n° 3

Vulnérabilité publiée pour kubernetes au cours des 30 derniers jours : 1. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 50

  1. CVE-2019-11248

    Moyenne · CVSS 6.5EPSS 75,06%Code d’exploitation publicCorrectif disponible

    Kubernetes kubelet exposes /debug/pprof info on healthz port

    The debugging endpoint /debug/pprof is exposed over the unauthenticated Kubelet healthz port. The go pprof endpoint is exposed over the Kubelet's healthz port. This debugging endpoint can potentially leak sensitive information such as internal Kubelet memory addresses and configuration, or for limited denial of service. Versions prior to 1.15.0, 1.14.4, 1.13.8, and 1.12.10 are affected. The issue is of medium severity, but not exposed by the default configuration.

    • Mettez à jour vers 1.17.4-1
    Publication Mise à jour
  2. CVE-2019-11247

    Moyenne · CVSS 5EPSS 2,15%Correctif disponible

    Kubernetes kube-apiserver allows access to custom resources via wrong scope

    The Kubernetes kube-apiserver mistakenly allows access to a cluster-scoped custom resource if the request is made as if the resource were namespaced. Authorizations for the resource accessed in this manner are enforced using roles and role bindings within the namespace, meaning that a user with access only to a resource in one namespace could create, view update or delete the cluster-scoped resource (according to their namespace role privileges). Kubernetes affected versions include versions prior to 1.13.9, versions prior to 1.14.5, versions prior to 1.15.2, and versions 1.7, 1.8, 1.9, 1.10, 1.11, 1.12.

    • Mettez à jour vers 1.17.4-1
    Publication Mise à jour
  3. CVE-2019-9946

    Élevée · CVSS 7.5EPSS 3,16%Correctif disponible

    CVE-2019-9946

    Cloud Native Computing Foundation (CNCF) CNI (Container Networking Interface) 0.7.4 has a network firewall misconfiguration which affects Kubernetes. The CNI 'portmap' plugin, used to setup HostPorts for CNI, inserts rules at the front of the iptables nat chains; which take precedence over the KUBE- SERVICES chain. Because of this, the HostPort/portmap rule could match incoming traffic even if there were better fitting, more specific service definition rules like NodePorts later in the chain. The issue is fixed in CNI 0.7.5 and Kubernetes 1.11.9, 1.12.7, 1.13.5, and 1.14.0.

    • Mettez à jour vers 1.17.4-1
    Publication Mise à jour
  4. CVE-2019-1002100

    Moyenne · CVSS 6.5EPSS 16,93%Correctif disponible

    CVE-2019-1002100

    In all Kubernetes versions prior to v1.11.8, v1.12.6, and v1.13.4, users that are authorized to make patch requests to the Kubernetes API Server can send a specially crafted patch of type "json-patch" (e.g. `kubectl patch --type json` or `"Content-Type: application/json-patch+json"`) that consumes excessive resources while processing, causing a Denial of Service on the API Server.

    • Mettez à jour vers 1.17.4-1
    Publication Mise à jour
  5. CVE-2018-1002105

    Critique · CVSS 9.8EPSS 86,98%Code d’exploitation publicCorrectif disponible

    CVE-2018-1002105

    In all Kubernetes versions prior to v1.10.11, v1.11.5, and v1.12.3, incorrect handling of error responses to proxied upgrade requests in the kube-apiserver allowed specially crafted requests to establish a connection through the Kubernetes API server to backend servers, then send arbitrary requests over the same connection directly to the backend, authenticated with the Kubernetes API server's TLS credentials used to establish the backend connection.

    • Mettez à jour vers 1.17.4-1
    Publication Mise à jour
  6. CVE-2016-7075

    Élevée · CVSS 7.5EPSS 1,57%Correctif disponible

    CVE-2016-7075

    It was found that Kubernetes as used by Openshift Enterprise 3 did not correctly validate X.509 client intermediate certificate host name fields. An attacker could use this flaw to bypass authentication requirements by using a specially crafted X.509 certificate.

    • Mettez à jour vers 1.5.5+dfsg-1
    Publication Mise à jour
  7. CVE-2017-1002102

    Élevée · CVSS 7.1EPSS 1,1%Correctif disponible

    CVE-2017-1002102

    In Kubernetes versions 1.3.x, 1.4.x, 1.5.x, 1.6.x and prior to versions 1.7.14, 1.8.9 and 1.9.4 containers using a secret, configMap, projected or downwardAPI volume can trigger deletion of arbitrary files/directories from the nodes where they are running.

    • Mettez à jour vers 1.7.16+dfsg-1
    Publication Mise à jour
  8. CVE-2017-1002101

    Élevée · CVSS 8.8EPSS 13,27%Correctif disponible

    CVE-2017-1002101

    In Kubernetes versions 1.3.x, 1.4.x, 1.5.x, 1.6.x and prior to versions 1.7.14, 1.8.9 and 1.9.4 containers using subpath volume mounts with any volume type (including non-privileged pods, subject to file permissions) can access files/directories outside of the volume, including the host's filesystem.

    • Mettez à jour vers 1.7.16+dfsg-1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →