p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de mediawiki · Page n° 5

Vulnérabilités publiées pour mediawiki au cours des 30 derniers jours : 9. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 295

  1. CVE-2024-34506

    Élevée · CVSS 7.5EPSS 0,9%Correctif disponible

    CVE-2024-34506

    An issue was discovered in includes/specials/SpecialMovePage.php in MediaWiki before 1.39.7, 1.40.x before 1.40.3, and 1.41.x before 1.41.1. If a user with the necessary rights to move the page opens Special:MovePage for a page with tens of thousands of subpages, then the page will exceed the maximum request time, leading to a denial of service.

    • Mettez à jour vers 1:1.39.7-1
    Publication Mise à jour
  2. CVE-2023-45362

    Moyenne · CVSS 4.3EPSS 0,78%Correctif disponible

    CVE-2023-45362

    An issue was discovered in DifferenceEngine.php in MediaWiki before 1.35.12, 1.36.x through 1.39.x before 1.39.5, and 1.40.x before 1.40.1. diff-multi-sameuser (aka "X intermediate revisions by the same user not shown") ignores username suppression. This is an information leak.

    • Mettez à jour vers 1:1.39.5-1
    Publication Mise à jour
  3. CVE-2023-45360

    Moyenne · CVSS 5.4EPSS 0,66%Correctif disponible

    CVE-2023-45360

    An issue was discovered in MediaWiki before 1.35.12, 1.36.x through 1.39.x before 1.39.5, and 1.40.x before 1.40.1. There is XSS in youhavenewmessagesmanyusers and youhavenewmessages i18n messages. This is related to MediaWiki:Youhavenewmessagesfromusers.

    • Mettez à jour vers 1:1.39.5-1
    Publication Mise à jour
  4. CVE-2023-45364

    Moyenne · CVSS 5.3EPSS 0,5%Correctif disponible

    CVE-2023-45364

    An issue was discovered in includes/page/Article.php in MediaWiki 1.36.x through 1.39.x before 1.39.5 and 1.40.x before 1.40.1. Deleted revision existence is leaked due to incorrect permissions being checked. This reveals that a given revision ID belonged to the given page title, and its timestamp, both of which are not supposed to be public information.

    • Mettez à jour vers 1:1.39.5-1
    Publication Mise à jour
  5. CVE-2023-45363

    Élevée · CVSS 7.5EPSS 23,78%Correctif disponible

    CVE-2023-45363

    An issue was discovered in ApiPageSet.php in MediaWiki before 1.35.12, 1.36.x through 1.39.x before 1.39.5, and 1.40.x before 1.40.1. It allows attackers to cause a denial of service (unbounded loop and RequestTimeoutException) when querying pages redirected to other variants with redirects and converttitles set.

    • Mettez à jour vers 1:1.39.5-1
    Publication Mise à jour
  6. CVE-2023-3550

    Élevée · CVSS 7.3EPSS 1,38%Correctif disponible

    Stored XSS leads to privilege escalation in MediaWiki v1.40.0

    Mediawiki v1.40.0 does not validate namespaces used in XML files. Therefore, if the instance administrator allows XML file uploads, a remote attacker with a low-privileged user account can use this exploit to become an administrator by sending a malicious link to the instance administrator.

    • Mettez à jour vers 1:1.39.5-1
    Publication Mise à jour
  7. CVE-2023-36674

    Moyenne · CVSS 5.3EPSS 0,74%Correctif disponible

    CVE-2023-36674

    An issue was discovered in MediaWiki before 1.35.11, 1.36.x through 1.38.x before 1.38.7, 1.39.x before 1.39.4, and 1.40.x before 1.40.1. It is possible to bypass the Bad image list (aka badFile) by using the thumb parameter (aka Manualthumb) of the File syntax.

    • Mettez à jour vers 1:1.39.4-1
    Publication Mise à jour
  8. CVE-2021-30153

    Moyenne · CVSS 4.3EPSS 0,83%Correctif disponible

    CVE-2021-30153

    An issue was discovered in the VisualEditor extension in MediaWiki before 1.31.13, and 1.32.x through 1.35.x before 1.35.2. . When using VisualEditor to edit a MediaWiki user page belonging to an existing, but hidden, user, VisualEditor will disclose that the user exists. (It shouldn't because they are hidden.) This is related to ApiVisualEditor.

    • Mettez à jour vers 1:1.35.2-1
    Publication Mise à jour
  9. CVE-2022-47927

    Moyenne · CVSS 5.5EPSS 0,27%Correctif disponible

    CVE-2022-47927

    An issue was discovered in MediaWiki before 1.35.9, 1.36.x through 1.38.x before 1.38.5, and 1.39.x before 1.39.1. When installing with a pre-existing data directory that has weak permissions, the SQLite files are created with file mode 0644, i.e., world readable to local users. These files include credentials data.

    • Mettez à jour vers 1:1.39.1-1
    Publication Mise à jour
  10. CVE-2020-36649

    Faible · CVSS 3.5EPSS 1,43%Correctif disponible

    mholt PapaParse papaparse.js redos

    A vulnerability was found in mholt PapaParse up to 5.1.x. It has been classified as problematic. Affected is an unknown function of the file papaparse.js. The manipulation leads to inefficient regular expression complexity. Upgrading to version 5.2.0 is able to address this issue. The name of the patch is 235a12758cd77266d2e98fd715f53536b34ad621. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-218004.

    • Mettez à jour vers 1:1.39.4-1
    Publication Mise à jour
  11. CVE-2022-41767

    Moyenne · CVSS 5.3EPSS 0,69%Correctif disponible

    CVE-2022-41767

    An issue was discovered in MediaWiki before 1.35.8, 1.36.x and 1.37.x before 1.37.5, and 1.38.x before 1.38.3. When changes made by an IP address are reassigned to a user (using reassignEdits.php), the changes will still be attributed to the IP address on Special:Contributions when doing a range lookup.

    • Mettez à jour vers 1:1.35.8-1
    Publication Mise à jour
  12. CVE-2021-44856

    Moyenne · CVSS 5.3EPSS 0,53%Correctif disponible

    CVE-2021-44856

    An issue was discovered in MediaWiki before 1.35.5, 1.36.x before 1.36.3, and 1.37.x before 1.37.1. A title blocked by AbuseFilter can be created via Special:ChangeContentModel due to the mishandling of the EditFilterMergedContent hook return value.

    • Mettez à jour vers 1:1.35.5-1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →