p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de ghostscript · Page n° 4

Vulnérabilités publiées pour ghostscript au cours des 30 derniers jours : 2. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 165

  1. CVE-2020-16293

    Moyenne · CVSS 5.5EPSS 1,77%Correctif disponible

    CVE-2020-16293

    A null pointer dereference vulnerability in compose_group_nonknockout_nonblend_isolated_allmask_common() in base/gxblend.c of Artifex Software GhostScript v9.50 allows a remote attacker to cause a denial of service via a crafted PDF file. This is fixed in v9.51.

    • Mettez à jour vers 9.51~dfsg-1
    Publication Mise à jour
  2. CVE-2020-15900

    Critique · CVSS 9.8EPSS 5,19%Correctif disponible

    CVE-2020-15900

    A memory corruption issue was found in Artifex Ghostscript 9.50 and 9.52. Use of a non-standard PostScript operator can allow overriding of file access controls. The 'rsearch' calculation for the 'post' size resulted in a size that was too large, and could underflow to max uint32_t. This was fixed in commit 5d499272b95a6b890a1397e11d20937de000d31b.

    • Mettez à jour vers 9.52.1~dfsg-1
    Publication Mise à jour
  3. CVE-2019-14812

    Élevée · CVSS 7.3EPSS 2,47%Correctif disponible

    CVE-2019-14812

    A flaw was found in all ghostscript versions 9.x before 9.50, in the .setuserparams2 procedure where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. A specially crafted PostScript file could disable security protection and then have access to the file system, or execute arbitrary commands.

    • Mettez à jour vers 9.28~~rc2~dfsg-1
    Publication Mise à jour
  4. CVE-2019-10216

    Élevée · CVSS 7.3EPSS 2,3%Correctif disponible

    CVE-2019-10216

    In ghostscript before version 9.50, the .buildfont1 procedure did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. An attacker could abuse this flaw by creating a specially crafted PostScript file that could escalate privileges and access files outside of restricted areas.

    • Mettez à jour vers 9.27~dfsg-3.1
    Publication Mise à jour
  5. CVE-2019-14869

    Élevée · CVSS 7.3EPSS 3,09%Correctif disponible

    CVE-2019-14869

    A flaw was found in all versions of ghostscript 9.x before 9.50, where the `.charkeys` procedure, where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. An attacker could abuse this flaw by creating a specially crafted PostScript file that could escalate privileges within the Ghostscript and access files outside of restricted areas or execute commands.

    • Mettez à jour vers 9.50~dfsg-3
    Publication Mise à jour
  6. CVE-2019-14813

    Élevée · CVSS 7.3EPSS 10,96%Correctif disponible

    CVE-2019-14813

    A flaw was found in ghostscript, versions 9.x before 9.50, in the setsystemparams procedure where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. A specially crafted PostScript file could disable security protection and then have access to the file system, or execute arbitrary commands.

    • Mettez à jour vers 9.28~~rc2~dfsg-1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →