p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de redict · Page n° 2

Vulnérabilités publiées pour redict au cours des 30 derniers jours : 0. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 23

  1. CVE-2024-31449

    Élevée · CVSS 7EPSS 4,46%Correctif disponible

    Lua library commands may lead to stack overflow and RCE in Redis

    Redis is an open source, in-memory database that persists on disk. An authenticated user may use a specially crafted Lua script to trigger a stack buffer overflow in the bit library, which may potentially lead to remote code execution. The problem exists in all versions of Redis with Lua scripting. This problem has been fixed in Redis versions 6.2.16, 7.2.6, and 7.4.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.

    • Mettez à jour vers 7.3.1+ds-1
    Publication Mise à jour
  2. CVE-2024-31228

    Moyenne · CVSS 5.5EPSS 1,01%Correctif disponible

    Denial-of-service due to unbounded pattern matching in Redis

    Redis is an open source, in-memory database that persists on disk. Authenticated users can trigger a denial-of-service by using specially crafted, long string match patterns on supported commands such as `KEYS`, `SCAN`, `PSUBSCRIBE`, `FUNCTION LIST`, `COMMAND LIST` and ACL definitions. Matching of extremely long patterns may result in unbounded recursion, leading to stack overflow and process crash. This problem has been fixed in Redis versions 6.2.16, 7.2.6, and 7.4.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.

    • Mettez à jour vers 7.3.1+ds-1
    Publication Mise à jour
  3. CVE-2024-31227

    Moyenne · CVSS 4.4EPSS 0,4%Correctif disponible

    Denial-of-service due to malformed ACL selectors in Redis

    Redis is an open source, in-memory database that persists on disk. An authenticated with sufficient privileges may create a malformed ACL selector which, when accessed, triggers a server panic and subsequent denial of service. The problem exists in Redis 7 prior to versions 7.2.6 and 7.4.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.

    • Mettez à jour vers 7.3.1+ds-1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →