p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de webkit2gtk · Page n° 38

Vulnérabilité publiée pour webkit2gtk au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 960

  1. CVE-2019-6215

    Élevée · CVSS 8.8EPSS 9,75%Code d’exploitation publicCorrectif disponible

    CVE-2019-6215

    A type confusion issue was addressed with improved memory handling. This issue is fixed in iOS 12.1.3, tvOS 12.1.2, Safari 12.0.3, iTunes 12.9.3 for Windows, iCloud for Windows 7.10. Processing maliciously crafted web content may lead to arbitrary code execution.

    • Mettez à jour vers 2.22.6-1
    Publication Mise à jour
  2. CVE-2019-6212

    Élevée · CVSS 8.8EPSS 1,86%Correctif disponible

    CVE-2019-6212

    Multiple memory corruption issues were addressed with improved memory handling. This issue is fixed in iOS 12.1.3, tvOS 12.1.2, Safari 12.0.3, iTunes 12.9.3 for Windows, iCloud for Windows 7.10. Processing maliciously crafted web content may lead to arbitrary code execution.

    • Mettez à jour vers 2.22.6-1
    Publication Mise à jour
  3. CVE-2019-8375

    Critique · CVSS 9.8EPSS 15,7%Code d’exploitation publicCorrectif disponible

    CVE-2019-8375

    The UIProcess subsystem in WebKit, as used in WebKitGTK through 2.23.90 and WebKitGTK+ through 2.22.6 and other products, does not prevent the script dialog size from exceeding the web view size, which allows remote attackers to cause a denial of service (Buffer Overflow) or possibly have unspecified other impact, related to UIProcess/API/gtk/WebKitScriptDialogGtk.cpp, UIProcess/API/gtk/WebKitScriptDialogImpl.cpp, and UIProcess/API/gtk/WebKitWebViewGtk.cpp, as demonstrated by GNOME Web (aka Epiphany).

    • Mettez à jour vers 2.24.1-1
    Publication Mise à jour
  4. CVE-2019-6251

    Élevée · CVSS 8.1EPSS 4,26%Correctif disponible

    CVE-2019-6251

    WebKitGTK and WPE WebKit prior to version 2.24.1 are vulnerable to address bar spoofing upon certain JavaScript redirections. An attacker could cause malicious web content to be displayed as if for a trusted URI. This is similar to the CVE-2018-8383 issue in Microsoft Edge.

    • Mettez à jour vers 2.24.1-1
    Publication Mise à jour
  5. CVE-2018-4278

    Moyenne · CVSS 4.3EPSS 2,28%Correctif disponible

    CVE-2018-4278

    In Safari before 11.1.2, iTunes before 12.8 for Windows, iOS before 11.4.1, tvOS before 11.4.1, iCloud for Windows before 7.6, sound fetched through audio elements may be exfiltrated cross-origin. This issue was addressed with improved audio taint tracking.

    • Mettez à jour vers 2.20.4-1
    Publication Mise à jour
  6. CVE-2018-12293

    Élevée · CVSS 8.8EPSS 10,03%Code d’exploitation publicCorrectif disponible

    CVE-2018-12293

    The getImageData function in the ImageBufferCairo class in WebCore/platform/graphics/cairo/ImageBufferCairo.cpp in WebKit, as used in WebKitGTK+ prior to version 2.20.3 and WPE WebKit prior to version 2.20.1, is vulnerable to a heap-based buffer overflow triggered by an integer overflow, which could be abused by crafted HTML content.

    • Mettez à jour vers 2.20.3-1
    Publication Mise à jour
  7. CVE-2018-4246

    Élevée · CVSS 8.8EPSS 2,97%Correctif disponible

    CVE-2018-4246

    An issue was discovered in certain Apple products. iOS before 11.4 is affected. Safari before 11.1.1 is affected. iCloud before 7.5 on Windows is affected. iTunes before 12.7.5 on Windows is affected. tvOS before 11.4 is affected. watchOS before 4.3.1 is affected. The issue involves the "WebKit" component. It allows remote attackers to execute arbitrary code via a crafted web site that leverages type confusion.

    • Mettez à jour vers 2.20.4-1
    Publication Mise à jour
  8. CVE-2018-4233

    Élevée · CVSS 8.8EPSS 53,82%Code d’exploitation publicCorrectif disponible

    CVE-2018-4233

    An issue was discovered in certain Apple products. iOS before 11.4 is affected. Safari before 11.1.1 is affected. iCloud before 7.5 on Windows is affected. iTunes before 12.7.5 on Windows is affected. tvOS before 11.4 is affected. watchOS before 4.3.1 is affected. The issue involves the "WebKit" component. It allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site.

    • Mettez à jour vers 2.20.3-1
    Publication Mise à jour
  9. CVE-2018-4232

    Moyenne · CVSS 4.3EPSS 2,08%Correctif disponible

    CVE-2018-4232

    An issue was discovered in certain Apple products. iOS before 11.4 is affected. Safari before 11.1.1 is affected. iCloud before 7.5 on Windows is affected. iTunes before 12.7.5 on Windows is affected. tvOS before 11.4 is affected. The issue involves the "WebKit" component. It allows remote attackers to overwrite cookies via a crafted web site.

    • Mettez à jour vers 2.20.3-1
    Publication Mise à jour
  10. CVE-2018-4222

    Élevée · CVSS 8.8EPSS 10,17%Code d’exploitation publicCorrectif disponible

    CVE-2018-4222

    An issue was discovered in certain Apple products. iOS before 11.4 is affected. Safari before 11.1.1 is affected. iCloud before 7.5 on Windows is affected. iTunes before 12.7.5 on Windows is affected. tvOS before 11.4 is affected. watchOS before 4.3.1 is affected. The issue involves the "WebKit" component. It allows remote attackers to execute arbitrary code via a crafted web site that leverages a getWasmBufferFromValue out-of-bounds read during WebAssembly compilation.

    • Mettez à jour vers 2.20.3-1
    Publication Mise à jour
  11. CVE-2018-4218

    Élevée · CVSS 8.8EPSS 9,05%Code d’exploitation publicCorrectif disponible

    CVE-2018-4218

    An issue was discovered in certain Apple products. iOS before 11.4 is affected. Safari before 11.1.1 is affected. iCloud before 7.5 on Windows is affected. iTunes before 12.7.5 on Windows is affected. tvOS before 11.4 is affected. watchOS before 4.3.1 is affected. The issue involves the "WebKit" component. It allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site that triggers an @generatorState use-after-free.

    • Mettez à jour vers 2.20.3-1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →