p PatchFirst

PatchFirst · Vulnérabilités récentes

n8n 2.28.1 : vulnérabilités connues · Page n° 3

Vulnérabilités connues concernant n8n 2.28.1 : 46. Comparez les versions corrigées ci-dessous avec celle que vous utilisez.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 46

  1. CVE-2026-65592

    Élevée · CVSS 8.4EPSS 0,24%Correctif disponible

    n8n before 1.123.64 Stored DOM XSS via cachedResultUrl

    n8n before 1.123.64, 2.29.8, and 2.30.1 contains a stored DOM cross-site scripting vulnerability in the Resource Locator component, which passes the workflow-persisted cachedResultUrl parameter to window.open() without scheme validation. An attacker with workflow creation/editing privileges can craft a workflow with a malicious (e.g., javascript:) scheme in cachedResultUrl; when a victim opens the crafted workflow and interacts with external links, the payload executes in the victim's browser.

    • Mettez à jour vers 2.29.8
    Publication Mise à jour
  2. CVE-2026-65591

    Élevée · CVSS 8.9EPSS 0,69%Correctif disponible

    n8n before 1.123.64 Sanitizer Bypass Remote Code Execution

    n8n contains a sanitizer bypass vulnerability in the legacy expression evaluator's computed-member handler. An authenticated user with workflow create or modify permissions can craft a malicious expression to bypass the sanitizer and achieve host-level code execution as the n8n process. The legacy expression engine is the default in affected versions. Fixed in n8n 1.123.64, 2.29.8, and 2.30.1.

    • Mettez à jour vers 2.29.8
    Publication Mise à jour
  3. CVE-2026-65590

    Moyenne · CVSS 5.5EPSS 0,58%Correctif disponible

    n8n before 2.30.1 Shell Sandbox Bypass on Linux Windows

    n8n before 2.29.8 and 2.30.x before 2.30.1 does not enforce shell sandbox restrictions on Linux and Windows in the @n8n/computer-use package (sandboxing was applied only on macOS). Shell commands executed by the tool run without any filesystem or network restrictions, allowing unrestricted access to the host filesystem and network from within the computer-use agent process. This issue only affects deployments where the @n8n/computer-use package is explicitly installed and running; standard n8n installations are not affected.

    • Mettez à jour vers 2.29.8
    Publication Mise à jour
  4. CVE-2026-65589

    Moyenne · CVSS 5.1EPSS 0,48%Correctif disponible

    n8n before 1.123.64 Credential Exposure via LLM Node Execution Data

    n8n versions before 1.123.64 fail to properly mask custom HTTP header credentials in LLM sub-node execution data, writing plaintext API keys and secrets to workflow execution records. Authenticated users with access to execution data can read exposed header values and credentials that persist in the database and can be exported.

    • Mettez à jour vers 2.29.8
    Publication Mise à jour
  5. CVE-2026-65016

    Élevée · CVSS 7.7EPSS 0,45%Correctif disponible

    n8n before 1.123.64, 2.29.8, and 2.30.1 Privilege Escalation via SSO Instance-Role

    n8n versions before 1.123.64, 2.29.8, and 2.30.1 contain a privilege escalation vulnerability in Enterprise SSO instance-role provisioning. The provisioning path maps an IdP-asserted role claim to an n8n global role but does not prevent assignment of the global:owner role (unlike the token-exchange identity path, which rejects it). An SSO-authenticated user whose instance-role claim resolves to global:owner is provisioned as instance owner, gaining full administrative control over workflows, credentials, users, and instance configuration. Exploitation requires that Enterprise SSO is configured, instance-role provisioning is enabled via N8N_SS

    • Mettez à jour vers 2.29.8
    Publication Mise à jour
  6. CVE-2026-65015

    Élevée · CVSS 7.2EPSS 0,61%Correctif disponible

    n8n before 2.30.1 Privilege Escalation via run_node_tool

    n8n versions before 2.30.1 contain a privilege escalation vulnerability in the AI Agents feature where the node-execution tool lacks proper authorization checks. A Project Viewer user can escalate privileges by chatting with an agent that has node tools enabled, executing arbitrary nodes and accessing credential secrets without proper authorization verification.

    • Mettez à jour vers 2.29.8
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →