p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de laravel/framework · Page n° 2

Vulnérabilités publiées pour laravel/framework au cours des 30 derniers jours : 2. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 28

  1. CVE-2021-43808

    Moyenne · CVSS 5.3EPSS 0,83%Correctif disponible

    Blade `@parent` Exploitation Leading To Possible XSS in Laravel

    Laravel is a web application framework. Laravel prior to versions 8.75.0, 7.30.6, and 6.20.42 contain a possible cross-site scripting (XSS) vulnerability in the Blade templating engine. A broken HTML element may be clicked and the user taken to another location in their browser due to XSS. This is due to the user being able to guess the parent placeholder SHA-1 hash by trying common names of sections. If the parent template contains an exploitable HTML structure an XSS vulnerability can be exposed. This vulnerability has been patched in versions 8.75.0, 7.30.6, and 6.20.42 by determining the parent placeholder at runtime and using a random ha

    • Mettez à jour vers 6.20.42
    • Mettez à jour vers 7.30.6
    • Mettez à jour vers 8.75.0
    Publication Mise à jour
  2. GHSA-4mg9-vhxq-vm7j

    Non évaluéeCorrectif disponible

    SQL Server LIMIT / OFFSET SQL Injection in laravel/framework and illuminate/database

    ### Impact Those using SQL Server with Laravel and allowing user input to be passed directly to the `limit` and `offset` functions are vulnerable to SQL injection. Other database drivers such as MySQL and Postgres are not affected by this vulnerability. ### Patches This problem has been patched on Laravel versions 6.20.26, 7.30.5, and 8.40.0. ### Workarounds You may workaround this vulnerability by ensuring that only integers are passed to the `limit` and `offset` functions, as well as the `skip` and `take` functions.

    • Mettez à jour vers 6.20.26
    • Mettez à jour vers 8.40.0
    Publication Mise à jour
  3. GHSA-x7p5-p2c9-phvg

    Élevée · CVSS 7.2Correctif disponible

    Unexpected database bindings

    This is a follow-up to the previous security advisory (GHSA-3p32-j457-pg5x) which addresses a few additional edge cases. If a request is crafted where a field that is normally a non-array value is an array, and that input is not validated or cast to its expected type before being passed to the query builder, an unexpected number of query bindings can be added to the query. In some situations, this will simply lead to no results being returned by the query builder; however, it is possible certain queries could be affected in a way that causes the query to return unexpected results.

    • Mettez à jour vers 6.20.14
    • Mettez à jour vers 7.30.4
    • Mettez à jour vers 8.24.0
    Publication Mise à jour
  4. CVE-2021-21263

    Élevée · CVSS 7.2EPSS 1,62%Correctif disponible

    Query Binding Exploitation in Laravel

    Laravel is a web application framework. Versions of Laravel before 6.20.11, 7.30.2 and 8.22.1 contain a query binding exploitation. This same exploit applies to the illuminate/database package which is used by Laravel. If a request is crafted where a field that is normally a non-array value is an array, and that input is not validated or cast to its expected type before being passed to the query builder, an unexpected number of query bindings can be added to the query. In some situations, this will simply lead to no results being returned by the query builder; however, it is possible certain queries could be affected in a way that causes the

    • Mettez à jour vers 6.20.11
    • Mettez à jour vers 7.30.2
    • Mettez à jour vers 8.22.1
    Publication Mise à jour
  5. CVE-2018-15133

    Élevée · CVSS 8.1EPSS 76,57%Dans le catalogue KEVCode d’exploitation publicCorrectif disponible

    CVE-2018-15133

    In Laravel Framework through 5.5.40 and 5.6.x through 5.6.29, remote code execution might occur as a result of an unserialize call on a potentially untrusted X-XSRF-TOKEN value. This involves the decrypt method in Illuminate/Encryption/Encrypter.php and PendingBroadcast in gadgetchains/Laravel/RCE/3/chain.php in phpggc. The attacker must know the application key, which normally would never occur, but could happen if the attacker previously had privileged access or successfully accomplished a previous attack.

    • Mettez à jour vers 5.6.30
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →