p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de moodle/moodle · Page n° 12

Vulnérabilité publiée pour moodle/moodle au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 437

  1. CVE-2019-10187

    Moyenne · CVSS 4EPSS 0,86%Correctif disponible

    CVE-2019-10187

    A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. Users with permission to delete entries from a glossary were able to delete entries from other glossaries they did not have direct access to.

    • Mettez à jour vers 3.5.7
    • Mettez à jour vers 3.6.5
    • Mettez à jour vers 3.7.1
    Publication Mise à jour
  2. CVE-2019-10134

    Moyenne · CVSS 4.2EPSS 1,05%Correctif disponible

    CVE-2019-10134

    A flaw was found in Moodle before 3.7, 3.6.4, 3.5.6, 3.4.9 and 3.1.18. The size of users' private file uploads via email were not correctly checked, so their quota allowance could be exceeded.

    • Mettez à jour vers 3.1.18
    • Mettez à jour vers 3.4.9
    • Mettez à jour vers 3.5.6
    • Mettez à jour vers 3.6.4
    Publication Mise à jour
  3. CVE-2019-10133

    Faible · CVSS 3.1EPSS 0,9%Correctif disponible

    CVE-2019-10133

    A flaw was found in Moodle before 3.7, 3.6.4, 3.5.6, 3.4.9 and 3.1.18. The form to upload cohorts contained a redirect field, which was not restricted to internal URLs.

    • Mettez à jour vers 3.1.18
    • Mettez à jour vers 3.4.9
    • Mettez à jour vers 3.5.6
    • Mettez à jour vers 3.6.4
    Publication Mise à jour
  4. CVE-2019-3847

    Moyenne · CVSS 5.4EPSS 2,22%Correctif disponible

    CVE-2019-3847

    A vulnerability was found in moodle before versions 3.6.3, 3.5.5, 3.4.8 and 3.1.17. Users with the "login as other users" capability (such as administrators/managers) can access other users' Dashboards, but the JavaScript those other users may have added to their Dashboard was not being escaped when being viewed by the user logging in on their behalf.

    • Mettez à jour vers 3.1.17
    • Mettez à jour vers 3.4.8
    • Mettez à jour vers 3.5.5
    • Mettez à jour vers 3.6.3
    Publication Mise à jour
  5. CVE-2019-3850

    Moyenne · CVSS 4.3EPSS 0,95%Correctif disponible

    CVE-2019-3850

    A vulnerability was found in moodle before versions 3.6.3, 3.5.5, 3.4.8 and 3.1.17. Links within assignment submission comments would open directly (in the same window). Although links themselves may be valid, opening within the same window and without the no-referrer header policy made them more susceptible to exploits.

    • Mettez à jour vers 3.1.17
    • Mettez à jour vers 3.4.8
    • Mettez à jour vers 3.5.5
    • Mettez à jour vers 3.6.3
    Publication Mise à jour
  6. CVE-2019-3849

    Moyenne · CVSS 6.3EPSS 1,02%Correctif disponible

    CVE-2019-3849

    A vulnerability was found in moodle before versions 3.6.3, 3.5.5 and 3.4.8. Users could assign themselves an escalated role within courses or content accessed via LTI, by modifying the request to the LTI publisher site.

    • Mettez à jour vers 3.4.8
    • Mettez à jour vers 3.5.5
    • Mettez à jour vers 3.6.3
    Publication Mise à jour
  7. CVE-2019-3848

    Moyenne · CVSS 4.3EPSS 0,92%Correctif disponible

    CVE-2019-3848

    A vulnerability was found in moodle before versions 3.6.3, 3.5.5 and 3.4.8. Permissions were not correctly checked before loading event information into the calendar's edit event modal popup, so logged in non-guest users could view unauthorised calendar events. (Note: It was read-only access, users could not edit the events.)

    • Mettez à jour vers 3.4.8
    • Mettez à jour vers 3.5.5
    • Mettez à jour vers 3.6.3
    Publication Mise à jour
  8. CVE-2019-3809

    Moyenne · CVSS 6.5EPSS 0,84%Correctif disponible

    CVE-2019-3809

    A flaw was found in Moodle versions 3.1 to 3.1.15 and earlier unsupported versions. The mybackpack functionality allowed setting the URL of badges, when it should be restricted to the Mozilla Open Badges backpack URL. This resulted in the possibility of blind SSRF via requests made by the page.

    • Mettez à jour vers 3.1.16
    Publication Mise à jour
  9. CVE-2019-3808

    Moyenne · CVSS 4.3EPSS 1,23%Correctif disponible

    CVE-2019-3808

    A flaw was found in Moodle versions 3.6 to 3.6.1, 3.5 to 3.5.3, 3.4 to 3.4.6, 3.1 to 3.1.15 and earlier unsupported versions. The 'manage groups' capability did not have the 'XSS risk' flag assigned to it, but does have that access in certain places. Note that the capability is intended for use by trusted users, and is only assigned to teachers and managers by default.

    • Mettez à jour vers 3.1.16
    • Mettez à jour vers 3.4.7
    • Mettez à jour vers 3.5.4
    • Mettez à jour vers 3.6.2
    Publication Mise à jour
  10. CVE-2019-3810

    Moyenne · CVSS 4.3EPSS 13,84%Code d’exploitation publicCorrectif disponible

    CVE-2019-3810

    A flaw was found in moodle versions 3.6 to 3.6.1, 3.5 to 3.5.3, 3.4 to 3.4.6, 3.1 to 3.1.15 and earlier unsupported versions. The /userpix/ page did not escape users' full names, which are included as text when hovering over profile images. Note this page is not linked to by default and its access is restricted.

    • Mettez à jour vers 3.1.15
    • Mettez à jour vers 3.4.6
    • Mettez à jour vers 3.5.3
    • Mettez à jour vers 3.6.1
    Publication Mise à jour
  11. CVE-2018-16854

    Moyenne · CVSS 6.5EPSS 2,33%Correctif disponible

    CVE-2018-16854

    A flaw was found in moodle versions 3.5 to 3.5.2, 3.4 to 3.4.5, 3.3 to 3.3.8, 3.1 to 3.1.14 and earlier. The login form is not protected by a token to prevent login cross-site request forgery. Fixed versions include 3.6, 3.5.3, 3.4.6, 3.3.9 and 3.1.15.

    • Mettez à jour vers 3.1.15
    • Mettez à jour vers 3.3.9
    • Mettez à jour vers 3.4.6
    • Mettez à jour vers 3.5.3
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →