p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de la pile Python · Page n° 150

Vulnérabilités publiées pour Python au cours des 30 derniers jours : 352. Présentes dans le catalogue KEV : 1.

Filtrer les vulnérabilités
Python

Vulnérabilités : 7135

  1. CVE-2025-10950

    Moyenne · CVSS 5.3EPSS 0,39%Aucun correctif publié

    geyang ml-logger Ping server.py log_handler deserialization

    A vulnerability was determined in geyang ml-logger up to acf255bade5be6ad88d90735c8367b28cbe3a743. Affected is the function log_handler of the file ml_logger/server.py of the component Ping Handler. This manipulation of the argument data causes deserialization. It is possible to initiate the attack remotely. The exploit has been publicly disclosed and may be utilized. This product is using a rolling release to provide continious delivery. Therefore, no version details for affected nor updated releases are available.

    Publication Mise à jour
  2. CVE-2025-55560

    Élevée · CVSS 7.5EPSS 0,41%Correctif disponible

    CVE-2025-55560

    An issue in pytorch v2.7.0 can lead to a Denial of Service (DoS) when a PyTorch model consists of torch.Tensor.to_sparse() and torch.Tensor.to_dense() and is compiled by Inductor.

    • Mettez à jour vers 2.12.0+dfsg2-1
    • Mettez à jour vers 2.7.1
    Publication Mise à jour
  3. CVE-2025-55558

    Élevée · CVSS 7.5EPSS 0,45%Correctif disponible

    CVE-2025-55558

    A buffer overflow occurs in pytorch v2.7.0 when a PyTorch model consists of torch.nn.Conv2d, torch.nn.functional.hardshrink, and torch.Tensor.view-torch.mv() and is compiled by Inductor, leading to a Denial of Service (DoS).

    • Mettez à jour vers 2.12.0+dfsg2-1
    • Mettez à jour vers 2.7.1
    Publication Mise à jour
  4. CVE-2025-55557

    Élevée · CVSS 7.5EPSS 0,41%Correctif disponible

    CVE-2025-55557

    A Name Error occurs in pytorch v2.7.0 when a PyTorch model consists of torch.cummin and is compiled by Inductor, leading to a Denial of Service (DoS).

    • Mettez à jour vers 2.12.0+dfsg2-1
    • Mettez à jour vers 2.7.1
    Publication Mise à jour
  5. CVE-2025-46153

    Moyenne · CVSS 5.3EPSS 0,42%Correctif disponible

    CVE-2025-46153

    PyTorch before 3.7.0 has a bernoulli_p decompose function in decompositions.py even though it lacks full consistency with the eager CPU implementation, negatively affecting nn.Dropout1d, nn.Dropout2d, and nn.Dropout3d for fallback_random=True.

    • Mettez à jour vers 2.12.0+dfsg2-1
    • Mettez à jour vers 2.7.0
    Publication Mise à jour
  6. CVE-2025-8869

    Moyenne · CVSS 5.9EPSS 0,49%Correctif disponible

    Fallback tar extraction in pip doesn't check symbolic links point to extraction directory

    When extracting a tar archive pip may not check symbolic links point into the extraction directory if the tarfile module doesn't implement PEP 706. Note that upgrading pip to a "fixed" version for this vulnerability doesn't fix all known vulnerabilities that are remediated by using a Python version that implements PEP 706. Note that this is a vulnerability in pip's fallback implementation of tar extraction for Python versions that don't implement PEP 706 and therefore are not secure to all vulnerabilities in the Python 'tarfile' module. If you're using a Python version that implements PEP 706 then pip doesn't use the "vulnerable" fallback co

    • Mettez à jour vers 25.3
    • Mettez à jour vers 25.3+dfsg-1
    Publication Mise à jour
  7. CVE-2025-48459

    Moyenne · CVSS 5.3EPSS 0,51%Correctif disponible

    Apache IoTDB: Deserialization of untrusted Data

    Deserialization of Untrusted Data vulnerability in Apache IoTDB. This issue affects Apache IoTDB: from 1.0.0 before 2.0.5. Users are recommended to upgrade to version 2.0.5, which fixes the issue.

    • Mettez à jour vers 2.0.5
    Publication Mise à jour
  8. CVE-2025-6921

    Moyenne · CVSS 5.3EPSS 0,51%Correctif disponible

    Regular Expression Denial of Service (ReDoS) in huggingface/transformers

    The huggingface/transformers library, versions prior to 4.53.0, is vulnerable to Regular Expression Denial of Service (ReDoS) in the AdamWeightDecay optimizer. The vulnerability arises from the _do_use_weight_decay method, which processes user-controlled regular expressions in the include_in_weight_decay and exclude_from_weight_decay lists. Malicious regular expressions can cause catastrophic backtracking during the re.search call, leading to 100% CPU utilization and a denial of service. This issue can be exploited by attackers who can control the patterns in these lists, potentially causing the machine learning task to hang and rendering ser

    • Mettez à jour vers 4.53.0
    Publication Mise à jour
  9. CVE-2025-59420

    Élevée · CVSS 7.5EPSS 0,26%Correctif disponible

    Authlib: JWS/JWT accepts unknown crit headers (RFC violation → possible authz bypass)

    Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to version 1.6.4, Authlib’s JWS verification accepts tokens that declare unknown critical header parameters (crit), violating RFC 7515 “must‑understand” semantics. An attacker can craft a signed token with a critical header (for example, bork or cnf) that strict verifiers reject but Authlib accepts. In mixed‑language fleets, this enables split‑brain verification and can lead to policy bypass, replay, or privilege escalation. This issue has been patched in version 1.6.4.

    • Mettez à jour vers 0.15.5-1ubuntu0.1~esm1
    • Mettez à jour vers 1.2.0-1+deb12u1
    • Mettez à jour vers 1.3.0-1ubuntu0.1~esm1
    • Mettez à jour vers 1.6.0-1+deb13u1
    • Mettez à jour vers 1.6.4
    • Mettez à jour vers 1.6.4-1
    Publication Mise à jour
  10. CVE-2025-6544

    Critique · CVSS 9.8EPSS 0,95%Correctif disponible

    Deserialization Vulnerability in h2oai/h2o-3

    A deserialization vulnerability exists in h2oai/h2o-3 versions <= 3.46.0.8, allowing attackers to read arbitrary system files and execute arbitrary code. The vulnerability arises from improper handling of JDBC connection parameters, which can be exploited by bypassing regular expression checks and using double URL encoding. This issue impacts all users of the affected versions.

    • Mettez à jour vers 3.46.8
    Publication Mise à jour
  11. CVE-2025-9905

    Élevée · CVSS 7.3EPSS 0,22%Correctif disponible

    Arbitary Code execution in Keras load_model()

    The Keras Model.load_model method can be exploited to achieve arbitrary code execution, even with safe_mode=True. One can create a specially crafted .h5/.hdf5 model archive that, when loaded via Model.load_model, will trigger arbitrary code to be executed. This is achieved by crafting a special .h5 archive file that uses the Lambda layer feature of keras which allows arbitrary Python code in the form of pickled code. The vulnerability comes from the fact that the safe_mode=True option is not honored when reading .h5 archives. Note that the .h5/.hdf5 format is a legacy format supported by Keras 3 for backwards compatibility.

    • Mettez à jour vers 3.11.3
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →