p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de linux-gcp-edge · Page n° 26

Vulnérabilité publiée pour linux-gcp-edge au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 553

  1. CVE-2018-16871

    Élevée · CVSS 7.5EPSS 2,7%Correctif disponible

    CVE-2018-16871

    A flaw was found in the Linux kernel's NFS implementation, all versions 3.x and all versions 4.x up to 4.20. An attacker, who is able to mount an exported NFS filesystem, is able to trigger a null pointer dereference by using an invalid NFS sequence. This can panic the machine and deny access to the NFS server. Any outstanding disk writes to the NFS server will be lost.

    • Mettez à jour vers 4.18.0-1006.7~18.04.1
    Publication Mise à jour
  2. CVE-2019-11479

    Moyenne · CVSS 5.3EPSS 91,66%Correctif disponible

    CVE-2019-11479

    Jonathan Looney discovered that the Linux kernel default MSS is hard-coded to 48 bytes. This allows a remote peer to fragment TCP resend queues significantly more than if a larger MSS were enforced. A remote attacker could use this to cause a denial of service. This has been fixed in stable kernel releases 4.4.182, 4.9.182, 4.14.127, 4.19.52, 5.1.11, and is fixed in commits 967c05aee439e6e5d7d805e195b3a20ef5c433d6 and 5f3e2bf008c2221478101ee72f5cb4654b9fc363.

    • Mettez à jour vers 4.18.0-1015.16~18.04.1
    Publication Mise à jour
  3. CVE-2019-11478

    Moyenne · CVSS 5.3EPSS 94,69%Correctif disponible

    SACK can cause extensive memory use via fragmented resend queue

    Jonathan Looney discovered that the TCP retransmission queue implementation in tcp_fragment in the Linux kernel could be fragmented when handling certain TCP Selective Acknowledgment (SACK) sequences. A remote attacker could use this to cause a denial of service. This has been fixed in stable kernel releases 4.4.182, 4.9.182, 4.14.127, 4.19.52, 5.1.11, and is fixed in commit f070ef2ac66716357066b683fb0baf55f8191a2e.

    • Mettez à jour vers 4.18.0-1013.14~18.04.1
    Publication Mise à jour
  4. CVE-2019-11477

    Élevée · CVSS 7.5EPSS 98,75%Correctif disponible

    Integer overflow in TCP_SKB_CB(skb)->tcp_gso_segs

    Jonathan Looney discovered that the TCP_SKB_CB(skb)->tcp_gso_segs value was subject to an integer overflow in the Linux kernel when handling TCP Selective Acknowledgments (SACKs). A remote attacker could use this to cause a denial of service. This has been fixed in stable kernel releases 4.4.182, 4.9.182, 4.14.127, 4.19.52, 5.1.11, and is fixed in commit 3b4929f65b0d8249f19a50245cd88ed1a2f78cff.

    • Mettez à jour vers 4.18.0-1013.14~18.04.1
    Publication Mise à jour
  5. CVE-2019-12881

    Élevée · CVSS 7.8EPSS 0,8%Aucun correctif publié

    CVE-2019-12881

    i915_gem_userptr_get_pages in drivers/gpu/drm/i915/i915_gem_userptr.c in the Linux kernel 4.15.0 on Ubuntu 18.04.2 allows local users to cause a denial of service (NULL pointer dereference and BUG) or possibly have unspecified other impact via crafted ioctl calls to /dev/dri/card0.

    Publication Mise à jour
  6. CVE-2019-12380

    Moyenne · CVSS 5.5EPSS 0,46%Aucun correctif publié

    CVE-2019-12380

    **DISPUTED** An issue was discovered in the efi subsystem in the Linux kernel through 5.1.5. phys_efi_set_virtual_address_map in arch/x86/platform/efi/efi.c and efi_call_phys_prolog in arch/x86/platform/efi/efi_64.c mishandle memory allocation failures. NOTE: This id is disputed as not being an issue because “All the code touched by the referenced commit runs only at boot, before any user processes are started. Therefore, there is no possibility for an unprivileged user to control it.”.

    Publication Mise à jour
  7. CVE-2019-3882

    Moyenne · CVSS 4.7EPSS 0,54%Correctif disponible

    CVE-2019-3882

    A flaw was found in the Linux kernel's vfio interface implementation that permits violation of the user's locked memory limit. If a device is bound to a vfio driver, such as vfio-pci, and the local attacker is administratively granted ownership of the device, it may cause a system memory exhaustion and thus a denial of service (DoS). Versions 3.10, 4.14 and 4.18 are vulnerable.

    • Mettez à jour vers 4.18.0-1011.12~18.04.1
    Publication Mise à jour
  8. CVE-2019-3887

    Moyenne · CVSS 6.7EPSS 0,36%Correctif disponible

    CVE-2019-3887

    A flaw was found in the way KVM hypervisor handled x2APIC Machine Specific Rregister (MSR) access with nested(=1) virtualization enabled. In that, L1 guest could access L0's APIC register values via L2 guest, when 'virtualize x2APIC mode' is enabled. A guest could use this flaw to potentially crash the host kernel resulting in DoS issue. Kernel versions from 4.16 and newer are vulnerable to this issue.

    • Mettez à jour vers 4.18.0-1011.12~18.04.1
    Publication Mise à jour
  9. CVE-2019-9213

    Moyenne · CVSS 5.5EPSS 5,67%Code d’exploitation publicCorrectif disponible

    CVE-2019-9213

    In the Linux kernel before 4.20.14, expand_downwards in mm/mmap.c lacks a check for the mmap minimum address, which makes it easier for attackers to exploit kernel NULL pointer dereferences on non-SMAP platforms. This is related to a capability check for the wrong task.

    • Mettez à jour vers 4.18.0-1008.9~18.04.1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →