p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de python3.8 · Page n° 2

Vulnérabilité publiée pour python3.8 au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 29

  1. CVE-2022-0391

    Élevée · CVSS 7.5EPSS 8,54%Correctif disponible

    CVE-2022-0391

    A flaw was found in Python, specifically within the urllib.parse module. This module helps break Uniform Resource Locator (URL) strings into components. The issue involves how the urlparse method does not sanitize input and allows characters like '\r' and '\n' in the URL path. This flaw allows an attacker to input a crafted URL, leading to injection attacks. This flaw affects Python versions prior to 3.10.0b1, 3.9.5, 3.8.11, 3.7.11 and 3.6.14.

    • Mettez à jour vers 3.8.10-0ubuntu1~20.04.4
    Publication Mise à jour
  2. CVE-2021-3177

    Critique · CVSS 9.8EPSS 24,22%Correctif disponible

    CVE-2021-3177

    Python 3.x through 3.9.1 has a buffer overflow in PyCArg_repr in _ctypes/callproc.c, which may lead to remote code execution in certain Python applications that accept floating-point numbers as untrusted input, as demonstrated by a 1e300 argument to c_double.from_param. This occurs because sprintf is used unsafely.

    • Mettez à jour vers 3.8.5-1~20.04.2
    Publication Mise à jour
  3. CVE-2020-14422

    Moyenne · CVSS 5.9EPSS 12,71%Correctif disponible

    CVE-2020-14422

    Lib/ipaddress.py in Python through 3.8.3 improperly computes hash values in the IPv4Interface and IPv6Interface classes, which might allow a remote attacker to cause a denial of service if an application is affected by the performance of a dictionary containing IPv4Interface or IPv6Interface objects, and this attacker can cause many dictionary entries to be created. This is fixed in: v3.5.10, v3.5.10rc1; v3.6.12; v3.7.9; v3.8.4, v3.8.4rc1, v3.8.5, v3.8.6, v3.8.6rc1; v3.9.0, v3.9.0b4, v3.9.0b5, v3.9.0rc1, v3.9.0rc2.

    • Mettez à jour vers 3.8.2-1ubuntu1.2
    Publication Mise à jour
  4. CVE-2020-8492

    Moyenne · CVSS 6.5EPSS 6,62%Correctif disponible

    CVE-2020-8492

    Python 2.7 through 2.7.17, 3.5 through 3.5.9, 3.6 through 3.6.10, 3.7 through 3.7.6, and 3.8 through 3.8.1 allows an HTTP server to conduct Regular Expression Denial of Service (ReDoS) attacks against a client because of urllib.request.AbstractBasicAuthHandler catastrophic backtracking.

    • Mettez à jour vers 3.8.2-1ubuntu1.1
    Publication Mise à jour
  5. CVE-2019-18348

    Moyenne · CVSS 5.4EPSS 3,51%Correctif disponible

    CVE-2019-18348

    An issue was discovered in urllib2 in Python 2.x through 2.7.17 and urllib in Python 3.x through 3.8.0. CRLF injection is possible if the attacker controls a url parameter, as demonstrated by the first argument to urllib.request.urlopen with \r\n (specifically in the host component of a URL) followed by an HTTP header. This is similar to the CVE-2019-9740 query string issue and the CVE-2019-9947 path string issue. (This is not exploitable when glibc has CVE-2016-10739 fixed.). This is fixed in: v2.7.18, v2.7.18rc1; v3.5.10, v3.5.10rc1; v3.6.11, v3.6.11rc1, v3.6.12; v3.7.8, v3.7.8rc1, v3.7.9; v3.8.3, v3.8.3rc1, v3.8.4, v3.8.4rc1, v3.8.5, v3.8.

    • Mettez à jour vers 3.8.2-1ubuntu1.1
    Publication Mise à jour
  6. CVE-2019-17514

    Élevée · CVSS 7.5EPSS 4,67%Correctif disponible

    CVE-2019-17514

    library/glob.html in the Python 2 and 3 documentation before 2016 has potentially misleading information about whether sorting occurs, as demonstrated by irreproducible cancer-research results. NOTE: the effects of this documentation cross application domains, and thus it is likely that security-relevant code elsewhere is affected. This issue is not a Python implementation bug, and there are no reports that NMR researchers were specifically relying on library/glob.html. In other words, because the older documentation stated "finds all the pathnames matching a specified pattern according to the rules used by the Unix shell," one might have inc

    • Mettez à jour vers 3.8.2-1ubuntu1.2
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →