p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de apache2 · Page n° 4

Vulnérabilités publiées pour apache2 au cours des 30 derniers jours : 17. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 83

  1. CVE-2022-28615

    Critique · CVSS 9.1EPSS 6,28%Correctif disponible

    Read beyond bounds in ap_strcmp_match()

    Apache HTTP Server 2.4.53 and earlier may crash or disclose information due to a read beyond bounds in ap_strcmp_match() when provided with an extremely large input buffer. While no code distributed with the server can be coerced into such a call, third-party modules or lua scripts that use ap_strcmp_match() may hypothetically be affected.

    • Mettez à jour vers 2.4.7-1ubuntu4.22+esm6
    Publication Mise à jour
  2. CVE-2022-28614

    Moyenne · CVSS 5.3EPSS 4,98%Correctif disponible

    read beyond bounds via ap_rwrite()

    The ap_rwrite() function in Apache HTTP Server 2.4.53 and earlier may read unintended memory if an attacker can cause the server to reflect very large input using ap_rwrite() or ap_rputs(), such as with mod_luas r:puts() function. Modules compiled and distributed separately from Apache HTTP Server that use the 'ap_rputs' function and may pass it a very large (INT_MAX or larger) string must be compiled against current headers to resolve the issue.

    • Mettez à jour vers 2.4.7-1ubuntu4.22+esm6
    Publication Mise à jour
  3. CVE-2022-26377

    Élevée · CVSS 7.5EPSS 21,08%Correctif disponible

    mod_proxy_ajp: Possible request smuggling

    Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in mod_proxy_ajp of Apache HTTP Server allows an attacker to smuggle requests to the AJP server it forwards requests to. This issue affects Apache HTTP Server Apache HTTP Server 2.4 version 2.4.53 and prior versions.

    • Mettez à jour vers 2.4.7-1ubuntu4.22+esm5
    Publication Mise à jour
  4. CVE-2022-23943

    Critique · CVSS 9.8EPSS 50,4%Correctif disponible

    mod_sed: Read/write beyond bounds

    Out-of-bounds Write vulnerability in mod_sed of Apache HTTP Server allows an attacker to overwrite heap memory with possibly attacker provided data. This issue affects Apache HTTP Server 2.4 version 2.4.52 and prior versions.

    • Mettez à jour vers 2.4.7-1ubuntu4.22+esm4
    Publication Mise à jour
  5. CVE-2022-22721

    Critique · CVSS 9.1EPSS 41,71%Correctif disponible

    core: Possible buffer overflow with very large or unlimited LimitXMLRequestBody

    If LimitXMLRequestBody is set to allow request bodies larger than 350MB (defaults to 1M) on 32 bit systems an integer overflow happens which later causes out of bounds writes. This issue affects Apache HTTP Server 2.4.52 and earlier.

    • Mettez à jour vers 2.4.7-1ubuntu4.22+esm4
    Publication Mise à jour
  6. CVE-2021-44224

    Élevée · CVSS 8.2EPSS 82,3%Correctif disponible

    Possible NULL dereference or SSRF in forward proxy configurations in Apache HTTP Server 2.4.51 and earlier

    A crafted URI sent to httpd configured as a forward proxy (ProxyRequests on) can cause a crash (NULL pointer dereference) or, for configurations mixing forward and reverse proxy declarations, can allow for requests to be directed to a declared Unix Domain Socket endpoint (Server Side Request Forgery). This issue affects Apache HTTP Server 2.4.7 up to 2.4.51 (included).

    • Mettez à jour vers 2.4.7-1ubuntu4.22+esm3
    Publication Mise à jour
  7. CVE-2021-44790

    Critique · CVSS 9.8EPSS 96,84%Code d’exploitation publicCorrectif disponible

    Possible buffer overflow when parsing multipart content in mod_lua of Apache HTTP Server 2.4.51 and earlier

    A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.

    • Mettez à jour vers 2.4.7-1ubuntu4.22+esm3
    Publication Mise à jour
  8. CVE-2021-39275

    Critique · CVSS 9.8EPSS 39,4%Correctif disponible

    ap_escape_quotes buffer overflow

    ap_escape_quotes() may write beyond the end of a buffer when given malicious input. No included modules pass untrusted data to these functions, but third-party / external modules may. This issue affects Apache HTTP Server 2.4.48 and earlier.

    • Mettez à jour vers 2.4.7-1ubuntu4.22+esm2
    Publication Mise à jour
  9. CVE-2020-35452

    Élevée · CVSS 7.3EPSS 54,81%Correctif disponible

    mod_auth_digest possible stack overflow by one nul byte

    Apache HTTP Server versions 2.4.0 to 2.4.46 A specially crafted Digest nonce can cause a stack overflow in mod_auth_digest. There is no report of this overflow being exploitable, nor the Apache HTTP Server team could create one, though some particular compiler and/or compilation option might make it possible, with limited consequences anyway due to the size (a single byte) and the value (zero byte) of the overflow

    • Mettez à jour vers 2.4.7-1ubuntu4.22+esm1
    Publication Mise à jour
  10. CVE-2019-17567

    Moyenne · CVSS 5.3EPSS 60,27%Aucun correctif publié

    mod_proxy_wstunnel tunneling of non Upgraded connections

    Apache HTTP Server versions 2.4.6 to 2.4.46 mod_proxy_wstunnel configured on an URL that is not necessarily Upgraded by the origin server was tunneling the whole connection regardless, thus allowing for subsequent requests on the same connection to pass through with no HTTP validation, authentication or authorization possibly configured.

    Publication Mise à jour
  11. CVE-2020-11985

    Moyenne · CVSS 5.3EPSS 7,05%Aucun correctif publié

    CVE-2020-11985

    IP address spoofing when proxying using mod_remoteip and mod_rewrite For configurations using proxying with mod_remoteip and certain mod_rewrite rules, an attacker could spoof their IP address for logging and PHP scripts. Note this issue was fixed in Apache HTTP Server 2.4.24 but was retrospectively allocated a low severity CVE in 2020.

    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →