p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de drupal7 · Page n° 3

Vulnérabilité publiée pour drupal7 au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 78

  1. CVE-2017-6932

    Moyenne · CVSS 4.7EPSS 1,17%Aucun correctif publié

    CVE-2017-6932

    Drupal core 7.x versions before 7.57 has an external link injection vulnerability when the language switcher block is used. A similar vulnerability exists in various custom and contributed modules. This vulnerability could allow an attacker to trick users into unwillingly navigating to an external site.

    Publication Mise à jour
  2. CVE-2017-6929

    Moyenne · CVSS 6.1EPSS 1,22%Aucun correctif publié

    CVE-2017-6929

    A jQuery cross site scripting vulnerability is present when making Ajax requests to untrusted domains. This vulnerability is mitigated by the fact that it requires contributed or custom modules in order to exploit. For Drupal 8, this vulnerability was already fixed in Drupal 8.4.0 in the Drupal core upgrade to jQuery 3. For Drupal 7, it is fixed in the current release (Drupal 7.57) for jQuery 1.4.4 (the version that ships with Drupal 7 core) as well as for other newer versions of jQuery that might be used on the site, for example using the jQuery Update module.

    Publication Mise à jour
  3. CVE-2017-6928

    Moyenne · CVSS 5.3EPSS 1,02%Aucun correctif publié

    CVE-2017-6928

    Drupal core 7.x versions before 7.57 when using Drupal's private file system, Drupal will check to make sure a user has access to a file before allowing the user to view or download it. This check fails under certain conditions in which one module is trying to grant access to the file and another is trying to deny it, leading to an access bypass vulnerability. This vulnerability is mitigated by the fact that it only occurs for unusual site configurations.

    Publication Mise à jour
  4. CVE-2017-6927

    Moyenne · CVSS 6.1EPSS 1,61%Aucun correctif publié

    CVE-2017-6927

    Drupal 8.4.x versions before 8.4.5 and Drupal 7.x versions before 7.57 has a Drupal.checkPlain() JavaScript function which is used to escape potentially dangerous text before outputting it to HTML (as JavaScript output does not typically go through Twig autoescaping). This function does not correctly handle all methods of injecting malicious HTML, leading to a cross-site scripting vulnerability under certain circumstances. The PHP functions which Drupal provides for HTML escaping are not affected.

    Publication Mise à jour
  5. CVE-2015-7943

    Moyenne · CVSS 6.1EPSS 1,77%Aucun correctif publié

    CVE-2015-7943

    Open redirect vulnerability in the Overlay module in Drupal 7.x before 7.41, the jQuery Update module 7.x-2.x before 7.x-2.7 for Drupal, and the LABjs module 7.x-1.x before 7.x-1.8 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via unspecified vectors. NOTE: this vulnerability exists because of an incomplete fix for CVE-2015-3233.

    Publication Mise à jour
  6. CVE-2015-2750

    Moyenne · CVSS 6.1EPSS 1,82%Correctif disponible

    CVE-2015-2750

    Open redirect vulnerability in URL-related API functions in Drupal 6.x before 6.35 and 7.x before 7.35 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via vectors involving the "//" initial sequence.

    • Mettez à jour vers 7.26-1ubuntu0.1+esm1
    Publication Mise à jour
  7. CVE-2017-6381

    Élevée · CVSS 8.1EPSS 3,9%Aucun correctif publié

    CVE-2017-6381

    A 3rd party development library including with Drupal 8 development dependencies is vulnerable to remote code execution. This is mitigated by the default .htaccess protection against PHP execution, and the fact that Composer development dependencies aren't normal installed. You might be vulnerable to this if you are running a version of Drupal before 8.2.2. To be sure you aren't vulnerable, you can remove the <siteroot>/vendor/phpunit directory from your production deployments

    Publication Mise à jour
  8. CVE-2016-3170

    Moyenne · CVSS 5.3EPSS 2,09%Aucun correctif publié

    CVE-2016-3170

    The "have you forgotten your password" links in the User module in Drupal 7.x before 7.43 and 8.x before 8.0.4 allow remote attackers to obtain sensitive username information by leveraging a configuration that permits using an email address to login and a module that permits logging in.

    Publication Mise à jour
  9. CVE-2015-6665

    Non évaluéeEPSS 2,68%Aucun correctif publié

    CVE-2015-6665

    Cross-site scripting (XSS) vulnerability in the Ajax handler in Drupal 7.x before 7.39 and the Ctools module 6.x-1.x before 6.x-1.14 for Drupal allows remote attackers to inject arbitrary web script or HTML via vectors involving a whitelisted HTML element, possibly related to the "a" tag.

    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →