p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de python-pip · Page n° 2

Vulnérabilités publiées pour python-pip au cours des 30 derniers jours : 3. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 33

  1. CVE-2024-35195

    Moyenne · CVSS 5.6EPSS 0,34%Aucun correctif publié

    Requests `Session` object does not verify requests after making first request with verify=False

    Requests is a HTTP library. Prior to 2.32.0, when making requests through a Requests `Session`, if the first request is made with `verify=False` to disable cert verification, all subsequent requests to the same host will continue to ignore cert verification regardless of changes to the value of `verify`. This behavior will continue for the lifecycle of the connection in the connection pool. This vulnerability is fixed in 2.32.0.

    Publication Mise à jour
  2. CVE-2023-45803

    Moyenne · CVSS 4.2EPSS 0,59%Aucun correctif publié

    Request body not stripped after redirect in urllib3

    urllib3 is a user-friendly HTTP client library for Python. urllib3 previously wouldn't remove the HTTP request body when an HTTP redirect response using status 301, 302, or 303 after the request had its method changed from one that could accept a request body (like `POST`) to `GET` as is required by HTTP RFCs. Although this behavior is not specified in the section for redirects, it can be inferred by piecing together information from different sections and we have observed the behavior in other major HTTP client implementations like curl and web browsers. Because the vulnerability requires a previously trusted service to become compromised in

    Publication Mise à jour
  3. CVE-2018-25091

    Moyenne · CVSS 6.1EPSS 0,59%Aucun correctif publié

    CVE-2018-25091

    urllib3 before 1.24.2 does not remove the authorization HTTP header when following a cross-origin redirect (i.e., a redirect that differs in host, port, or scheme). This can allow for credentials in the authorization header to be exposed to unintended hosts or transmitted in cleartext. NOTE: this issue exists because of an incomplete fix for CVE-2018-20060 (which was case-sensitive).

    Publication Mise à jour
  4. CVE-2023-43804

    Moyenne · CVSS 5.9EPSS 1,36%Aucun correctif publié

    `Cookie` HTTP header isn't stripped on cross-origin redirects

    urllib3 is a user-friendly HTTP client library for Python. urllib3 doesn't treat the `Cookie` HTTP header special or provide any helpers for managing cookies over HTTP, that is the responsibility of the user. However, it is possible for a user to specify a `Cookie` header and unknowingly leak information via HTTP redirects to a different origin if that user doesn't disable redirects explicitly. This issue has been patched in urllib3 version 1.26.17 or 2.0.5.

    Publication Mise à jour
  5. CVE-2023-37920

    Élevée · CVSS 7.5EPSS 0,57%Aucun correctif publié

    Certifi's removal of e-Tugra root certificate

    Certifi is a curated collection of Root Certificates for validating the trustworthiness of SSL certificates while verifying the identity of TLS hosts. Certifi prior to version 2023.07.22 recognizes "e-Tugra" root certificates. e-Tugra's root certificates were subject to an investigation prompted by reporting of security issues in their systems. Certifi 2023.07.22 removes root certificates from "e-Tugra" from the root store.

    Publication Mise à jour
  6. USN-5821-4

    Non évaluéeCorrectif disponible

    python-pip regression

    USN-5821-3 fixed a vulnerability in pip. The update introduced a minor regression in Ubuntu 14.04 ESM, Ubuntu 16.04 ESM and Ubuntu 18.04 LTS. This update fixes the problem. We apologize for the inconvenience. Original advisory details: Sebastian Chnelik discovered that wheel incorrectly handled certain file names when validated against a regex expression. An attacker could possibly use this issue to cause a denial of service.

    • Mettez à jour vers 1.5.4-1ubuntu4+esm4
    Publication Mise à jour
  7. CVE-2022-40897

    Moyenne · CVSS 5.9EPSS 2,63%Correctif disponible

    CVE-2022-40897

    Python Packaging Authority (PyPA) setuptools before 65.5.1 allows remote attackers to cause a denial of service via HTML in a crafted package or custom PackageIndex page. There is a Regular Expression Denial of Service (ReDoS) in package_index.py.

    • Mettez à jour vers 1.5.4-1ubuntu4+esm2
    Publication Mise à jour
  8. CVE-2021-3572

    Élevée · CVSS 7.1EPSS 1,83%Correctif disponible

    CVE-2021-3572

    A flaw was found in python-pip in the way it handled Unicode separators in git references. A remote attacker could possibly use this issue to install a different revision on a repository. The highest threat from this vulnerability is to data integrity. This is fixed in python-pip version 21.1.

    • Mettez à jour vers 1.5.4-1ubuntu4+esm1
    Publication Mise à jour
  9. CVE-2019-20916

    Élevée · CVSS 8.7EPSS 3%Aucun correctif publié

    CVE-2019-20916

    The pip package before 19.2 for Python allows Directory Traversal when a URL is given in an install command, because a Content-Disposition header can have ../ in a filename, as demonstrated by overwriting the /root/.ssh/authorized_keys file. This occurs in _download_http_url in _internal/download.py.

    Publication Mise à jour
  10. CVE-2018-20225

    Élevée · CVSS 7.8EPSS 1,78%Aucun correctif publié

    CVE-2018-20225

    An issue was discovered in pip (all versions) because it installs the version with the highest version number, even if the user had intended to obtain a private package from a private index. This only affects use of the --extra-index-url option, and exploitation requires that the package does not already exist in the public index (and thus the attacker can put the package there with an arbitrary version number). NOTE: it has been reported that this is intended functionality and the user is responsible for using --extra-index-url securely

    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →