p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de cups · Page n° 2

Vulnérabilités publiées pour cups au cours des 30 derniers jours : 9. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 29

  1. CVE-2025-61915

    Moyenne · CVSS 6EPSS 0,46%Correctif disponible

    OpenPrinting CUPS vulnerable to stack based out-of-bound write

    OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to version 2.4.15, a user in the lpadmin group can use the cups web ui to change the config and insert a malicious line. Then the cupsd process which runs as root will parse the new config and cause an out-of-bound write. This issue has been patched in version 2.4.15.

    • Mettez à jour vers 2.2.7-1ubuntu2.10+esm9
    Publication Mise à jour
  2. CVE-2025-58364

    Moyenne · CVSS 6.5EPSS 1,16%Correctif disponible

    cups: Remote DoS via null dereference

    OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. In versions 2.4.12 and earlier, an unsafe deserialization and validation of printer attributes causes null dereference in the libcups library. This is a remote DoS vulnerability available in local subnet in default configurations. It can cause the cups & cups-browsed to crash, on all the machines in local network who are listening for printers (so by default for all regular linux machines). On systems where the vulnerability CVE-2024-47176 (cups-filters 1.x/cups-browsed 2.x vulnerability) was not fixed, and the firewall on the machine does not

    • Mettez à jour vers 2.2.7-1ubuntu2.10+esm7
    Publication Mise à jour
  3. CVE-2025-58060

    Élevée · CVSS 8EPSS 1%Correctif disponible

    cups has Authentication bypass with AuthType Negotiate

    OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. In versions 2.4.12 and earlier, when the `AuthType` is set to anything but `Basic`, if the request contains an `Authorization: Basic ...` header, the password is not checked. This results in authentication bypass. Any configuration that allows an `AuthType` that is not `Basic` is affected. Version 2.4.13 fixes the issue.

    • Mettez à jour vers 2.2.7-1ubuntu2.10+esm7
    Publication Mise à jour
  4. CVE-2024-47175

    Élevée · CVSS 8.6EPSS 63,61%Code d’exploitation publicCorrectif disponible

    libppd's ppdCreatePPDFromIPP2 function does not sanitize IPP attributes when creating the PPD buffer

    CUPS is a standards-based, open-source printing system, and `libppd` can be used for legacy PPD file support. The `libppd` function `ppdCreatePPDFromIPP2` does not sanitize IPP attributes when creating the PPD buffer. When used in combination with other functions such as `cfGetPrinterAttributes5`, can result in user controlled input and ultimately code execution via Foomatic. This vulnerability can be part of an exploit chain leading to remote code execution (RCE), as described in CVE-2024-47176.

    • Mettez à jour vers 2.2.7-1ubuntu2.10+esm6
    Publication Mise à jour
  5. USN-6844-2

    Non évaluéeCorrectif disponible

    cups regression

    USN-6844-1 fixed vulnerabilities in the CUPS package. The update lead to the discovery of a regression in CUPS with regards to how the cupsd daemon handles Listen configuration directive. This update fixes the problem. We apologize for the inconvenience. Original advisory details: Rory McNamara discovered that when starting the cupsd server with a Listen configuration item, the cupsd process fails to validate if bind call passed. An attacker could possibly trick cupsd to perform an arbitrary chmod of the provided argument, providing world-writable access to the target.

    • Mettez à jour vers 2.2.7-1ubuntu2.10+esm5
    Publication Mise à jour
  6. CVE-2024-35235

    Moyenne · CVSS 4.4EPSS 2,42%Correctif disponible

    Cupsd Listen arbitrary chmod 0140777

    OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. In versions 2.4.8 and earlier, when starting the cupsd server with a Listen configuration item pointing to a symbolic link, the cupsd process can be caused to perform an arbitrary chmod of the provided argument, providing world-writable access to the target. Given that cupsd is often running as root, this can result in the change of permission of any user or system files to be world writable. Given the aforementioned Ubuntu AppArmor context, on such systems this vulnerability is limited to those files modifiable by the cupsd process. In that s

    • Mettez à jour vers 2.2.7-1ubuntu2.10+esm4
    Publication Mise à jour
  7. CVE-2023-4504

    Élevée · CVSS 7EPSS 0,64%Correctif disponible

    OpenPrinting CUPS/libppd Postscript Parsing Heap Overflow

    Due to failure in validating the length provided by an attacker-crafted PPD PostScript document, CUPS and libppd are susceptible to a heap-based buffer overflow and possibly code execution. This issue has been fixed in CUPS version 2.4.7, released in September of 2023.

    • Mettez à jour vers 2.2.7-1ubuntu2.10+esm2
    Publication Mise à jour
  8. CVE-2023-34241

    Moyenne · CVSS 5.3EPSS 1,38%Correctif disponible

    CUPS vulnerable to use-after-free in cupsdAcceptClient()

    OpenPrinting CUPS is a standards-based, open source printing system for Linux and other Unix-like operating systems. Starting in version 2.0.0 and prior to version 2.4.6, CUPS logs data of free memory to the logging service AFTER the connection has been closed, when it should have logged the data right before. This is a use-after-free bug that impacts the entire cupsd process. The exact cause of this issue is the function `httpClose(con->http)` being called in `scheduler/client.c`. The problem is that httpClose always, provided its argument is not null, frees the pointer at the end of the call, only for cupsdLogClient to pass the pointer to

    • Mettez à jour vers 2.2.7-1ubuntu2.10+esm1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →