p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de edk2 · Page n° 4

Vulnérabilité publiée pour edk2 au cours des 30 derniers jours : 1. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 79

  1. CVE-2022-0778

    Élevée · CVSS 7.5EPSS 73,19%Code d’exploitation publicAucun correctif publié

    Infinite loop in BN_mod_sqrt() reachable when parsing certificates

    The BN_mod_sqrt() function, which computes a modular square root, contains a bug that can cause it to loop forever for non-prime moduli. Internally this function is used when parsing certificates that contain elliptic curve public keys in compressed form or explicit elliptic curve parameters with a base point encoded in compressed form. It is possible to trigger the infinite loop by crafting a certificate that has invalid explicit curve parameters. Since certificate parsing happens prior to verification of the certificate signature, any process that parses an externally supplied certificate may thus be subject to a denial of service attack. T

    Publication Mise à jour
  2. CVE-2021-3712

    Élevée · CVSS 7.4EPSS 50,44%Aucun correctif publié

    Read buffer overruns processing ASN.1 strings

    ASN.1 strings are represented internally within OpenSSL as an ASN1_STRING structure which contains a buffer holding the string data and a field holding the buffer length. This contrasts with normal C strings which are repesented as a buffer for the string data which is terminated with a NUL (0) byte. Although not a strict requirement, ASN.1 strings that are parsed using OpenSSL's own "d2i" functions (and other similar parsing functions) as well as any string whose value has been set with the ASN1_STRING_set() function will additionally NUL terminate the byte array in the ASN1_STRING structure. However, it is possible for applications to direc

    Publication Mise à jour
  3. CVE-2021-23840

    Élevée · CVSS 7.5EPSS 50,73%Aucun correctif publié

    Integer overflow in CipherUpdate

    Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable length for an integer on the platform. In such cases the return value from the function call will be 1 (indicating success), but the output length value will be negative. This could cause applications to behave incorrectly or crash. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer r

    Publication Mise à jour
  4. CVE-2017-5731

    Élevée · CVSS 7.8EPSS 0,39%Correctif disponible

    CVE-2017-5731

    Bounds checking in Tianocompress before November 7, 2017 may allow an authenticated user to potentially enable an escalation of privilege via local access.

    • Mettez à jour vers 0~20180205.c0d9813c-2ubuntu0.3+esm1
    Publication Mise à jour
  5. CVE-2019-1563

    Faible · CVSS 3.7EPSS 3,84%Aucun correctif publié

    Padding Oracle in PKCS7_dataDecode and CMS_decrypt_set1_pkey

    In situations where an attacker receives automated notification of the success or failure of a decryption attempt an attacker, after sending a very large number of messages to be decrypted, can recover a CMS/PKCS7 transported encryption key or decrypt any RSA encrypted message that was encrypted with the public RSA key, using a Bleichenbacher padding oracle attack. Applications are not affected if they use a certificate together with the private RSA key to the CMS_decrypt or PKCS7_decrypt functions to select the correct recipient info to decrypt. Fixed in OpenSSL 1.1.1d (Affected 1.1.1-1.1.1c). Fixed in OpenSSL 1.1.0l (Affected 1.1.0-1.1.0k).

    Publication Mise à jour
  6. CVE-2019-0160

    Élevée · CVSS 8.7EPSS 1,34%Correctif disponible

    CVE-2019-0160

    Buffer overflow in system firmware for EDK II may allow unauthenticated user to potentially enable escalation of privilege and/or denial of service via network access.

    • Mettez à jour vers 0~20180205.c0d9813c-2ubuntu0.3+esm1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →