p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de unbound · Page n° 3

Vulnérabilités publiées pour unbound au cours des 30 derniers jours : 5. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 49

  1. CVE-2026-32792

    Moyenne · CVSS 4.6EPSS 0,34%Aucun correctif publié

    Packet of death with DNSCrypt

    NLnet Labs Unbound 1.6.2 up to and including version 1.25.0 has a denial of service vulnerability when compiled with DNSCrypt support ('--enable-dnscrypt'). A bad DNSCrypt query could underflow Unbound's DNSCrypt packet reading procedure that may lead to heap overflow. A malicious actor can exploit the vulnerability with a single bad DNSCrypt query that its decrypted plaintext consists entirely of '0x00' bytes and does not contain the expected '0x80' marker. Unbound would then start reading more bytes than necessary until it finds a non-'0x00' byte. Based on the underlying memory allocator and the memory layout, it could lead to heap overflow

    Publication Mise à jour
  2. CVE-2025-11411

    Moyenne · CVSS 5.7EPSS 0,33%Aucun correctif publié

    Possible domain hijacking via promiscuous records in the authority section

    NLnet Labs Unbound up to and including version 1.24.1 is vulnerable to possible domain hijack attacks. Promiscuous NS RRSets that complement positive DNS replies in the authority section can be used to trick resolvers to update their delegation information for the zone. Usually these RRSets are used to update the resolver's knowledge of the zone's name servers. A malicious actor can exploit the possible poisonous effect by injecting NS RRSets (and possibly their respective address records) in a reply. This could be done for example by trying to spoof a packet or fragmentation attacks. Unbound would then proceed to update the NS RRSet data it

    Publication Mise à jour
  3. CVE-2025-5994

    Élevée · CVSS 8.7EPSS 0,22%Aucun correctif publié

    Cache poisoning via the ECS-enabled Rebirthday Attack

    A multi-vendor cache poisoning vulnerability named 'Rebirthday Attack' has been discovered in caching resolvers that support EDNS Client Subnet (ECS). Unbound is also vulnerable when compiled with ECS support, i.e., '--enable-subnet', AND configured to send ECS information along with queries to upstream name servers, i.e., at least one of the 'send-client-subnet', 'client-subnet-zone' or 'client-subnet-always-forward' options is used. Resolvers supporting ECS need to segregate outgoing queries to accommodate for different outgoing ECS information. This re-opens up resolvers to a birthday paradox attack (Rebirthday Attack) that tries to match

    Publication Mise à jour
  4. CVE-2024-8508

    Moyenne · CVSS 5.3EPSS 0,8%Correctif disponible

    Unbounded name compression could lead to Denial of Service

    NLnet Labs Unbound up to and including version 1.21.0 contains a vulnerability when handling replies with very large RRsets that it needs to perform name compression for. Malicious upstreams responses with very large RRsets can cause Unbound to spend a considerable time applying name compression to downstream replies. This can lead to degraded performance and eventually denial of service in well orchestrated attacks. The vulnerability can be exploited by a malicious actor querying Unbound for the specially crafted contents of a malicious zone with very large RRsets. Before Unbound replies to the query it will try to apply name compression whi

    • Mettez à jour vers 1.6.7-1ubuntu2.6+esm3
    Publication Mise à jour
  5. CVE-2024-43168

    Moyenne · CVSS 4.8EPSS 0,31%Correctif disponible

    Unbound: heap-buffer-overflow in unbound

    DISPUTE NOTE: this issue does not pose a security risk as it (according to analysis by the original software developer, NLnet Labs) falls within the expected functionality and security controls of the application. Red Hat has made a claim that there is a security risk within Red Hat products. NLnet Labs has no further information about the claim, and suggests that affected Red Hat customers refer to available Red Hat documentation or support channels. ORIGINAL DESCRIPTION: A heap-buffer-overflow flaw was found in the cfg_mark_ports function within Unbound's config_file.c, which can lead to memory corruption. This issue could allow an attacker

    • Mettez à jour vers 1.6.7-1ubuntu2.6+esm2
    Publication Mise à jour
  6. CVE-2024-43167

    Faible · CVSS 2.8EPSS 0,39%Correctif disponible

    Unbound: null pointer dereference in unbound

    DISPUTE NOTE: this issue does not pose a security risk as it (according to analysis by the original software developer, NLnet Labs) falls within the expected functionality and security controls of the application. Red Hat has made a claim that there is a security risk within Red Hat products. NLnet Labs has no further information about the claim, and suggests that affected Red Hat customers refer to available Red Hat documentation or support channels. ORIGINAL DESCRIPTION: A NULL pointer dereference flaw was found in the ub_ctx_set_fwd function in Unbound. This issue could allow an attacker who can invoke specific sequences of API calls to ca

    • Mettez à jour vers 1.6.7-1ubuntu2.6+esm2
    Publication Mise à jour
  7. CVE-2024-33655

    Élevée · CVSS 7.5EPSS 1,74%Aucun correctif publié

    CVE-2024-33655

    The DNS protocol in RFC 1035 and updates allows remote attackers to cause a denial of service (resource consumption) by arranging for DNS queries to be accumulated for seconds, such that responses are later sent in a pulsing burst (which can be considered traffic amplification in some cases), aka the "DNSBomb" issue.

    Publication Mise à jour
  8. CVE-2023-50868

    Élevée · CVSS 7.5EPSS 74,3%Correctif disponible

    CVE-2023-50868

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations.

    • Mettez à jour vers 1.6.7-1ubuntu2.6+esm6
    Publication Mise à jour
  9. CVE-2023-50387

    Élevée · CVSS 7.5EPSS 99,99%Correctif disponible

    CVE-2023-50387

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG records, the protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.

    • Mettez à jour vers 1.6.7-1ubuntu2.6+esm6
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →