p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de python2.7 · Page n° 3

Vulnérabilités publiées pour python2.7 au cours des 30 derniers jours : 5. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 55

  1. CVE-2025-0938

    Moyenne · CVSS 6.3EPSS 1,56%Correctif disponible

    URL parser allowed square brackets in domain names

    The Python standard library functions `urllib.parse.urlsplit` and `urlparse` accepted domain names that included square brackets which isn't valid according to RFC 3986. Square brackets are only meant to be used as delimiters for specifying IPv6 and IPvFuture hosts in URLs. This could result in differential parsing across the Python URL parser and other specification-compliant URL parsers.

    • Mettez à jour vers 2.7.18-1~20.04.7+esm7
    Publication Mise à jour
  2. CVE-2024-11168

    Moyenne · CVSS 6.3EPSS 0,66%Correctif disponible

    Improper validation of IPv6 and IPvFuture addresses

    The urllib.parse.urlsplit() and urlparse() functions improperly validated bracketed hosts (`[]`), allowing hosts that weren't IPv6 or IPvFuture. This behavior was not conformant to RFC 3986 and potentially enabled SSRF if a URL is processed by more than one URL parser.

    • Mettez à jour vers 2.7.18-1~20.04.7+esm6
    Publication Mise à jour
  3. CVE-2024-7592

    Élevée · CVSS 7.5EPSS 2,3%Correctif disponible

    Quadratic complexity parsing cookies with backslashes

    There is a LOW severity vulnerability affecting CPython, specifically the 'http.cookies' standard library module. When parsing cookies that contained backslashes for quoted characters in the cookie value, the parser would use an algorithm with quadratic complexity, resulting in excess CPU resources being used while parsing the value.

    • Mettez à jour vers 2.7.18-1~20.04.4+esm2
    Publication Mise à jour
  4. CVE-2024-5642

    Moyenne · CVSS 6.5EPSS 0,74%Aucun correctif publié

    Buffer overread when using an empty list with SSLContext.set_npn_protocols()

    CPython 3.9 and earlier doesn't disallow configuring an empty list ("[]") for SSLContext.set_npn_protocols() which is an invalid value for the underlying OpenSSL API. This results in a buffer over-read when NPN is used (see CVE-2024-5535 for OpenSSL). This vulnerability is of low severity due to NPN being not widely used and specifying an empty list likely being uncommon in-practice (typically a protocol name would be configured).

    Publication Mise à jour
  5. CVE-2024-0397

    Élevée · CVSS 7.4EPSS 0,81%Aucun correctif publié

    Memory race condition in ssl.SSLContext certificate store methods

    A defect was discovered in the Python “ssl” module where there is a memory race condition with the ssl.SSLContext methods “cert_store_stats()” and “get_ca_certs()”. The race condition can be triggered if the methods are called at the same time as certificates are loaded into the SSLContext, such as during the TLS handshake with a certificate directory configured. This issue is fixed in CPython 3.10.14, 3.11.9, 3.12.3, and 3.13.0a5.

    Publication Mise à jour
  6. CVE-2024-0450

    Moyenne · CVSS 6.2EPSS 0,34%Correctif disponible

    Quoted zip-bomb protection for zipfile

    An issue was found in the CPython `zipfile` module affecting versions 3.12.1, 3.11.7, 3.10.13, 3.9.18, and 3.8.18 and prior. The zipfile module is vulnerable to “quoted-overlap” zip-bombs which exploit the zip format to create a zip-bomb with a high compression ratio. The fixed versions of CPython makes the zipfile module reject zip archives which overlap entries in the archive.

    • Mettez à jour vers 2.7.18-1~20.04.7+esm4
    Publication Mise à jour
  7. CVE-2023-27043

    Moyenne · CVSS 5.3EPSS 2,53%Correctif disponible

    CVE-2023-27043

    The email module of Python through 3.11.3 incorrectly parses e-mail addresses that contain a special character. The wrong portion of an RFC2822 header is identified as the value of the addr-spec. In some applications, an attacker can bypass a protection mechanism in which application access is granted only after verifying receipt of e-mail to a specific domain (e.g., only @company.example.com addresses may be used for signup). This occurs in email/_parseaddr.py in recent versions of Python.

    • Mettez à jour vers 2.7.18-1~20.04.4+esm3
    Publication Mise à jour
  8. CVE-2022-45061

    Élevée · CVSS 7.5EPSS 2,67%Correctif disponible

    CVE-2022-45061

    An issue was discovered in Python before 3.11.1. An unnecessary quadratic algorithm exists in one path when processing some inputs to the IDNA (RFC 3490) decoder, such that a crafted, unreasonably long name being presented to the decoder could lead to a CPU denial of service. Hostnames are often supplied by remote servers that could be controlled by a malicious actor; in such a scenario, they could trigger excessive CPU consumption on the client attempting to make use of an attacker-supplied supposed hostname. For example, the attack payload could be placed in the Location header of an HTTP response with status code 302. A fix is planned in 3

    • Mettez à jour vers 2.7.18-1~20.04.7+esm4
    Publication Mise à jour
  9. CVE-2020-10735

    Moyenne · CVSS 6.2EPSS 4,49%Aucun correctif publié

    CVE-2020-10735

    A flaw was found in python. In algorithms with quadratic time complexity using non-binary bases, when using int("text"), a system could take 50ms to parse an int string with 100,000 digits and 5s for 1,000,000 digits (float, decimal, int.from_bytes(), and int() for binary bases 2, 4, 8, 16, and 32 are not affected). The highest threat from this vulnerability is to system availability.

    Publication Mise à jour
  10. CVE-2021-4189

    Moyenne · CVSS 5.3EPSS 3,41%Correctif disponible

    CVE-2021-4189

    A flaw was found in Python, specifically in the FTP (File Transfer Protocol) client library in PASV (passive) mode. The issue is how the FTP client trusts the host from the PASV response by default. This flaw allows an attacker to set up a malicious FTP server that can trick FTP clients into connecting back to a given IP address and port. This vulnerability could lead to FTP client scanning ports, which otherwise would not have been possible.

    • Mettez à jour vers 2.7.18-1~20.04.3+esm1
    Publication Mise à jour
  11. CVE-2022-0391

    Élevée · CVSS 7.5EPSS 8,54%Correctif disponible

    CVE-2022-0391

    A flaw was found in Python, specifically within the urllib.parse module. This module helps break Uniform Resource Locator (URL) strings into components. The issue involves how the urlparse method does not sanitize input and allows characters like '\r' and '\n' in the URL path. This flaw allows an attacker to input a crafted URL, leading to injection attacks. This flaw affects Python versions prior to 3.10.0b1, 3.9.5, 3.8.11, 3.7.11 and 3.6.14.

    • Mettez à jour vers 2.7.18-1~20.04.3+esm1
    Publication Mise à jour
  12. CVE-2021-23336

    Moyenne · CVSS 5.9EPSS 40,74%Aucun correctif publié

    Web Cache Poisoning

    The package python/cpython from 0 and before 3.6.13, from 3.7.0 and before 3.7.10, from 3.8.0 and before 3.8.8, from 3.9.0 and before 3.9.2 are vulnerable to Web Cache Poisoning via urllib.parse.parse_qsl and urllib.parse.parse_qs by using a vector called parameter cloaking. When the attacker can separate query parameters using a semicolon (;), they can cause a difference in the interpretation of the request between the proxy (running with default configuration) and the server. This can result in malicious requests being cached as completely safe ones, as the proxy would usually not see the semicolon as a separator, and therefore would not in

    Publication Mise à jour
  13. CVE-2017-18207

    Moyenne · CVSS 6.5EPSS 1,32%Aucun correctif publié

    CVE-2017-18207

    The Wave_read._read_fmt_chunk function in Lib/wave.py in Python through 3.6.4 does not ensure a nonzero channel value, which allows attackers to cause a denial of service (divide-by-zero and exception) via a crafted wav format audio file. NOTE: the vendor disputes this issue because Python applications "need to be prepared to handle a wide variety of exceptions.

    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →