p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de ffmpeg · Page n° 5

Vulnérabilités publiées pour ffmpeg au cours des 30 derniers jours : 10. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 98

  1. CVE-2024-35366

    Critique · CVSS 9.1EPSS 0,65%Correctif disponible

    CVE-2024-35366

    FFmpeg n6.1.1 is Integer Overflow. The vulnerability exists in the parse_options function of sbgdec.c within the libavformat module. When parsing certain options, the software does not adequately validate the input. This allows for negative duration values to be accepted without proper bounds checking.

    • Mettez à jour vers 7:4.4.2-0ubuntu0.22.04.1+esm9
    Publication Mise à jour
  2. CVE-2024-7055

    Moyenne · CVSS 6.9EPSS 1,44%Correctif disponible

    FFmpeg pnmdec.c pnm_decode_frame heap-based overflow

    A vulnerability was found in FFmpeg up to 7.0.1. It has been classified as critical. This affects the function pnm_decode_frame in the library /libavcodec/pnmdec.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 7.0.2 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-273651.

    • Mettez à jour vers 7:4.4.2-0ubuntu0.22.04.1+esm9
    Publication Mise à jour
  3. USN-6449-2

    Non évaluéeCorrectif disponible

    ffmpeg regression

    USN-6449-1 fixed vulnerabilities in FFmpeg. Unfortunately that update could introduce a regression in tools using an FFmpeg library, like VLC. This updated fixes the problem. We apologize for the inconvenience. Original advisory details: It was discovered that FFmpeg incorrectly managed memory resulting in a memory leak. An attacker could possibly use this issue to cause a denial of service via application crash. This issue only affected Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2020-22038) It was discovered that FFmpeg incorrectly handled certain input files, leading to an integer overflow. An attacker could possibly use this iss

    • Mettez à jour vers 7:4.4.2-0ubuntu0.22.04.1+esm3
    Publication Mise à jour
  4. CVE-2022-48434

    Élevée · CVSS 8.1EPSS 1,52%Correctif disponible

    CVE-2022-48434

    libavcodec/pthread_frame.c in FFmpeg before 5.1.2, as used in VLC and other products, leaves stale hwaccel state in worker threads, which allows attackers to trigger a use-after-free and execute arbitrary code in some circumstances (e.g., hardware re-initialization upon a mid-video SPS change when Direct3D11 is used).

    • Mettez à jour vers 7:4.4.2-0ubuntu0.22.04.1+esm2
    Publication Mise à jour
  5. CVE-2022-3341

    Moyenne · CVSS 5.3EPSS 0,86%Correctif disponible

    CVE-2022-3341

    A null pointer dereference issue was discovered in 'FFmpeg' in decode_main_header() function of libavformat/nutdec.c file. The flaw occurs because the function lacks check of the return value of avformat_new_stream() and triggers the null pointer dereference error, causing an application to crash.

    • Mettez à jour vers 7:4.4.2-0ubuntu0.22.04.1+esm1
    Publication Mise à jour
  6. CVE-2022-3964

    Moyenne · CVSS 4.3EPSS 3,78%Correctif disponible

    ffmpeg QuickTime RPZA Video Encoder rpzaenc.c out-of-bounds

    A vulnerability classified as problematic has been found in ffmpeg. This affects an unknown part of the file libavcodec/rpzaenc.c of the component QuickTime RPZA Video Encoder. The manipulation of the argument y_size leads to out-of-bounds read. It is possible to initiate the attack remotely. The name of the patch is 92f9b28ed84a77138105475beba16c146bdaf984. It is recommended to apply a patch to fix this issue. The associated identifier of this vulnerability is VDB-213543.

    • Mettez à jour vers 7:4.4.2-0ubuntu0.22.04.1+esm1
    Publication Mise à jour
  7. CVE-2014-5271

    Non évaluéeEPSS 4,7%Aucun correctif publié

    CVE-2014-5271

    Heap-based buffer overflow in the encode_slice function in libavcodec/proresenc_kostya.c in FFMpeg before 1.1.14, 1.2.x before 1.2.8, 2.x before 2.2.7, and 2.3.x before 2.3.3 and Libav before 10.5 allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via unspecified vectors.

    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →