p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de php-twig · Page n° 2

Vulnérabilité publiée pour php-twig au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 22

  1. CVE-2024-45411

    Élevée · CVSS 8.6EPSS 0,85%Correctif disponible

    Twig has a possible sandbox bypass

    Twig is a template language for PHP. Under some circumstances, the sandbox security checks are not run which allows user-contributed templates to bypass the sandbox restrictions. This vulnerability is fixed in 1.44.8, 2.16.1, and 3.14.0.

    • Mettez à jour vers 3.3.8-2ubuntu4+esm2
    Publication Mise à jour
  2. CVE-2022-39261

    Élevée · CVSS 7.5EPSS 3,17%Correctif disponible

    Twig may load a template outside a configured directory when using the filesystem loader

    Twig is a template language for PHP. Versions 1.x prior to 1.44.7, 2.x prior to 2.15.3, and 3.x prior to 3.4.3 encounter an issue when the filesystem loader loads templates for which the name is a user input. It is possible to use the `source` or `include` statement to read arbitrary files from outside the templates' directory when using a namespace like `@somewhere/../some.file`. In such a case, validation is bypassed. Versions 1.44.7, 2.15.3, and 3.4.3 contain a fix for validation of such template names. There are no known workarounds aside from upgrading.

    • Mettez à jour vers 3.3.8-2ubuntu4+esm1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →