p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

apache httpd 2.4.30: bekannte Sicherheitslücken · Seite 4

Bekannte Sicherheitslücken für apache httpd 2.4.30: 86. Vergleichen Sie die unten genannten Korrekturen mit Ihrer installierten Version.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 86

  1. CVE-2024-27316

    Hoch · CVSS 7.5EPSS 91,33%Keine Korrektur veröffentlicht

    Apache HTTP Server: HTTP/2 DoS by memory exhaustion on endless continuation frames

    HTTP/2 incoming headers exceeding the limit are temporarily buffered in nghttp2 in order to generate an informative HTTP 413 response. If a client does not stop sending headers, this leads to memory exhaustion.

    Veröffentlicht Aktualisiert
  2. CVE-2024-24795

    Mittel · CVSS 6.3EPSS 2,87%Keine Korrektur veröffentlicht

    Apache HTTP Server: HTTP Response Splitting in multiple modules

    HTTP Response splitting in multiple modules in Apache HTTP Server allows an attacker that can inject malicious response headers into backend applications to cause an HTTP desynchronization attack. Users are recommended to upgrade to version 2.4.59, which fixes this issue.

    Veröffentlicht Aktualisiert
  3. CVE-2023-45802

    Mittel · CVSS 5.9EPSS 3,17%Keine Korrektur veröffentlicht

    Apache HTTP Server: HTTP/2 stream memory not reclaimed right away on RST

    When a HTTP/2 stream was reset (RST frame) by a client, there was a time window were the request's memory resources were not reclaimed immediately. Instead, de-allocation was deferred to connection close. A client could send new requests and resets, keeping the connection busy and open and causing the memory footprint to keep on growing. On connection close, all resources were reclaimed, but the process might run out of memory before that. This was found by the reporter during testing of CVE-2023-44487 (HTTP/2 Rapid Reset Exploit) with their own test client. During "normal" HTTP/2 use, the probability to hit this bug is very low. The kept me

    Veröffentlicht Aktualisiert
  4. CVE-2023-27522

    Hoch · CVSS 7.5EPSS 2,13%Keine Korrektur veröffentlicht

    Apache HTTP Server: mod_proxy_uwsgi HTTP response splitting

    HTTP Response Smuggling vulnerability in Apache HTTP Server via mod_proxy_uwsgi. This issue affects Apache HTTP Server: from 2.4.30 through 2.4.55. Special characters in the origin response header can truncate/split the response forwarded to the client.

    Veröffentlicht Aktualisiert
  5. CVE-2023-25690

    Kritisch · CVSS 9.8EPSS 84,51%Öffentlicher ExploitKeine Korrektur veröffentlicht

    Apache HTTP Server: HTTP request splitting with mod_rewrite and mod_proxy

    Some mod_proxy configurations on Apache HTTP Server versions 2.4.0 through 2.4.55 allow a HTTP Request Smuggling attack. Configurations are affected when mod_proxy is enabled along with some form of RewriteRule or ProxyPassMatch in which a non-specific pattern matches some portion of the user-supplied request-target (URL) data and is then re-inserted into the proxied request-target using variable substitution. For example, something like: RewriteEngine on RewriteRule "^/here/(.*)" "http://example.com:8080/elsewhere?$1"; [P] ProxyPassReverse /here/ http://example.com:8080/ Request splitting/smuggling could result in bypass of acc

    Veröffentlicht Aktualisiert
  6. CVE-2022-37436

    Mittel · CVSS 5.3EPSS 55,91%Korrektur verfügbar

    Apache HTTP Server: mod_proxy prior to 2.4.55 allows a backend to trigger HTTP response splitting

    Prior to Apache HTTP Server 2.4.55, a malicious backend can cause the response headers to be truncated early, resulting in some headers being incorporated into the response body. If the later headers have any security purpose, they will not be interpreted by the client.

    • Auf 2.4.55 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2022-36760

    Kritisch · CVSS 9.0EPSS 1,88%Keine Korrektur veröffentlicht

    Apache HTTP Server: mod_proxy_ajp Possible request smuggling

    Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in mod_proxy_ajp of Apache HTTP Server allows an attacker to smuggle requests to the AJP server it forwards requests to. This issue affects Apache HTTP Server Apache HTTP Server 2.4 version 2.4.54 and prior versions.

    Veröffentlicht Aktualisiert
  8. CVE-2006-20001

    Hoch · CVSS 7.5EPSS 3,55%Keine Korrektur veröffentlicht

    Apache HTTP Server: mod_dav out of bounds read, or write of zero byte

    A carefully crafted If: request header can cause a memory read, or write of a single zero byte, in a pool (heap) memory location beyond the header value sent. This could cause the process to crash. This issue affects Apache HTTP Server 2.4.54 and earlier.

    Veröffentlicht Aktualisiert
  9. CVE-2022-31813

    Kritisch · CVSS 9.8EPSS 3,54%Keine Korrektur veröffentlicht

    mod_proxy X-Forwarded-For dropped by hop-by-hop mechanism

    Apache HTTP Server 2.4.53 and earlier may not send the X-Forwarded-* headers to the origin server based on client side Connection header hop-by-hop mechanism. This may be used to bypass IP based authentication on the origin server/application.

    Veröffentlicht Aktualisiert
  10. CVE-2022-28615

    Kritisch · CVSS 9.1EPSS 6,28%Keine Korrektur veröffentlicht

    Read beyond bounds in ap_strcmp_match()

    Apache HTTP Server 2.4.53 and earlier may crash or disclose information due to a read beyond bounds in ap_strcmp_match() when provided with an extremely large input buffer. While no code distributed with the server can be coerced into such a call, third-party modules or lua scripts that use ap_strcmp_match() may hypothetically be affected.

    Veröffentlicht Aktualisiert
  11. CVE-2022-28614

    Mittel · CVSS 5.3EPSS 4,98%Keine Korrektur veröffentlicht

    read beyond bounds via ap_rwrite()

    The ap_rwrite() function in Apache HTTP Server 2.4.53 and earlier may read unintended memory if an attacker can cause the server to reflect very large input using ap_rwrite() or ap_rputs(), such as with mod_luas r:puts() function. Modules compiled and distributed separately from Apache HTTP Server that use the 'ap_rputs' function and may pass it a very large (INT_MAX or larger) string must be compiled against current headers to resolve the issue.

    Veröffentlicht Aktualisiert
  12. CVE-2022-26377

    Hoch · CVSS 7.5EPSS 21,08%Keine Korrektur veröffentlicht

    mod_proxy_ajp: Possible request smuggling

    Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in mod_proxy_ajp of Apache HTTP Server allows an attacker to smuggle requests to the AJP server it forwards requests to. This issue affects Apache HTTP Server Apache HTTP Server 2.4 version 2.4.53 and prior versions.

    Veröffentlicht Aktualisiert
  13. CVE-2022-22721

    Kritisch · CVSS 9.1EPSS 41,71%Keine Korrektur veröffentlicht

    core: Possible buffer overflow with very large or unlimited LimitXMLRequestBody

    If LimitXMLRequestBody is set to allow request bodies larger than 350MB (defaults to 1M) on 32 bit systems an integer overflow happens which later causes out of bounds writes. This issue affects Apache HTTP Server 2.4.52 and earlier.

    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →