p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in jruby · Seite 2

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für jruby: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 26

  1. CVE-2018-1000074

    Hoch · CVSS 7.8EPSS 2,88%Korrektur verfügbar

    CVE-2018-1000074

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Deserialization of Untrusted Data vulnerability in owner command that can result in code execution. This attack appear to be exploitable via victim must run the `gem owner` command on a gem with a specially crafted YAML file. This vulnerability appears to have been fixed in 2.7.6.

    • Auf 9.1.17.0-1 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2018-1000073

    Hoch · CVSS 7.5EPSS 4,91%Korrektur verfügbar

    CVE-2018-1000073

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in install_location function of package.rb that can result in path traversal when writing to a symlinked basedir outside of the root. This vulnerability appears to have been fixed in 2.7.6.

    • Auf 9.1.17.0-2.1 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2015-3900

    Nicht bewertetEPSS 8,87%Korrektur verfügbar

    CVE-2015-3900

    RubyGems 2.0.x before 2.0.16, 2.2.x before 2.2.4, and 2.4.x before 2.4.7 does not validate the hostname when fetching gems or making API requests, which allows remote attackers to redirect requests to arbitrary domains via a crafted DNS SRV record, aka a "DNS hijack attack."

    • Auf 1.7.20.1-2 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2012-5370

    Nicht bewertetEPSS 2,25%Korrektur verfügbar

    CVE-2012-5370

    JRuby computes hash values without properly restricting the ability to trigger hash collisions predictably, which allows context-dependent attackers to cause a denial of service (CPU consumption) via crafted input to an application that maintains a hash table, as demonstrated by a universal multicollision attack against the MurmurHash2 algorithm, a different vulnerability than CVE-2011-4838.

    • Auf 1.5.6-5 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2010-1330

    Nicht bewertetEPSS 2,22%Korrektur verfügbar

    CVE-2010-1330

    The regular expression engine in JRuby before 1.4.1, when $KCODE is set to 'u', does not properly handle characters immediately after a UTF-8 character, which allows remote attackers to conduct cross-site scripting (XSS) attacks via a crafted string.

    • Auf 1.5.0~rc1-1 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2011-4838

    Nicht bewertetEPSS 4,2%Korrektur verfügbar

    CVE-2011-4838

    JRuby before 1.6.5.1 computes hash values without restricting the ability to trigger hash collisions predictably, which allows context-dependent attackers to cause a denial of service (CPU consumption) via crafted input to an application that maintains a hash table.

    • Auf 1.5.6-4 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →