p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in unbound · Seite 3

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für unbound: 5. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 87

  1. CVE-2026-42960

    Mittel · CVSS 5.7EPSS 0,26%Korrektur verfügbar

    Possible cache poisoning via promiscuous records for the authority section

    NLnet Labs Unbound up to and including version 1.25.0 is vulnerable to poisoning via promiscuous records for the authority section. Promiscuous RRSets that complement DNS replies in the authority section can be used to trick Unbound to cache such records. If an adversary is able to attach such records in a reply (i.e., spoofed packet, fragmentation attack) he would be able to poison Unbound's cache. A malicious actor can exploit the possible poisonous effect by injecting RRSets other than NS that are also accompanied by address records in a reply, for example MX. This could be achieved by trying to spoof a reply packet or fragmentation attack

    • Auf 1.22.0-2+deb13u3 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2026-42959

    Hoch · CVSS 8.7EPSS 0,81%Korrektur verfügbar

    Crash during DNSSEC validation of malicious content

    NLnet Labs Unbound up to and including version 1.25.0 has a denial of service vulnerability in the DNSSEC validator that can lead to a crash given malicious upstream replies. When Unbound constructs chase-reply messages for validation, the code uses the wrong counter to calculate write offsets for ADDITIONAL section rrsets. DNAME duplication could increase the ANSWER section count and authority filtering could decrease the AUTHORITY section count and create an uninitialized array slot. Combining these two, the validator later dereferences this uninitialized pointer, causing an immediate process crash. An adversary controlling a DNSSEC-signed

    • Auf 1.22.0-2+deb13u3 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2026-42944

    Hoch · CVSS 8.7EPSS 0,84%Korrektur verfügbar

    Heap overflow with multiple NSID, COOKIE, PADDING EDNS options

    NLnet Labs Unbound 1.14.0 up to and including version 1.25.0 has a vulnerability that results in heap overflow when encoding multiple NSID and/or DNS Cookie EDNS and/or EDNS Padding options in the reply packet. The relevant options ('nsid', 'answer-cookie', 'pad-responses' (default)) need to be enabled for the vulnerability to be exploited. An adversary who can query Unbound can exploit the vulnerability by attaching multiple NSID and/or DNS Cookie EDNS and/or EDNS Padding options to the query. A flaw in the size calculation of the EDNS field truncates the correct value which allows the encoder to overflow the available space when writing. Th

    • Auf 1.22.0-2+deb13u3 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2026-42923

    Mittel · CVSS 6.9EPSS 0,34%Korrektur verfügbar

    Degradation of service with unbounded NSEC3 hash calculations

    NLnet Labs Unbound up to and including version 1.25.0 has a vulnerability in the DNSSEC validator where the code path to consult the negative cache for DS records does not take into account the limit on NSEC3 hash calculations introduced in 1.19.1. This leads to degradation of service during the attack. An adversary that controls a DNSSEC signed zone can exploit this by signing NSEC3 records with acceptably high iterations for child delegations and querying a vulnerable Unbound. Unbound will keep performing the allowed hash calculations on the NSEC3 records and will not limit the work by the mitigation introduced in 1.19.1. As a side effect,

    • Auf 1.22.0-2+deb13u3 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2026-42534

    Mittel · CVSS 6.9EPSS 0,6%Korrektur verfügbar

    Jostle logic bypass degrades resolution performance

    NLnet Labs Unbound up to and including version 1.25.0 has a vulnerability in the jostle logic that could defeat its purpose and degrade resolution performance. Retransmits of the same query could renew the age of slow running queries and not allow the jostle logic to see them as aged and potential targets for replacement with new queries. An adversary who can query a vulnerable Unbound and who can control a domain name server that replies slowly and/or maliciously to Unbound's queries can exploit the vulnerability and degrade the resolution performance of Unbound. When Unbound's 'num-queries-per-thread' reaches its limit, the jostle logic kic

    • Auf 1.22.0-2+deb13u3 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2026-41292

    Mittel · CVSS 6.6EPSS 0,75%Korrektur verfügbar

    Long list of incoming EDNS options degrades performance

    NLnet Labs Unbound up to and including version 1.25.0 is vulnerable to a degradation of service attack related to parsing long lists of incoming EDNS options. An adversary sending queries with too many EDNS options can hold Unbound threads hostage while they are parsing and creating internal data structures for the options. Coordinated attacks can result in degradation and/or denial of service. Unbound 1.25.1 contains a patch with a fix to limit acceptable incoming EDNS options (100).

    • Auf 1.22.0-2+deb13u3 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2026-40622

    Mittel · CVSS 6.6EPSS 0,14%Korrektur verfügbar

    Another 'ghost domain names' attack variant

    NLnet Labs Unbound 1.16.2 up to and including version 1.25.0 has a vulnerability of the 'ghost domain names' family of attacks that could extend the ghost domain window by up to one cached TTL configured value. Similar to other 'ghost domain names' attacks, an adversary needs to control a (ghost) zone and be able to query a vulnerable Unbound. A single client NS query can cause Unbound to overwrite the cached expired parent-side referral NS rrset with the child-side apex NS rrset and essentially extend the ghost domain window by up to one cached TTL configured value ('cache-max-ttl'). In configurations where 'harden-referral-path: yes' is use

    • Auf 1.26.1-0+deb13u1 aktualisieren
    Veröffentlicht Aktualisiert
  8. CVE-2026-33278

    Kritisch · CVSS 9.1EPSS 1,42%Korrektur verfügbar

    Possible arbitrary code execution during DNSSEC validation

    NLnet Labs Unbound 1.19.1 up to and including version 1.25.0 has a vulnerability in the DNSSEC validator that enables denial of service and possible remote code execution as a result of deep copying a data structure and erroneously overwriting a destination pointer. An adversary can exploit the vulnerability by controlling a malicious signed zone and querying a vulnerable Unbound. When DS sub-queries need to suspend validation due to NSEC3 computational budget exhaustion (introduced in Unbound 1.19.1), Unbound deep-copies response messages to preserve them across memory region teardown. A struct-assignment bug overwrites the destination's poi

    • Auf 1.22.0-2+deb13u3 aktualisieren
    Veröffentlicht Aktualisiert
  9. CVE-2026-32792

    Mittel · CVSS 4.6EPSS 0,34%Korrektur verfügbar

    Packet of death with DNSCrypt

    NLnet Labs Unbound 1.6.2 up to and including version 1.25.0 has a denial of service vulnerability when compiled with DNSCrypt support ('--enable-dnscrypt'). A bad DNSCrypt query could underflow Unbound's DNSCrypt packet reading procedure that may lead to heap overflow. A malicious actor can exploit the vulnerability with a single bad DNSCrypt query that its decrypted plaintext consists entirely of '0x00' bytes and does not contain the expected '0x80' marker. Unbound would then start reading more bytes than necessary until it finds a non-'0x00' byte. Based on the underlying memory allocator and the memory layout, it could lead to heap overflow

    • Auf 1.22.0-2+deb13u3 aktualisieren
    Veröffentlicht Aktualisiert
  10. CVE-2025-11411

    Mittel · CVSS 5.7EPSS 0,33%Korrektur verfügbar

    Possible domain hijacking via promiscuous records in the authority section

    NLnet Labs Unbound up to and including version 1.24.1 is vulnerable to possible domain hijack attacks. Promiscuous NS RRSets that complement positive DNS replies in the authority section can be used to trick resolvers to update their delegation information for the zone. Usually these RRSets are used to update the resolver's knowledge of the zone's name servers. A malicious actor can exploit the possible poisonous effect by injecting NS RRSets (and possibly their respective address records) in a reply. This could be done for example by trying to spoof a packet or fragmentation attacks. Unbound would then proceed to update the NS RRSet data it

    • Auf 1.22.0-2+deb13u1 aktualisieren
    Veröffentlicht Aktualisiert
  11. CVE-2025-5994

    Hoch · CVSS 8.7EPSS 0,22%Korrektur verfügbar

    Cache poisoning via the ECS-enabled Rebirthday Attack

    A multi-vendor cache poisoning vulnerability named 'Rebirthday Attack' has been discovered in caching resolvers that support EDNS Client Subnet (ECS). Unbound is also vulnerable when compiled with ECS support, i.e., '--enable-subnet', AND configured to send ECS information along with queries to upstream name servers, i.e., at least one of the 'send-client-subnet', 'client-subnet-zone' or 'client-subnet-always-forward' options is used. Resolvers supporting ECS need to segregate outgoing queries to accommodate for different outgoing ECS information. This re-opens up resolvers to a birthday paradox attack (Rebirthday Attack) that tries to match

    • Auf 1.22.0-2 aktualisieren
    Veröffentlicht Aktualisiert
  12. CVE-2024-8508

    Mittel · CVSS 5.3EPSS 0,8%Korrektur verfügbar

    Unbounded name compression could lead to Denial of Service

    NLnet Labs Unbound up to and including version 1.21.0 contains a vulnerability when handling replies with very large RRsets that it needs to perform name compression for. Malicious upstreams responses with very large RRsets can cause Unbound to spend a considerable time applying name compression to downstream replies. This can lead to degraded performance and eventually denial of service in well orchestrated attacks. The vulnerability can be exploited by a malicious actor querying Unbound for the specially crafted contents of a malicious zone with very large RRsets. Before Unbound replies to the query it will try to apply name compression whi

    • Auf 1.21.1-1 aktualisieren
    Veröffentlicht Aktualisiert
  13. CVE-2024-43168

    Mittel · CVSS 4.8EPSS 0,31%Korrektur verfügbar

    Unbound: heap-buffer-overflow in unbound

    DISPUTE NOTE: this issue does not pose a security risk as it (according to analysis by the original software developer, NLnet Labs) falls within the expected functionality and security controls of the application. Red Hat has made a claim that there is a security risk within Red Hat products. NLnet Labs has no further information about the claim, and suggests that affected Red Hat customers refer to available Red Hat documentation or support channels. ORIGINAL DESCRIPTION: A heap-buffer-overflow flaw was found in the cfg_mark_ports function within Unbound's config_file.c, which can lead to memory corruption. This issue could allow an attacker

    • Auf 1.20.0-1 aktualisieren
    Veröffentlicht Aktualisiert
  14. CVE-2024-43167

    Niedrig · CVSS 2.8EPSS 0,39%Korrektur verfügbar

    Unbound: null pointer dereference in unbound

    DISPUTE NOTE: this issue does not pose a security risk as it (according to analysis by the original software developer, NLnet Labs) falls within the expected functionality and security controls of the application. Red Hat has made a claim that there is a security risk within Red Hat products. NLnet Labs has no further information about the claim, and suggests that affected Red Hat customers refer to available Red Hat documentation or support channels. ORIGINAL DESCRIPTION: A NULL pointer dereference flaw was found in the ub_ctx_set_fwd function in Unbound. This issue could allow an attacker who can invoke specific sequences of API calls to ca

    • Auf 1.21.1-1 aktualisieren
    Veröffentlicht Aktualisiert
  15. CVE-2024-33655

    Hoch · CVSS 7.5EPSS 1,74%Korrektur verfügbar

    CVE-2024-33655

    The DNS protocol in RFC 1035 and updates allows remote attackers to cause a denial of service (resource consumption) by arranging for DNS queries to be accumulated for seconds, such that responses are later sent in a pulsing burst (which can be considered traffic amplification in some cases), aka the "DNSBomb" issue.

    • Auf 1.20.0-1 aktualisieren
    Veröffentlicht Aktualisiert
  16. CVE-2024-1931

    Hoch · CVSS 7.5EPSS 2,52%Korrektur verfügbar

    Denial of service when trimming EDE text on positive replies

    NLnet Labs Unbound version 1.18.0 up to and including version 1.19.1 contain a vulnerability that can cause denial of service by a certain code path that can lead to an infinite loop. Unbound 1.18.0 introduced a feature that removes EDE records from responses with size higher than the client's advertised buffer size. Before removing all the EDE records however, it would try to see if trimming the extra text fields on those records would result in an acceptable size while still retaining the EDE codes. Due to an unchecked condition, the code that trims the text of the EDE records could loop indefinitely. This happens when Unbound would reply w

    • Auf 1.19.2-1 aktualisieren
    Veröffentlicht Aktualisiert
  17. CVE-2023-50868

    Hoch · CVSS 7.5EPSS 74,3%Korrektur verfügbar

    CVE-2023-50868

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations.

    • Auf 1.19.1-1 aktualisieren
    Veröffentlicht Aktualisiert
  18. CVE-2023-50387

    Hoch · CVSS 7.5EPSS 99,99%Korrektur verfügbar

    CVE-2023-50387

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG records, the protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.

    • Auf 1.19.1-1 aktualisieren
    Veröffentlicht Aktualisiert
  19. CVE-2022-3204

    Hoch · CVSS 7.5EPSS 1,65%Korrektur verfügbar

    NRDelegation Attack

    A vulnerability named 'Non-Responsive Delegation Attack' (NRDelegation Attack) has been discovered in various DNS resolving software. The NRDelegation Attack works by having a malicious delegation with a considerable number of non responsive nameservers. The attack starts by querying a resolver for a record that relies on those unresponsive nameservers. The attack can cause a resolver to spend a lot of time/resources resolving records under a malicious delegation point where a considerable number of unresponsive NS records reside. It can trigger high CPU usage in some resolver implementations that continually look in the cache for resolved NS

    • Auf 1.16.3-1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →