p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in ghostscript · Seite 4

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für ghostscript: 2. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 165

  1. CVE-2020-16293

    Mittel · CVSS 5.5EPSS 1,77%Korrektur verfügbar

    CVE-2020-16293

    A null pointer dereference vulnerability in compose_group_nonknockout_nonblend_isolated_allmask_common() in base/gxblend.c of Artifex Software GhostScript v9.50 allows a remote attacker to cause a denial of service via a crafted PDF file. This is fixed in v9.51.

    • Auf 9.51~dfsg-1 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2020-15900

    Kritisch · CVSS 9.8EPSS 5,19%Korrektur verfügbar

    CVE-2020-15900

    A memory corruption issue was found in Artifex Ghostscript 9.50 and 9.52. Use of a non-standard PostScript operator can allow overriding of file access controls. The 'rsearch' calculation for the 'post' size resulted in a size that was too large, and could underflow to max uint32_t. This was fixed in commit 5d499272b95a6b890a1397e11d20937de000d31b.

    • Auf 9.52.1~dfsg-1 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2019-14812

    Hoch · CVSS 7.3EPSS 2,47%Korrektur verfügbar

    CVE-2019-14812

    A flaw was found in all ghostscript versions 9.x before 9.50, in the .setuserparams2 procedure where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. A specially crafted PostScript file could disable security protection and then have access to the file system, or execute arbitrary commands.

    • Auf 9.28~~rc2~dfsg-1 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2019-10216

    Hoch · CVSS 7.3EPSS 2,3%Korrektur verfügbar

    CVE-2019-10216

    In ghostscript before version 9.50, the .buildfont1 procedure did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. An attacker could abuse this flaw by creating a specially crafted PostScript file that could escalate privileges and access files outside of restricted areas.

    • Auf 9.27~dfsg-3.1 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2019-14869

    Hoch · CVSS 7.3EPSS 3,09%Korrektur verfügbar

    CVE-2019-14869

    A flaw was found in all versions of ghostscript 9.x before 9.50, where the `.charkeys` procedure, where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. An attacker could abuse this flaw by creating a specially crafted PostScript file that could escalate privileges within the Ghostscript and access files outside of restricted areas or execute commands.

    • Auf 9.50~dfsg-3 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2019-14813

    Hoch · CVSS 7.3EPSS 10,96%Korrektur verfügbar

    CVE-2019-14813

    A flaw was found in ghostscript, versions 9.x before 9.50, in the setsystemparams procedure where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. A specially crafted PostScript file could disable security protection and then have access to the file system, or execute arbitrary commands.

    • Auf 9.28~~rc2~dfsg-1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →