p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in contao/core-bundle · Seite 2

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für contao/core-bundle: 6. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 40

  1. CVE-2024-28235

    Hoch · CVSS 8.4EPSS 0,71%Korrektur verfügbar

    Contao possible cookie sharing with external domains while checking protected pages for broken links

    Contao is an open source content management system. Starting in version 4.9.0 and prior to versions 4.13.40 and 5.3.4, when checking for broken links on protected pages, Contao sends the cookie header to external urls as well, the passed options for the http client are used for all requests. Contao versions 4.13.40 and 5.3.4 have a patch for this issue. As a workaround, disable crawling protected pages.

    • Auf 4.13.40 aktualisieren
    • Auf 5.3.4 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2024-28191

    Niedrig · CVSS 3.1EPSS 0,5%Korrektur verfügbar

    Contao may have unencoded insert tags in the frontend

    Contao is an open source content management system. Starting in version 4.0.0 and prior to version 4.13.40 and 5.3.4, it is possible to inject insert tags in frontend forms if the output is structured in a very specific way. Contao versions 4.13.40 and 5.3.4 have a patch for this issue. As a workaround, do not output user data from frontend forms next to each other, always separate them by at least one character.

    • Auf 4.13.40 aktualisieren
    • Auf 5.3.4 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2024-28190

    Mittel · CVSS 5.4EPSS 0,5%Korrektur verfügbar

    Contao core bundle vulnerable to cross site scripting in the file manager

    Contao is an open source content management system. Starting in version 4.0.0 and prior to version 4.13.40 and 5.3.4, users can inject malicious code in filenames when uploading files (back end and front end), which is then executed in tooltips and popups in the back end. Contao versions 4.13.40 and 5.3.4 have a patch for this issue. As a workaround, remove upload fields from frontend forms and disable uploads for untrusted back end users.

    • Auf 4.13.40 aktualisieren
    • Auf 5.3.4 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2023-36806

    Mittel · CVSS 6.5EPSS 0,64%Korrektur verfügbar

    Contao cross site scripting vulnerability via input unit widget

    Contao is an open source content management system. Starting in version 4.0.0 and prior to versions 4.9.42, 4.13.28, and 5.1.10, it is possible for untrusted backend users to inject malicious code into headline fields in the back end, which will be executed both in the element preview (back end) and on the website (front end). Installations are only affected if there are untrusted back end users who have the rights to modify headline fields, or other fields using the input unit widget. Contao 4.9.42, 4.13.28, and 5.1.10 have a patch for this issue. As a workaround, disable the login for all untrusted back end users.

    • Auf 4.13.28 aktualisieren
    • Auf 4.9.42 aktualisieren
    • Auf 5.1.10 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2022-24899

    Hoch · CVSS 7.2EPSS 4,48%Öffentlicher ExploitKorrektur verfügbar

    Cross site scripting via canonical tag

    Contao is a powerful open source CMS that allows you to create professional websites and scalable web applications. In versions of Contao prior to 4.13.3 it is possible to inject code into the canonical tag. As a workaround users may disable canonical tags in the root page settings.

    • Auf 4.13.3 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2021-37627

    Hoch · CVSS 8EPSS 1,02%Korrektur verfügbar

    Privilege escalation via form generator

    Contao is an open source CMS that allows creation of websites and scalable web applications. In affected versions it is possible to gain privileged rights in the Contao back end. Installations are only affected if they have untrusted back end users who have access to the form generator. All users are advised to update to Contao 4.4.56, 4.9.18 or 4.11.7. As a workaround users may disable the form generator or disable the login for untrusted back end users.

    • Auf 4.11.7 aktualisieren
    • Auf 4.4.56 aktualisieren
    • Auf 4.9.18 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2021-37626

    Hoch · CVSS 7.2EPSS 1,25%Korrektur verfügbar

    PHP file inclusion via insert tags

    Contao is an open source CMS that allows you to create websites and scalable web applications. In affected versions it is possible to load PHP files by entering insert tags in the Contao back end. Installations are only affected if they have untrusted back end users who have the rights to modify fields that are shown in the front end. Update to Contao 4.4.56, 4.9.18 or 4.11.7 to resolve. If you cannot update then disable the login for untrusted back end users.

    • Auf 4.11.7 aktualisieren
    • Auf 4.4.56 aktualisieren
    • Auf 4.9.18 aktualisieren
    Veröffentlicht Aktualisiert
  8. CVE-2021-35210

    Mittel · CVSS 6.1EPSS 0,74%Korrektur verfügbar

    CVE-2021-35210

    Contao 4.5.x through 4.9.x before 4.9.16, and 4.10.x through 4.11.x before 4.11.5, allows XSS. It is possible to inject code into the tl_log table that will be executed in the browser when the system log is called in the back end.

    • Auf 4.11.5 aktualisieren
    • Auf 4.9.16 aktualisieren
    Veröffentlicht Aktualisiert
  9. CVE-2020-25768

    Mittel · CVSS 5.3EPSS 0,82%Korrektur verfügbar

    CVE-2020-25768

    Contao before 4.4.52, 4.9.x before 4.9.6, and 4.10.x before 4.10.1 have Improper Input Validation. It is possible to inject insert tags in front end forms which will be replaced when the page is rendered.

    • Auf 4.10.1 aktualisieren
    • Auf 4.4.52 aktualisieren
    • Auf 4.9.6 aktualisieren
    Veröffentlicht Aktualisiert
  10. CVE-2017-10993

    Hoch · CVSS 8.8EPSS 2,72%Korrektur verfügbar

    CVE-2017-10993

    Contao before 3.5.28 and 4.x before 4.4.1 allows remote attackers to include and execute arbitrary local PHP files via a crafted parameter in a URL, aka Directory Traversal.

    • Auf 4.4.1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →