p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in vyper · Seite 3

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für vyper: 7. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 47

  1. CVE-2023-30629

    Hoch · CVSS 7.5EPSS 0,88%Korrektur verfügbar

    Vyper's raw_call with outsize=0 and revert_on_failure=False returns incorrect success value

    Vyper is a Pythonic Smart Contract Language for the ethereum virtual machine. In versions 0.3.1 through 0.3.7, the Vyper compiler generates the wrong bytecode. Any contract that uses the `raw_call` with `revert_on_failure=False` and `max_outsize=0` receives the wrong response from `raw_call`. Depending on the memory garbage, the result can be either `True` or `False`. A patch is available and, as of time of publication, anticipated to be part of Vyper 0.3.8. As a workaround, one may always put `max_outsize>0`.

    • Auf 0.3.8 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2022-29255

    Hoch · CVSS 8.2EPSS 1,35%Korrektur verfügbar

    Multiple evaluation of contract address in call in vyper

    Vyper is a Pythonic Smart Contract Language for the ethereum virtual machine. In versions prior to 0.3.4 when a calling an external contract with no return value, the contract address (including side effects) could be evaluated twice. This may result in incorrect outcomes for contracts. This issue has been addressed in v0.3.4.

    • Auf 0.3.4 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2022-24845

    Hoch · CVSS 8.8EPSS 1,43%Korrektur verfügbar

    Integer bounds error in Vyper

    Vyper is a pythonic Smart Contract Language for the ethereum virtual machine. In affected versions, the return of `<iface>.returns_int128()` is not validated to fall within the bounds of `int128`. This issue can result in a misinterpretation of the integer value and lead to incorrect behavior. As of v0.3.0, `<iface>.returns_int128()` is validated in simple expressions, but not complex expressions. Users are advised to upgrade. There is no known workaround for this issue.

    • Auf 0.3.2 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2022-24788

    Hoch · CVSS 7.1EPSS 0,99%Korrektur verfügbar

    Buffer overflow in Vyper

    Vyper is a pythonic Smart Contract Language for the ethereum virtual machine. Versions of vyper prior to 0.3.2 suffer from a potential buffer overrun. Importing a function from a JSON interface which returns `bytes` generates bytecode which does not clamp bytes length, potentially resulting in a buffer overrun. Users are advised to upgrade. There are no known workarounds for this issue.

    • Auf 0.3.2 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2022-24787

    Hoch · CVSS 7.5EPSS 1,03%Korrektur verfügbar

    Incorrect Comparison in Vyper

    Vyper is a Pythonic Smart Contract Language for the Ethereum Virtual Machine. In version 0.3.1 and prior, bytestrings can have dirty bytes in them, resulting in the word-for-word comparisons giving incorrect results. Even without dirty nonzero bytes, two bytestrings can compare to equal if one ends with `"\x00"` because there is no comparison of the length. A patch is available and expected to be part of the 0.3.2 release. There are currently no known workarounds.

    • Auf 0.3.2 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2021-41121

    Hoch · CVSS 7.5EPSS 1,07%Korrektur verfügbar

    Memory corruption in Vyper

    Vyper is a Pythonic Smart Contract Language for the EVM. In affected versions when performing a function call inside a literal struct, there is a memory corruption issue that occurs because of an incorrect pointer to the the top of the stack. This issue has been resolved in version 0.3.0.

    • Auf 0.3.0 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2021-41122

    Mittel · CVSS 4.3EPSS 0,8%Korrektur verfügbar

    Bounds check missing for decimal args in Vyper

    Vyper is a Pythonic Smart Contract Language for the EVM. In affected versions external functions did not properly validate the bounds of decimal arguments. The can lead to logic errors. This issue has been resolved in version 0.3.0.

    • Auf 0.3.0 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →