p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Schwachstellen im Stack PHP · Seite 132

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für PHP: 222. Davon im KEV-Katalog: 2.

Sicherheitslücken filtern
PHP

Frühwarnungen

Neue Schwachstellenmeldungen aus Herstellerankündigungen und Sicherheitsnachrichten. Diese Warnungen ändern die Sicherheitsbewertung nicht.

  1. php

    Keine Korrektur veröffentlicht

    PHP: Remote-Codeausführung

    Laut OpenNet wurde in PHP eine Sicherheitslücke gefunden: Remote-Codeausführung (CVE-2026-115560). Die betroffenen Versionen sind nicht genau angegeben. Im Bericht wird keine Version mit Fehlerbehebung genannt.

    Was jetzt zu tun ist: Prüfen Sie, ob ein Update für PHP mit der Fehlerbehebung verfügbar ist, und installieren Sie es.

    CVE-2026-115560

Sicherheitslücken: 7239

  1. CVE-2024-50343

    Niedrig · CVSS 3.1EPSS 0,46%Korrektur verfügbar

    Incorrect response from Validator when input ends with `\n` in symfony/validator

    symfony/validator is a module for the Symphony PHP framework which provides tools to validate values. It is possible to trick a `Validator` configured with a regular expression using the `$` metacharacters, with an input ending with `\n`. Symfony as of versions 5.4.43, 6.4.11, and 7.1.4 now uses the `D` regex modifier to match the entire input. Users are advised to upgrade. There are no known workarounds for this vulnerability.

    • Auf 4.3.8+dfsg-1ubuntu1+esm2 aktualisieren
    • Auf 5.4.23+dfsg-1+deb12u3 aktualisieren
    • Auf 5.4.4+dfsg-1ubuntu8+esm1 aktualisieren
    • Auf 5.4.43 aktualisieren
    • Auf 6.4.11 aktualisieren
    • Auf 6.4.11+dfsg-1 aktualisieren
    • Auf 6.4.5+dfsg-3ubuntu3+esm1 aktualisieren
    • Auf 7.1.4 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2024-50345

    Niedrig · CVSS 3.1EPSS 0,59%Korrektur verfügbar

    Open redirect via browser-sanitized URLs in symfony/http-foundation

    symfony/http-foundation is a module for the Symphony PHP framework which defines an object-oriented layer for the HTTP specification. The `Request` class, does not parse URI with special characters the same way browsers do. As a result, an attacker can trick a validator relying on the `Request` class to redirect users to another domain. The `Request::create` methods now assert the URI does not contain invalid characters as defined by https://url.spec.whatwg.org/. This issue has been patched in versions 5.4.46, 6.4.14, and 7.1.7. Users are advised to upgrade. There are no known workarounds for this vulnerability.

    • Auf 4.3.8+dfsg-1ubuntu1+esm2 aktualisieren
    • Auf 5.4.23+dfsg-1+deb12u3 aktualisieren
    • Auf 5.4.4+dfsg-1ubuntu8+esm1 aktualisieren
    • Auf 5.4.46 aktualisieren
    • Auf 6.4.14 aktualisieren
    • Auf 6.4.14+dfsg-1 aktualisieren
    • Auf 6.4.5+dfsg-3ubuntu3+esm1 aktualisieren
    • Auf 7.1.7 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2024-51736

    Niedrig · CVSS 0EPSS 0,43%Korrektur verfügbar

    Command execution hijack on Windows with Process class in symfony/process

    Symphony process is a module for the Symphony PHP framework which executes commands in sub-processes. On Windows, when an executable file named `cmd.exe` is located in the current working directory it will be called by the `Process` class when preparing command arguments, leading to possible hijacking. This issue has been addressed in release versions 5.4.46, 6.4.14, and 7.1.7. Users are advised to upgrade. There are no known workarounds for this vulnerability.

    • Auf 5.4.46 aktualisieren
    • Auf 6.4.14 aktualisieren
    • Auf 7.1.7 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2024-51754

    Niedrig · CVSS 2.2EPSS 0,43%Korrektur verfügbar

    Unguarded calls to __toString() when nesting an object into an array in Twig

    Twig is a template language for PHP. In a sandbox, an attacker can call `__toString()` on an object even if the `__toString()` method is not allowed by the security policy when the object is part of an array or an argument list (arguments to a function or a filter for instance). This issue has been patched in versions 3.11.2 and 3.14.1. All users are advised to upgrade. There are no known workarounds for this issue.

    • Auf 2.12.5-1ubuntu0.1~esm2 aktualisieren
    • Auf 3.11.2 aktualisieren
    • Auf 3.14.1 aktualisieren
    • Auf 3.14.2-1 aktualisieren
    • Auf 3.3.8-2ubuntu4+esm2 aktualisieren
    • Auf 3.5.1-1+deb12u3 aktualisieren
    • Auf 3.8.0-2ubuntu0.1~esm1 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2024-51755

    Niedrig · CVSS 2.2EPSS 0,43%Korrektur verfügbar

    Unguarded calls to __isset() and to array-accesses when the sandbox is enabled in Twig

    Twig is a template language for PHP. In a sandbox, an attacker can access attributes of Array-like objects as they were not checked by the security policy. They are now checked via the property policy and the `__isset()` method is now called after the security check. This is a BC break. This issue has been patched in versions 3.11.2 and 3.14.1. All users are advised to upgrade. There are no known workarounds for this issue.

    • Auf 3.11.2 aktualisieren
    • Auf 3.14.1 aktualisieren
    • Auf 3.14.2-1 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2024-50347

    Mittel · CVSS 6.3EPSS 0,35%Korrektur verfügbar

    Laravel Reverb has Missing API Signature Verification

    Laravel Reverb provides a real-time WebSocket communication backend for Laravel applications. Prior to 1.4.0, there is an issue where verification signatures for requests sent to Reverb's Pusher-compatible API were not being verified. This API is used in scenarios such as broadcasting a message from a backend service or for obtaining statistical information (such as number of connections) about a given channel. This issue only affects the Pusher-compatible API endpoints and not the WebSocket connections themselves. In order to exploit this vulnerability, the application ID which, should never be exposed, would need to be known by an attacker.

    • Auf 1.4.0 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2024-51478

    Kritisch · CVSS 9.9EPSS 0,37%Korrektur verfügbar

    Use of a Broken or Risky Cryptographic Algorithm in YesWiki

    YesWiki is a wiki system written in PHP. Prior to 4.4.5, the use of a weak cryptographic algorithm and a hard-coded salt to hash the password reset key allows it to be recovered and used to reset the password of any account. This issue is fixed in 4.4.5.

    • Auf 4.4.5 aktualisieren
    Veröffentlicht Aktualisiert
  8. CVE-2024-34537

    Mittel · CVSS 4.9EPSS 0,71%Korrektur verfügbar

    CVE-2024-34537

    TYPO3 before 13.3.1 allows denial of service (interface error) in the Bookmark Toolbar (ext:backend), exploitable by an administrator-level backend user account via manipulated data saved in the bookmark toolbar of the backend user interface. The fixed versions are 10.4.46 ELTS, 11.5.40 LTS, 12.4.21 LTS, and 13.3.1.

    • Auf 10.4.46 aktualisieren
    • Auf 11.5.40 aktualisieren
    • Auf 12.4.21 aktualisieren
    • Auf 13.3.1 aktualisieren
    Veröffentlicht Aktualisiert
  9. CVE-2024-48228

    Mittel · CVSS 6.1EPSS 0,29%Keine Korrektur veröffentlicht

    CVE-2024-48228

    An issue was found in funadmin 5.0.2. The selectfiles method in \backend\controller\sys\Attachh.php directly stores the passed parameters and values into the param parameter without filtering, resulting in Cross Site Scripting (XSS).

    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →